Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gnome & logout]ca freeze le ridicule
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Ivru
n00b
n00b


Joined: 31 Dec 2006
Posts: 29
Location: [VD]Switzerland

PostPosted: Wed Mar 12, 2008 3:56 pm    Post subject: [gnome & logout]ca freeze le ridicule Reply with quote

Bonjour,
j'ai cherché j'ai pas trouvé de réponse je me permet donc de vous demandez votre aide. j'ai installer gnome-light avec aiglx, compiz-fusion,... et lorsque j'essais de me deloguer (logout) ou de changer d'utilisateur depuis ma session gnome, le système freeze. Je tente un CTRL ALT BACKSPACE, mais ca n'arrange rien : l'écran reste noir, rien ne se passe, je suis obligé d'éteindre à la bourrin.

Du coup je suis obligé de rebooter à chaque fois. Pas terrible.

Vous avez une idée, je suis preneur.
Merci.

Ivru.
_________________
Ivru's LastFM
Back to top
View user's profile Send private message
Dismantr
Apprentice
Apprentice


Joined: 06 Jun 2007
Posts: 201

PostPosted: Wed Mar 12, 2008 4:25 pm    Post subject: Reply with quote

Déjà, il faudrait qu'on sache quelle carte graphique tu utilises, ensuite, nous aurons certainement besoin de ton xorg.conf ; je suis sûr que le problème vient plus de X11+aiglx, et donc de ton xorg, que de quoi que ce soit d'autres ;

Juste avec les infos que tu donnes là, on ne pourra certainement rien te dire... 'faut compléter !

Au passage, laisse moi deviner : tu as une ATI ! ;-)
Back to top
View user's profile Send private message
Ivru
n00b
n00b


Joined: 31 Dec 2006
Posts: 29
Location: [VD]Switzerland

PostPosted: Wed Mar 12, 2008 5:05 pm    Post subject: Reply with quote

Oui j'ai une ATI :) Joie !

Bref, j'ai pas joins mon xorg.conf j'étais pas sur ma machine au moment de la rédaction du post.
Donc, voici mon xorg :

Quote:

Section "ServerLayout"
Identifier "Simple Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
Option "AIGLX" "true"
EndSection

Section "Files"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
Load "dri"
Load "dbe" # Double buffer extension
Load "glx"
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xorg"
Option "XkbModel" "acer_laptop"
Option "XkbLayout" "ch"
Option "XkbVariant" "fr"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Auto" # Auto detect
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "MONITOR"
HorizSync 31.5 - 64.3
VertRefresh 40.0 - 150.0
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Standard VGA"
Driver "vga"
VendorName "Unknown"
BoardName "Unknown"
Option "DRI" "true"
Option "XAANoOffscreenPixmaps" "true"
EndSection

Section "Device"
#VideoRam 65536
# Insert Clocks lines here if appropriate
Identifier "VIDEOCARD"
Driver "radeon"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
EndSection

Section "Screen"
Identifier "Screen 1"
Device "VIDEOCARD"
Monitor "MONITOR"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1400x1050" "1280x1024" "1024x768" "800x600"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Group "video"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


P.S : rien à voir -quoique- mais le défilement des pages sous firefox rame. J'entend par là que lorsque j'appuis sur la fleche du bas pour scroller la page, l'affichage rame (ptit temps mort avant de défiler). Ma carte graphique qui est trop pourrie avec compiz ? Pourtant il me semble qu'à l'époque Beryl + xgl (au lieu d'aiglx) ca allait bien.
_________________
Ivru's LastFM
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Wed Mar 12, 2008 6:07 pm    Post subject: Reply with quote

salut,
Vérifies bien que tu aies gnome-power-manager de lancé dans les programmes au démarrage de ta session (dans préférences/sessions), je l'avais viré au début pensant que cela ne m'était pas nécessaire vu que j'ai un pc de bureau avec tout acpi et apm de désactivé mais je ne pouvais plus me déloggué non plus jusqu'à ce que je le remette....(en revanche je pouvais toujours tuer X avec ctrl+alt+backspace)
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
Ivru
n00b
n00b


Joined: 31 Dec 2006
Posts: 29
Location: [VD]Switzerland

PostPosted: Wed Mar 12, 2008 7:01 pm    Post subject: Reply with quote

Il est bien lancé au démarrage de gnome. A noter que je suis sur un laptop avec l'acpi fonctionnel. Enfin, je pense, j'ai installé gnome-acpi et ma jauge de batterie est correcte. C'est peut être simpliste comme déduction, mais je fait avec mes connaissances limitées :)
_________________
Ivru's LastFM
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Wed Mar 12, 2008 7:28 pm    Post subject: Reply with quote

Au fait je sais pas si tu as essayé avant de poster mais si tu fais une recherche "gnome AND logout" sut le forum il y a pas mal de sujets là dessus... t'as été voir ? :wink:


EDIT: celui par ex https://forums.gentoo.org/viewtopic-t-671396-highlight-gnome+logout.html
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Thu Mar 13, 2008 8:11 am    Post subject: Reply with quote

arrete d'utiliser fglrx, passe au driver libre ... c'est mieux pour le moral et tout le reste :lol: (edit: c'est pas un troll)
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
Ivru
n00b
n00b


Joined: 31 Dec 2006
Posts: 29
Location: [VD]Switzerland

PostPosted: Thu Mar 13, 2008 8:28 am    Post subject: Reply with quote

Ok, ok. J'ai juste installé les drivers proprio en pensant que c'était mieux.
Par contre, quid de compiz et des drivers open sources ? AIGLX fonctionnera toujours (pas regardé, et pas trop le temps là) ?
_________________
Ivru's LastFM
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Thu Mar 13, 2008 8:30 am    Post subject: Reply with quote

Regarde le thread sur "ati nouveau choix du libre" ;) j'ai essayé le driver libre, j'en suis assez content; d'autre ont fait le pas et sont aussi content mais maintenant, tout dépend de ta carte ...
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
SlashRhumSlashNeisson
Apprentice
Apprentice


Joined: 30 Dec 2006
Posts: 200
Location: Lille

PostPosted: Fri Mar 14, 2008 4:48 am    Post subject: Reply with quote

+1 loopx :wink:

De mémoire AIGLX ne fonctionne pas avec les drivers proprio 8O

Confus tes Section Device

J'ai un laptop avec une FireglT2 + driver Libre, je te joins mon Xorg.conf pour info.

Code:

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    #FontPath "unix/:-1"
# RgbPath     "/usr/X11R6/lib/X11/rgb"
# FontPath   "/usr/X11R6/lib/X11/fonts/local/"
#FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
# FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
# FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
# FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
# FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
# FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
    Load "dri"
    Load "drm"
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "fr"
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/psaux"
    Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
    Identifier "monitor1"
    VendorName "Generic"
    ModelName "Flat Panel 1024x768"
    HorizSync 31.5-48.5
    VertRefresh 40-70
EndSection

Section "Device"
    Identifier "device1"
    VendorName "ATI"
    BoardName "FireGLT2"
    Driver "radeon"
    Option "DPMS"
    Option "RenderAccel" "true"
    Option "dri" "true"
    Option      "XAANoOffscreenPixmaps" "true"
EndSection

Section "Screen"
    DefaultColorDepth 24   
    Identifier "screen 1"
    Device "device1"
    Monitor "monitor1"
    DefaultDepth 24
    Option "backingstore" "true"
    Option "AddARGBGLXVisuals" "true"
   
    Subsection "Display"
        Depth 8
        Virtual 1600 1200
    EndSubsection
   
    Subsection "Display"
        Depth 15
        Virtual 1600 1200
    EndSubsection
   
    Subsection "Display"
        Depth 16
        Virtual 1600 1200
    EndSubsection
   
    Subsection "Display"
        Depth 24
        Virtual 1600 1200
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    Option "AIGLX" "true"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen 1"
EndSection

Section "Extensions"
    Option "Composite" "Enable"
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

_________________
Gentoo only
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Fri Mar 14, 2008 7:18 am    Post subject: Reply with quote

SlashRhumSlashNeisson wrote:

De mémoire AIGLX ne fonctionne pas avec les drivers proprio 8O

C'est "censé" être inclus en principe mais en effet: trop foireux pour être utilisable.
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
Ivru
n00b
n00b


Joined: 31 Dec 2006
Posts: 29
Location: [VD]Switzerland

PostPosted: Fri Mar 14, 2008 8:04 am    Post subject: Reply with quote

Bon ben hier soir j'ai craqué, j'ai changé de camp. Je suis faible je suis passé chez xubuntu (bhouuuu). J'en avait marre d'avoir des bugs à répétition. Ca vient pas de gentoo, je pense plus que ca vienne de ma configuration sûrement un peu foireuse.
De plus les Howto sont trop bordeliques à mon goût (trop de contradiction d'un forum/wiki à l'autre) les infos datent parfois de 2 ans, c'est donc assez dur pour un néophyte comme moi de s'y retrouver.

Merci d'avoir su prendre de votre temps pour m'aider, et bonne continuation.
_________________
Ivru's LastFM
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum