Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema compi-fusion
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lordkarolus
n00b
n00b


Joined: 13 Sep 2007
Posts: 30

PostPosted: Mon Mar 10, 2008 10:03 am    Post subject: Problema compi-fusion Reply with quote

Ho installato compiz-fusion da portage solo che quando lo avvio da compiz-start perdo i bordi e non riesco a farglieli prendere in alcun modo...(emerald --replace) come posso fare?
Back to top
View user's profile Send private message
Manwhe
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2007
Posts: 127

PostPosted: Mon Mar 10, 2008 2:25 pm    Post subject: Reply with quote

Ciao,

c'e' una discussione su questo forum

https://forums.gentoo.org/viewtopic-t-566882.html

ti consiglio di dare una lettura , posta anche la tua configurazione :)
Back to top
View user's profile Send private message
lordkarolus
n00b
n00b


Joined: 13 Sep 2007
Posts: 30

PostPosted: Mon Mar 10, 2008 3:55 pm    Post subject: Reply with quote

ho già guardato quella discussione ma non riesco a risolvere nulla...ora mi si avvia compiz però invece che farmi delle ombre mi fai dei bordi bianchi...e ho questo warning
Code:

libGL warning: 3D driver claims to not support visual 0x63

il mio xorg è questo
Code:

Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    #FontPath "unix/:-1"
    FontPath "/usr/share/fonts/TTF"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/75dpi"
    FontPath "/usr/share/fonts/aquafont"
    FontPath "/usr/share/fonts/corefonts"
    FontPath "/usr/share/fonts/default"
    FontPath "/usr/share/fonts/arphicfonts"
    FontPath "/usr/share/fonts/artwiz"
    FontPath "/usr/share/fonts/cheapskatefonts"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/freefont"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/misc"
    FontPath "/usr/share/fonts/ukr"
    FontPath "/usr/share/fonts/sharefonts"
    FontPath "/usr/share/fonts/urw-fonts"
    FontPath "/usr/share/fonts/urwvn-fonts"
    FontPath "/usr/share/fonts/hunkyfonts"
    FontPath "/usr/share/fonts/lfpfonts-fix"
    FontPath "/usr/share/fonts/lfpfonts-var"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    #Option  "Xinerama"  "true"
EndSection

Section "Module"
    Load "dbe"
    Load "dri"
    Load "drm"
    Load "GLcore"
#    Load "v4l"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
    Load "synaptics"
#    Load "record"
#    Load "agpgart"
EndSection

Section "DRI"
    Mode 0666
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "en_US"
    Option "XkbOptions" ""
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5"
    Option "SendCoreEvents" "true"
    Option "Emulate3Buttons" "true"
EndSection

#Section "InputDevice"
#    Identifier "FW-Mouse"
#    Driver "evdev"
#    Option "Protocol" "IMPS/2"
#    Option "Device" "/dev/input/fwmouse"
#    Option "ZAxisMapping" "4 5"
#    Option "SendCoreEvents" "true"
#EndSection

Section "InputDevice"
  Driver        "synaptics"
  Identifier    "touchpad"
  Option        "Device"        "/dev/input/mouse0"
  Option        "Protocol"      "auto-dev"
  Option        "LeftEdge"      "1700"
  Option        "RightEdge"     "5300"
  Option        "TopEdge"       "1700"
  Option        "BottomEdge"    "4200"
  Option        "FingerLow"     "25"
  Option        "FingerHigh"    "30"
  Option        "MaxTapTime"    "180"
  Option        "MaxTapMove"    "220"
  Option        "VertScrollDelta" "100"
  Option        "MinSpeed"      "0.12"
  Option        "MaxSpeed"      "0.24"
  Option        "AccelFactor" "0.0020"
  Option        "SHMConfig"     "on"
#  Option       "Repeater"      "/dev/ps2mouse"
EndSection

Section "Monitor"
    Identifier "LCD"
    VendorName "Generic"
    ModelName "lcd"
EndSection

Section "Device"
    Identifier "device0"
    Driver "i810"
    Option "DPMS"
    Screen   0
Option          "XAANoOffscreenPixmaps" "true"
EndSection

Section "Screen"
    Identifier      "screen0"
    Device          "device0"
    Monitor         "LCD"
    DefaultDepth    24

    SubSection "Display"
        Depth     16
        Modes   "1024x768" "800x600" "640x480"
    EndSubSection
 
    SubSection "Display"
        Depth     24
        Modes   "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "touchpad" "CorePointer"
    InputDevice "Mouse1"
    Screen 0 "screen0" 0 0
    Option "AIGLX" "true"
EndSection

Section "Extensions"
    Option "Composite" "true"
EndSection

Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Mon Mar 10, 2008 10:16 pm    Post subject: Reply with quote

La migliore opzione per far andare compiz-fusion è installare la fusion-icon, nella discussione che ti ha linkato manwhe trovi l'ebuild da copiare nel tuo overlay locale, è semplice e immediato. Io ho fatto così e non ho nessun problema.
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Fri Mar 14, 2008 3:46 pm    Post subject: Reply with quote

riverdragon wrote:
La migliore opzione per far andare compiz-fusion è installare la fusion-icon, nella discussione che ti ha linkato manwhe trovi l'ebuild da copiare nel tuo overlay locale, è semplice e immediato. Io ho fatto così e non ho nessun problema.

Concordo pienamente, fusion-icon è ottimo. Inoltre er quanto riguarda i bordi bisogna dare un'occhiata anche al Windows Decorator.. che sia attivo prima di tutto.
Per la fusion-icon devi far sì che si avvii ad ogni avvio di kde.. ma anche di questo se ne è parlato nell'altra discussione.

ciao
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Mon Mar 17, 2008 8:21 pm    Post subject: Reply with quote

ciao, io invece ho un problema diverso...
quando avvio compiz esso parte senza problemi e manifesta anche una discreta fluidità, peccato però che venfanp creati dei bordi ad ogni menu e pannello, che rendono il tutto davvero insopportabile (uno screen). usavo su ubuntu la versione 0.3 di compiz (quando era ancora un progetto a sè) e funzionava benone benchè xorg non fosse configurato ad hoc come quello attuale, che credo di aver riscritto discretamente:
Quote:
Section "Module"
Load "dbe" # Double buffer extension
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
Load "freetype"
Load "glx"
Load "dri"
EndSection

Section "Files"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
Identifier "Mouse1"
# Driver "mouse"
# Option "Protocol" "Auto" # Auto detect
# Option "Device" "/dev/input/mice"
# Option "ZAxisMapping" "4 5 6 7"
# Option "Emulate3Buttons" "true"
Driver "evdev"
Option "Device" "/dev/input/event5"
Option "Name" "PS/2+USB Mouse"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "TouchPad"
Option "SendCoreEvents"
Option "Protocol" "auto-dev"
Option "SHMConfig" "on"
EndSection

Section "Monitor"
Identifier "Monitor Notebook"
HorizSync 31.5 - 64.3
VertRefresh 50-70
EndSection

Section "Device"
Identifier "Standard VGA"
VendorName "Unknown"
BoardName "Unknown"
Driver "vga"
Option "AddARGBGLXVisuals" "true"
Option "XAANoOffscreenPixmaps" "1"
EndSection

Section "Device"
Identifier "Ati Radeon 9100IGP"
Driver "radeon"
VideoRam 65536
Option "AGPMode" "4"
Option "EnablePageFlip" "True"
Option "AddARGBGLXVisuals" "true"
Option "XAANoOffscreenPixmaps" "1"
EndSection

Section "Screen"
Identifier "Screen 1"
Device "Ati Radeon 9100IGP"
Monitor "Monitor Notebook"
DefaultDepth 24

Subsection "Display"
Depth 24
Modes "1280x800" "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

#Section "ServerLayout"
# Screen "Screen 1"
# InputDevice "Mouse1" "CorePointer"
# InputDevice "Keyboard1" "CoreKeyboard"
#EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

qualcuno è in grado di dirmi come tentare di risolvere? le impostazioni in Device credo siano adatte, ho provato anche ad alternarle, cancellarle, editarle, ma nada, il risultato è lo stesso. Le prime due mi servono piu che altro per sfruttare il meglio possibile la scheda, anche se sinceramente a volte gli fps risultano maggiori, a volte no, ma credo sia irrilevante in quanto sono stringhe che potrò adattare in base alle mie esigenze.
Quote:
Option "AGPMode" "4"
Option "EnablePageFlip" "True"
Option "AddARGBGLXVisuals" "true"
Option "XAANoOffscreenPixmaps" "1"

Mi sono già assicurato che i bordi non fossero qualche effetto particolare impostato da compiz stesso. il file che uso per avviare compiz è questo:
Quote:
if [ ! -x /usr/bin/glxinfo ]; then
echo "glxinfo not found, please install mesa-progs."
exit -1
fi

GLX_WITH_DIRECT=`glxinfo|grep -c GLX_EXT_texture_from_pixmap`
GLX_WITH_INDIRECT=`LIBGL_ALWAYS_INDIRECT=1 glxinfo|grep -c GLX_EXT_texture_from_pixmap`
GLX_RENDER=`glxinfo|grep -c "OpenGL renderer string: Mesa GLX Indirect"`


COMPIZ_OPTIONS="--replace"

if [ $GLX_WITH_DIRECT -eq 3 ]; then
if [ $GLX_RENDER -eq 0 ]; then
echo NVIDA detected
export __GL_YIELD="NOTHING"
else
echo XGL detected
fi
elif [ $GLX_WITH_INDIRECT -eq 3 ]; then
echo AIGLX detected
export LIBGL_ALWAYS_INDIRECT=1
fi

if [ ! -z $KDE_FULL_SESSION ] && [ -x /usr/bin/kde-window-decorator ]; then
echo Using KDE decorator
kde-window-decorator --replace &
else
echo Using GTK decorator
gtk-window-decorator --replace &
fi

#compiz $COMPIZ_OPTIONS gconf move resize minimize place decoration wobbly fade cube rotate scale switcher zoom dbus
compiz $COMPIZ_OPTIONS ccp

_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Wed Mar 19, 2008 1:59 am    Post subject: Reply with quote

un altro screen per capire meglio la situazione... http://bp2.blogger.com/_j--Rhjzc_-c/R-BsUEnsHII/AAAAAAAAAUI/JuWyXOeMoJg/s1600-h/Schermata.png
nessuno ha qualche idea?
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Fri Mar 21, 2008 9:51 am    Post subject: Reply with quote

ho risolto, come pensavo era un problema di ombre. per rimediare sono entrato nelle configurazioni del gestore finestre di compiz ed ho impostato le voci Decoration windows e Shadow windows a Normal piuttosto che a Any
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum