Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved][Compiz & emerald] besoin d'aide (pour changer)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Ivru
n00b
n00b


Joined: 31 Dec 2006
Posts: 29
Location: [VD]Switzerland

PostPosted: Sun Mar 09, 2008 11:00 am    Post subject: [solved][Compiz & emerald] besoin d'aide (pour changer) Reply with quote

Bonjour,
je viens d'installer compiz-fusion sur mon portable. J'ai une ATI radeon mobility 9500, j'ai donc installé les derniers drivers ati 8.455.2-r1. direct rendering OK, aiglx OK (xgl n'existe plus et les derniers drivers ati semblent supporter aiglx).
installation de compiz OK, par contre mon problème c'est que dès que je lance compiz je n'ai plus aucun gestionnaire de fenetres. J'ai configuré compiz en précisant "emerald --replace" dans le champs commande du windows manager, mais toujours rien (aucune bordure, et impossible de selectionner une fenetre : aucun focus apparemment). J'ai également essayé avec gtk-windows-manager --replace (suis sous gnome), mais rien n'y fait.
J'ai également tenté de lancé compiz en utilisant --loose-binding, en définissant la varaible LIBGL_ALWAYS_INDIRECT à 1, mais toujours rien...

bref, j'ai eu la bonne idée d'enregistrer ma session avant de quitter et maintenant ma session gnome est inutilisable (plus de bordure sur aucune fenetres et ce, même si j'enlève la sauvegarde automatique de la session). Par contre, une fois compiz lancé, mis a part ce problème de gestionnaire de fenetre, ca marche : je peux faire tourner mon cube par exemple.

Voila, si vous avez une piste je preneur.

P.S : je vous met pas mon xorg.conf puisque je suis sur un autre PC pour ecrire ce message...
_________________
Ivru's LastFM


Last edited by Ivru on Sun Mar 09, 2008 3:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3084
Location: Paris

PostPosted: Sun Mar 09, 2008 11:07 am    Post subject: Reply with quote

C'est un problème archi classique: regarde le wiki gentoo (la solution que j'ai choisi), et fait une recherche sur le fofo gentoo FR, me rappelle avoir vu d'autres solutions.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Ivru
n00b
n00b


Joined: 31 Dec 2006
Posts: 29
Location: [VD]Switzerland

PostPosted: Sun Mar 09, 2008 11:13 am    Post subject: Reply with quote

Le problème c'est que justement en faisant toute les manip présentes dans les howto ca ne marche toujours pas. ca fait 1 semaine que je tente en fouillant sur les wiki et forum, mais ne trouvant pas comment résoudre le problème je viens poster ici.

EDIT : Bon ok, j'ai trouvé. Faut lancer emerald --replace avant le lancement de compiz. Il faut également rajouter plusieurs plugins pour pouvoir, par exemple, bouger les fenetres.
_________________
Ivru's LastFM
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum