Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Kernel Panic] Après Réinstallation Vista (Résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Animatrix
Guru
Guru


Joined: 13 May 2006
Posts: 480
Location: France - Gard (30)

PostPosted: Sun Mar 09, 2008 2:15 am    Post subject: [Kernel Panic] Après Réinstallation Vista (Résolu) Reply with quote

Bonjour à tous !!

J'ai du réinstaller Windows Vista sur mon pc ([trollet oui, il aura pas tennu le coup ![/troll]).
AU passage, il a profiter pour me supprimer (temporairement quelques partitions notamment mon / et mon /boot).

J'ai réussi avec testdisk à récupérer mes partitions.
Mais, chose étrange la numérotation a changé. Par ex : mon / est passé du /dev/sda8 au /dev/sda5.
J'ai donc modifié en conséquence mon /etc/fstab et mon /boot/grub/grub.conf.

Seulement depuis, quand je boote sur ma Gentoo, j'ai droit à un beau kernel panic.

Voici le message d'erreur :

Quote:
ocfs2_fill_super : superblock probe failed !
Kernel panic _ Not syncing : VFS : unable to mount root fs on unknown-bloc (8,8)


J'ai tenté un fsck sur les partitions mais rien n'a changé.
Pourtant j'arrive bien à chrooter dessus.

J'avais peut-etre penser à recompiler mon kernel, solution viable ?
Ou Gentoo morte ?

Merci à tous pour votre aide :)


Last edited by Animatrix on Sun Mar 09, 2008 11:58 am; edited 1 time in total
Back to top
View user's profile Send private message
Untux
Apprentice
Apprentice


Joined: 10 Apr 2006
Posts: 285

PostPosted: Sun Mar 09, 2008 11:21 am    Post subject: Reply with quote

Pas de soluce clef en main mais, ce qui m'étonne, c'est le ocfs2... est-ce que ta racine est en OCFS2 ? Sinon, es-tu certain d'avoir désigné le bon "root=" à Grub ?... d'autant que, si je ne m'abuse, testdisk ne sait pas gérer l'ocfs, donc je vois pas ce qu'il vient faire dans cette histoire...

En espérant que mon étonnement puisse t'être utile,
Bonne chance.
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Sun Mar 09, 2008 11:28 am    Post subject: Reply with quote

Je ne vois pas particulièrement ce qui ne vas pas mais la règle d'or en multiboot est de toujours partitionner/formatter
à partir de linux car l"autre" os a tendance à faire cela comme un porcinet...
Back to top
View user's profile Send private message
Animatrix
Guru
Guru


Joined: 13 May 2006
Posts: 480
Location: France - Gard (30)

PostPosted: Sun Mar 09, 2008 11:40 am    Post subject: Reply with quote

dapsaille wrote:
Je ne vois pas particulièrement ce qui ne vas pas mais la règle d'or en multiboot est de toujours partitionner/formatter
à partir de linux car l"autre" os a tendance à faire cela comme un porcinet...

Je n'y avais pas pensé (du moins, je ne pensais pas que l'installateur de Windows était aussi désastreux.

[quote="Untux"]Pas de soluce clef en main mais, ce qui m'étonne, c'est le ocfs2... est-ce que ta racine est en OCFS2 ? Sinon, es-tu certain d'avoir désigné le bon "root=" à Grub ?... d'autant que, si je ne m'abuse, testdisk ne sait pas gérer l'ocfs, donc je vois pas ce qu'il vient faire dans cette histoire...

En espérant que mon étonnement puisse t'être utile,
Bonne chance.[quote]
Je viens de faire un fsck.reiserfs --rebuild-tree sur mon /
Mais je viens de voir mon grub.conf, je pense que l'erreur vient de la (je me suis trompé en indiquant /dev/sda6, au lieu de /dev/sda5 pour root)


Edit : le problème venait de là.....
Erreur c*n par excellence.
En tout cas, testdisk est un très bon outil :)

ET vive Gentoo ! :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum