Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200803-10 ] lighttpd: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Wed Mar 05, 2008 9:26 pm    Post subject: [ GLSA 200803-10 ] lighttpd: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: lighttpd: Multiple vulnerabilities (GLSA 200803-10)
Severity: normal
Exploitable: remote
Date: March 05, 2008
Bug(s): #211230, #211956
ID: 200803-10

Synopsis

Multiple vulnerabilities have been discovered in lighttpd.

Background

lighttpd is a lightweight high-performance web server.

Affected Packages

Package: www-servers/lighttpd
Vulnerable: < 1.4.18-r2
Unaffected: >= 1.4.18-r2
Architectures: All supported architectures


Description

lighttpd contains a calculation error when allocating the global file descriptor array (CVE-2008-0983). Furthermore, it sends the source of a CGI script instead of returning a 500 error (Internal Server Error) when the fork() system call fails (CVE-2008-1111).

Impact

A remote attacker could exploit these vulnerabilities to cause a Denial of Service or gain the source of a CGI script.

Workaround

There is no known workaround at this time.

Resolution

All lighttpd users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/lighttpd-1.4.18-r2"


References

CVE-2008-0983
CVE-2008-1111
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum