Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel panic - not syncing: Attempted to kill init!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
senz
n00b
n00b


Joined: 12 Jan 2005
Posts: 19
Location: Frankfurt

PostPosted: Wed Mar 05, 2008 5:44 pm    Post subject: Kernel panic - not syncing: Attempted to kill init! Reply with quote

hey there,

i just installed gentoo on a rented root-server and upon first boot
of the new kernel i get
Code:
Kernel panic - not syncing: Attempted to kill init!


find here the complete log of the boot process:

http://pastebin.com/m625f9e19
Back to top
View user's profile Send private message
senz
n00b
n00b


Joined: 12 Jan 2005
Posts: 19
Location: Frankfurt

PostPosted: Wed Mar 05, 2008 7:37 pm    Post subject: Reply with quote

think ive found the solution:

Quote:

On Tue, Mar 04, 2008 at 10:43:12AM -0800, Andrew Morton wrote:
> Isn't the device-mapper kernel code capable of detecting the older userspace
> version and loudly warning about it? That at least would prevent us from
> wasting lots of people's time like this.

It's not a device-mapper problem: It's between userspace LVM2 and kernel
sysfs.

LVM2 userspace expects a particular sysfs layout. That layout got
changed without offering sufficient lead time (>6-9 months) for the
required userspace changes to propagate into the main versions of the
distros people use.

LVM2 userspace version 2.02.29 (released 5th December 2007) can handle
old and new layouts. The patch was in the CVS head for a while before
that. Earlier versions of LVM2 require CONFIG_SYSFS_DEPRECATED. A
less-efficient workaround is to disable the use of sysfs in the LVM2
config: 'devices { sysfs_scan = 0 }'.
(I think the root cause of this mess was changing what
CONFIG_SYSFS_DEPRECATED did instead of adding a new setting that could
be enabled by default.)

Alasdair
--
agk@redhat.com
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum