Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
compiz-fusion (xorg.conf problem?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fnietzsche
n00b
n00b


Joined: 29 Feb 2008
Posts: 27

PostPosted: Mon Mar 03, 2008 9:54 pm    Post subject: compiz-fusion (xorg.conf problem?) Reply with quote

Now I have my xorg up and running I installed the compiz-fusion package (not the one from the overlay but the stable one). I followed the howto on the gentoo wiki, When I try to start it I get the following:

Code:

fnietzsche@spud ~ $ compiz-start
XGL detected
Using GTK decorator
compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0


After this my toolbars are on the place of the normal bar at the top from which you launch the applications and the only way to get everything normal again I need to reboot my laptop again. Does anybody know what could be the cause of this? I did everything from the howto, searching only doesn't help much either
Back to top
View user's profile Send private message
mardicas
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2008
Posts: 112
Location: Tallinn

PostPosted: Mon Mar 03, 2008 10:44 pm    Post subject: Reply with quote

What video card are you using and what drivers.
_________________
http://mardicas.dyndns.org
Back to top
View user's profile Send private message
fnietzsche
n00b
n00b


Joined: 29 Feb 2008
Posts: 27

PostPosted: Tue Mar 04, 2008 7:47 am    Post subject: Reply with quote

I'm having a 'ATI Technologies, Inc. Radeon Mobility 9600/9700 M10/M11 (RV350 NP)' in my laptop with 128megs of ram, and the driver I'm using is the 'fglrx' (the closed source driver). This is the current xorg.conf I have;

Code:

Section "ServerLayout"
        Identifier      "X.Org Configured"
        Screen  0       "Screen0" 0 0
        InputDevice     "Keyboard0" "CoreKeyboard"
        InputDevice     "PS/2 Mouse" "AlwaysCore"
        InputDevice     "USB Mouse" "AlwaysCore"
        InputDevice     "Synaptics" "AlwaysCore"
EndSection

Section "ServerFlags"
        Option  "AllowMouseOpenFail" "true"

EndSection

Section "Files"
        FontPath        "/usr/share/fonts/util"
        FontPath        "/usr/share/fonts/encodings"
        FontPath        "/usr/share/fonts/misc"
        FontPath        "/usr/share/fonts/local"
        FontPath        "/usr/share/fonts/terminus"
        FontPath        "/usr/share/fonts/corefonts"
        FontPath        "/usr/local/share/fonts"
        FontPath        "/usr/share/fonts/default"
        FontPath        "/usr/share/fonts/TTF"
        FontPath        "/usr/share/fonts/type1"
        FontPath        "/usr/share/fonts/100dpi"
        FontPath        "/usr/share/fonts/75dpi"
        FontPath        "/usr/share/fonts/arphicfonts"
        FontPath        "/usr/share/fonts/jisx0213"
        FontPath        "/usr/share/fonts/shinonome"
        FontPath        "/usr/share/fonts/baekmuk-fonts"
        FontPath        "/usr/share/fonts/kacst-fonts"
        FontPath        "/usr/share/fonts/sgi-fonts"
        FontPath        "/usr/share/fonts/unfonts"
        FontPath        "/usr/share/fonts/default/ghostscript"
        FontPath        "/usr/share/fonts/xfonts-cronyx-100dpi:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-75dpi:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-misc:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-100dpi"
        FontPath        "/usr/share/fonts/xfonts-cronyx-75dpi"
        FontPath        "/usr/share/fonts/xfonts-cronyx-misc"
        FontPath        "/usr/share/fonts/xfonts-cronyx-cp1251-100dpi:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-cp1251-75dpi:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-cp1251-misc:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-cp1251-100dpi"
        FontPath        "/usr/share/fonts/xfonts-cronyx-cp1251-75dpi"
        FontPath        "/usr/share/fonts/xfonts-cronyx-cp1251-misc"
        FontPath        "/usr/share/fonts/xfonts-cronyx-isocyr-100dpi:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-isocyr-75dpi:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-isocyr-misc:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-isocyr-100dpi"
        FontPath        "/usr/share/fonts/xfonts-cronyx-isocyr-75dpi"
        FontPath        "/usr/share/fonts/xfonts-cronyx-isocyr-misc"
        FontPath        "/usr/share/fonts/xfonts-cronyx-koi8r-100dpi:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-koi8r-75dpi:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-koi8r-misc:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-koi8r-100dpi"
        FontPath        "/usr/share/fonts/xfonts-cronyx-koi8r-75dpi"
        FontPath        "/usr/share/fonts/xfonts-cronyx-koi8r-misc"
        FontPath        "/usr/share/fonts/xfonts-cronyx-koi8u-100dpi:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-koi8u-75dpi:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-koi8u-misc:unscaled"
        FontPath        "/usr/share/fonts/xfonts-cronyx-koi8u-100dpi"
        FontPath        "/usr/share/fonts/xfonts-cronyx-koi8u-75dpi"
        FontPath        "/usr/share/fonts/xfonts-cronyx-koi8u-misc"
EndSection

Section "Module"
        Load    "ddc"
        Load    "vbe"
        Load    "GLcore"
        Load    "dbe"
        Load    "dri"
        Load    "extmod"
        Load    "glx"
        Load    "bitmap"
        Load    "type1"
        Load    "freetype"
        Load    "record"
EndSection

Section "InputDevice"
        Identifier      "Keyboard0"
        Driver  "kbd"
        Option  "CoreKeyboard"
        Option  "XkbRules" "xorg"
        Option  "XkbModel" "pc105"
        Option  "XkbVariant" ",winkeys"
EndSection

Section "InputDevice"
        Identifier      "Serial Mouse"
        Driver  "mouse"
        Option  "Protocol" "Microsoft"
        Option  "Device" "/dev/ttyS0"
        Option  "Emulate3Buttons" "true"
        Option  "Emulate3Timeout" "70"
        Option  "SendCoreEvents"  "true"
EndSection

Section "InputDevice"
        Identifier      "PS/2 Mouse"
        Driver  "mouse"
        Option  "Protocol" "IMPS/2"
        Option  "Device" "/dev/misc/psaux"
        Option  "Emulate3Buttons" "true"
        Option  "Emulate3Timeout" "70"
        Option  "SendCoreEvents"  "true"
        Option  "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
        Identifier      "USB Mouse"
        Driver  "mouse"
        Option  "Device" "/dev/input/mice"
        Option  "SendCoreEvents" "true"
        Option  "Protocol" "IMPS/2"
        Option  "ZAxisMapping" "4 5"
        Option  "Buttons" "5"
EndSection

Section "InputDevice"
        Identifier      "Synaptics"
        Driver  "synaptics"
        Option  "Protocol" "event"
        Option  "Device" "/dev/input/event1"
        Option  "LeftEdge" "1900"
        Option  "RightEdge" "5400"
        Option  "TopEdge" "1900"
        Option  "BottomEdge" "4000"
        Option  "FingerLow" "25"
        Option  "FingerHigh" "30"
        Option  "MaxTapTime" "180"
        Option  "MaxTapMove" "220"
        Option  "VertScrollDelta" "100"
        Option  "MinSpeed" "0.02"
        Option  "MaxSpeed" "0.10"
        Option  "AccelFactor" "0.0010"
        Option  "SHMConfig" "on"
EndSection

Section "Monitor"

    Identifier  "Jewel Jade 8080"
        HorizSync    28.0 - 96.0
        VertRefresh  50.0 - 75.0
EndSection

Section "Device"
        Identifier "ATI Technologies, Inc. Radeon Mobility 9600/9700 M10/M11 (RV350 NP)"
        Driver "fglrx"
        BusID "PCI:1:0:0"

        Option "no_accel" "no"
        Option "no_dri" "no"
        Option "mtrr" "off"
        Option "DesktopSetup" "0x00000100"
        Option "MonitorLayout" "AUTO, NONE"
        Option "IgnoreEDID" "off"
        Option "HSync2" "unspecified"
        Option "VRefresh2" "unspecified"
        Option "ScreenOverlap" "0"
        Option "NoTV" "no"
        Option "TVStandard" "PAL-B"
        Option "TVHSizeAdj" "0"
        Option "TVVSizeAdj" "0"
        Option "TVHPosAdj" "0"
        Option "TVVPosAdj" "0"
        Option "TVHStartAdj" "0"
        Option "TVColorAdj" "0"
        Option "GammaCorrectionI" "0x00000000"
        Option "GammaCorrectionII" "0x00000000"
        Option "Capabilities" "0x00000000"
        Option "VideoOverlay" "on"
        Option "OpenGLOverlay" "off"
        Option "CenterMode" "off"
        Option "PseudoColorVisuals" "off"
        Option "Stereo" "off"
        Option "StereoSyncEnable" "1"
        Option "FSAAEnable" "no"
        Option "FSAAScale" "1"
        Option "FSAADisableGamma" "no"
        Option "FSAACustomizeMSPos" "no"
        Option "FSAAMSPosX0" "0.000000"
        Option "FSAAMSPosY0" "0.000000"
        Option "FSAAMSPosX1" "0.000000"
        Option "FSAAMSPosY1" "0.000000"
        Option "FSAAMSPosX2" "0.000000"
        Option "FSAAMSPosY2" "0.000000"
        Option "FSAAMSPosX3" "0.000000"
        Option "FSAAMSPosY3" "0.000000"
        Option "FSAAMSPosX4" "0.000000"
        Option "FSAAMSPosY4" "0.000000"
        Option "FSAAMSPosX4" "0.000000"
        Option "FSAAMSPosY4" "0.000000"
        Option "FSAAMSPosX5" "0.000000"
        Option "FSAAMSPosY5" "0.000000"

        Option "UseFastTLS" "0"
        Option "BlockSignalsOnLock" "on"
        Option "UseInternalAGPGART" "no"
        Option "ForceGenericCPU" "no"

EndSection

Section "Extensions"
        Option "Composite" "Enable"
EndSection


Section "Screen"
        Identifier      "Screen0"
        Device  "ATI Technologies, Inc. Radeon Mobility 9600/9700 M10/M11 (RV350 NP)"
        Monitor "Jewel Jade 8080"
        DefaultColorDepth 24
        SubSection "Display"
                Depth   1
                Modes "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth   4
                Modes "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth   8
                Modes "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth   15
                Modes "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth   16
                Modes "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth   24
                Modes "1400x1050" "1280x1024" "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
                Depth   32
                Modes "1400x1050" "1280x1024" "1024x768" "800x600"
        EndSubSection
EndSection

Section "DRI"
        Mode 0666
EndSection
Back to top
View user's profile Send private message
mardicas
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2008
Posts: 112
Location: Tallinn

PostPosted: Tue Mar 04, 2008 9:25 pm    Post subject: Reply with quote

Something is funky witht his cofnig, it seems to me that you have some unneeded modules and something is missing, take antoher look at the wiki.
_________________
http://mardicas.dyndns.org
Back to top
View user's profile Send private message
fnietzsche
n00b
n00b


Joined: 29 Feb 2008
Posts: 27

PostPosted: Wed Mar 05, 2008 1:00 pm    Post subject: Reply with quote

which wiki did you mean the one with the install howto? I followed that one precisely.
Back to top
View user's profile Send private message
mardicas
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2008
Posts: 112
Location: Tallinn

PostPosted: Wed Mar 05, 2008 4:34 pm    Post subject: Reply with quote

http://gentoo-wiki.com/Compiz

This one.
_________________
http://mardicas.dyndns.org
Back to top
View user's profile Send private message
fnietzsche
n00b
n00b


Joined: 29 Feb 2008
Posts: 27

PostPosted: Wed Mar 05, 2008 9:13 pm    Post subject: Reply with quote

Yups followed that one, still get the same error; tried searching the web more and found this:

http://dev.compiz-fusion.org/~cyberorg/2007/11/23/ati-84337-11-on-opensuse-howto/

I know it is for opensuse but I thought it might help, but still no succes :-( anything else that could be going wrong?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum