Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problema icone con gnome [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Tue Mar 04, 2008 2:58 pm    Post subject: problema icone con gnome [RISOLTO] Reply with quote

spero sia l'ultimo problema e soprattutto spero di risolverlo... da ieri sono praticamente rimasto senza icone!!! mi spiego, awn e i menu hanno le loro solite icone, ma se provo a creare un lanciatore (ad esempio) non posso assegnargli alcuna icona... in /usr/share/pixmaps sono presenti i vari file, posso aprirli come fossero semplici immagini, ma ognuno di loro dovrei visualizzarlo esattamente come l'icona che rappresenta, mentre non è così.... si vede solo il piedone di gnome... spero di essermi spiegato...

alla fin della fiera mi ritrovo senza l'icona di firefox sul desktop (viene aperto il file come testo) e non so che fare...

anche gli archivi ad esempio non funzionano bene... se vi clicco col destro non mi permette di estrarli, non vengono indicati con le loro icone ma col piedone di gnome...ho anche provato a cambiare tema ma non dipende da quello...

le mie USE sono queste
Code:
USE="unicode mad ffmpeg win32codecs vorbis mp3 gstreamer nls glitz ogg dbus hal avahi -arts -debug X xorg gtk gnome -qt3 -qt4 -kde -cups gdm jpeg png gif midi svg -doc"

l'unica operazione che ho fatto prima che accadesse tutto ciò è stato unmergere un'applicazione, ovvero oregano...


vorrei poter ritornare alla perfezione di prima senza reinstallare oregano possibilmente....
_________________
spillo

GnuLinuxExperience

Il mio blog! :)


Last edited by spillo on Wed Mar 05, 2008 8:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Tue Mar 04, 2008 7:26 pm    Post subject: Re: problema icone con gnome Reply with quote

ragazzi dopo aver ricompilato inutilmente mezzo mondo sono arrivato alla conclusione che dovrebbe bastare riemergere gnome-themes e gnome-icons-theme con le adeguate flag USE per risolvere il problema... dato che ho avuto accesso fisico al pc (che non ha il desktop remoto attivo) solo per pochi secondi e io sto lavorando tramite ssh aspetto ad aggiungere il tag risolto, voglio prima verificare che tutto sia tornato alla normalità.

quello che mi chiedo è come possa esser successo ciò... :/
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Tue Mar 04, 2008 9:50 pm    Post subject: Reply with quote

scusate il triplo post in una giornata, ma la questione è in continuo aggiornamento e non posso far a meno di ripostare per riattirare l'attenzione al topic...


insomma tutto risolto eccetto una cosa: le immagini png non me le apre almeno che l'estensione non sia scritta in maiuscolo... come mai? come ovviare visto che qualsiasi applicativo salva con i nomi in minuscolo?
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Wed Mar 05, 2008 2:19 pm    Post subject: Reply with quote

Cosa vuol dire "non te le apre"? Se con il clic destro vai su Proprietà e poi nella scheda Apri con, che vedi?
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Wed Mar 05, 2008 6:06 pm    Post subject: Reply with quote

spillo wrote:
scusate il triplo post...

non c'è molto da scusare... le linee guida lo vietano,se hai altro da aggiungere appendi al post precedente.

la domanda posta da riverdragon è forse la prima cosa da controllare, in ogni caso nessuno qui ha la sfera di cristallo. più informazioni dai più le risposte possono essere mirate alla soluzione del problema.
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Wed Mar 05, 2008 7:04 pm    Post subject: Reply with quote

non ho potuto spiegare prima con perfezione il problema perchè non ho sempre accesso fisico al pc purtroppo... :/

comunque, in poche parole: il doppio click su un'immagine png produce il seguente messaggio di errore:
Code:
Il nome del file «Firefox_wallpaper.png» indica che si tratta di un file di tipo «Documento png», ma il suo contenuto indica che è del tipo «Immagine PNG». L'apertura di questo file potrebbe rappresentare un rischio per la sicurezza del sistema in uso.

È consigliabile non aprire il file se non lo si è personalmente creato o non è stato ricevuto da una sorgente fidata. Per poter aprire il file normalmente, rinominarlo con la corretta estensione per il tipo «Immagine PNG». Alternativamente usare il menù «Apri con» per scegliere una specifica applicazione per il file.

per ovviare al problema posso rinominare il file riscrivendo in maiuscolo (o in minuscolo, a seconda di come è già) l'estensione ogni volta che voglio accedervi, oppure cliccarvi sopra col tasto destro del mouse e scegliere la voce apri con visualizzatore di immagini.

Quote:
Se con il clic destro vai su Proprietà e poi nella scheda Apri con, che vedi?

ovviamente ho già controllato ed è settato giustamente per essere aperto col visualizzatore di immagini.
Ho provato anche a ricompilare eog, ma senza risultati...

Io ipotizzo che il problema possa esser di nautilus, ho provato anche a dare un'occhiata al gconf-editor, ma non ho trovato ciò che mi interessa... dico ciò perchè se tento di aprire le stesse immagini attraverso l'applet di AWN che mi permette di esplorare le cartelle non riscontro alcun problema...

qualche idea?
intanto grazie per le risposte :)
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Wed Mar 05, 2008 7:22 pm    Post subject: Reply with quote

questa è la prima cosa che ho trovato cercando con google "indica che si tratta di un file di tipo": http://elihh.wordpress.com/2007/11/10/impossibile-aprire-file-png/

EDIT: in alternativa potresti provare a rinominare .local nella tua home?
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Wed Mar 05, 2008 7:26 pm    Post subject: Reply with quote

non vengo certo a postare sul forum senza aver almeno una volta cercato su google ;)
ho già seguito quel piccolo tutorial, ma per prima cosa non ho trovato la stringa di cui parla l'autore. ho quindi provato a crearla io ma la situazione non cambia...

:)
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Wed Mar 05, 2008 8:09 pm    Post subject: Reply with quote

ed anche rinominare la dir nella home non sortisce alcun effetto?
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Wed Mar 05, 2008 8:27 pm    Post subject: Reply with quote

non avevo letto l'edit... così effettivamente ho risolto, però non mi spiego il motivo per cui è nato il problema...

esplorando la vecchia .local noto il file x-extension-png.xlm e credo sia lui a gestire quella finestra d'errore, almeno deduco da delle pagine lette oggi per il web che trattavano un problema simile... come può esser stato creato questo file? potrebbe esser nato come conseguenza di qualche installazione?

intanto grazie mille per l'aiuto, aggiungo risolto al titolo, ma vorrei cercare se possibile un motivo al problema... :)
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Wed Mar 05, 2008 8:48 pm    Post subject: Reply with quote

purtroppo non so dirti il motivo, sarebbe carino vedere il contenuto del file.
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Wed Mar 05, 2008 8:54 pm    Post subject: Reply with quote

che stupido, l'avevo anche copiato e poi non l'ho incollato nel post... -.-
comunque il file si trovava, per la precisione, in .local/share/mime/application
Code:
<?xml version="1.0" encoding="utf-8"?>
<mime-type xmlns="http://www.freedesktop.org/standards/shared-mime-info" type="application/x-extension-png">
  <!--Created automatically by update-mime-database. DO NOT EDIT!-->
  <comment>Documento png</comment>
</mime-type>

se sai ipotizzare qualche motivo bene, altrimenti pazienza ;)
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Wed Mar 05, 2008 8:59 pm    Post subject: Reply with quote

non saprei, a vederlo così non è che dica molto. comunque... sei sicuro che sia proprio lui a creare il problema? nel senso: se sposti solo quel file tutto funziona? se lo rimetti smette di funzionare?
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Wed Mar 05, 2008 9:22 pm    Post subject: Reply with quote

in verità anche se rimetto la cartella mime il tutto sembra funzionare per ora, però il nuovo local non contiene proprio quella cartella quindi immagino sia superflua...

ripeto, quelle che sto postando sono ipotesi eh! ;)
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum