Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gentookit] equery list
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
mcsky2
Guru
Guru


Joined: 25 Aug 2005
Posts: 307

PostPosted: Sat Mar 01, 2008 8:26 am    Post subject: [gentookit] equery list Reply with quote

Bonjour,
J'ai decouvert qu'avec la commande "equery list", on avait la liste complete des packages installés sur sa gentoo.
Je me suis apercu que lorsqu'il y a un [M ], cela signifiait que le package n'existait plus ou n'a pas été mis a jour.
Je voudrais avoir la liste des packages ayant cette marque. Seulement lorsque je veux travailler avec equery ce marquage n'existe pas.
Merci d'avance pour vos reponses
Back to top
View user's profile Send private message
Trapamoosch
Apprentice
Apprentice


Joined: 08 May 2004
Posts: 203

PostPosted: Sat Mar 01, 2008 8:54 am    Post subject: Reply with quote

Je comprends pas bien ce que tu veux dire mais je tente quand même.
Si tu fais
Code:
equery list > liste
en effet le marquage n'apparaît pas dans le fichier créé.

Il faut faire
Code:
equery -N list > liste
et là il y est.

C'était ça la question ?
Back to top
View user's profile Send private message
mcsky2
Guru
Guru


Joined: 25 Aug 2005
Posts: 307

PostPosted: Sat Mar 01, 2008 9:34 am    Post subject: Reply with quote

Oui c'est tout a fait ca.
Que signifie le tiret pour par exemple : [ -] sys-devel/gcc-4.1.2 (4.1)
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sat Mar 01, 2008 11:21 am    Post subject: Reply with quote

mcsky2 wrote:
Je me suis apercu que lorsqu'il y a un [M ], cela signifiait que le package n'existait plus ou n'a pas été mis a jour.

C'est faux ! Cela correspond à un ebuild hard masked.

Il suffit de lire la man page :P :
Quote:
Output:

The list command searches packages for the name given. If found, the following info will be
displayed: the package location between the first square brackets (I for Installed packages, P
for Portage, O for Overlay), the possible masks between the second (~ by keyword, - by arch or
M hard masked), then the category and complete name and last of all, the slot in which the
package is stored.


Chez moi :
Quote:
~ $ equery list -e gcc
[ Searching for package 'gcc' in all categories among: ]
* installed packages
[I--] [ ~] sys-devel/gcc-4.2.3 (4.2)

gcc-4.2.3, slot 4.2, est installé (I) et est marqué instable (~).
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
mcsky2
Guru
Guru


Joined: 25 Aug 2005
Posts: 307

PostPosted: Sat Mar 01, 2008 2:37 pm    Post subject: Reply with quote

La commande "equery list" ne correspond pas a la réalite. Parce que gcc 4.1.2 est stable sous x86

Code:
[I--] [ -] sys-devel/gcc-4.1.2 (4.1)


Code:
[I] sys-devel/gcc
     Available versions: 
   (2.95)   [P]2.95.3-r9 [P]~2.95.3-r10
   (3.1)   [P]3.1.1-r2
   (3.2)   [P]**3.2.2 [P]3.2.3-r4
   (3.3)   ~3.3.6-r1
   (3.4)   3.4.6-r2
   (4.0)   ~*4.0.3 ~*4.0.4
   (4.1)   ~4.1.0-r1 4.1.1-r3 4.1.2
   (4.2)   ~4.2.0 ~4.2.1 ~4.2.2 ~4.2.3


Pour le M, par exemple, j'ai

Code:
 [I--] [M ] x11-libs/libzvt-2.0.1-r2 (0)


le package n'existe plus

ou

Code:
[I--] [M ] media-sound/mpg123-0.65 (0)


existe toujours mais il existe une version plus recente qui n'a pas été mise a jour par un "emerge -unDaN world":

Code:
[U] media-sound/mpg123
     Available versions:  0.67 1.2.0 ~1.2.1 {3dnow 3dnowext alsa altivec arts esd jack mmx nas oss portaudio pulseaudio sdl sse}
     Installed versions:  0.65(21:46:19 11.04.2007)(alsa esd mmx -3dnow -jack -nas -oss -portaudio -sdl)

Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sat Mar 01, 2008 2:46 pm    Post subject: Reply with quote

mcsky2 wrote:
Pour le M, par exemple, j'ai
Code:
 [I--] [M ] x11-libs/libzvt-2.0.1-r2 (0)
le package n'existe plus

equery doit surement considérer les ebuilds qui ne sont plus disponibles comme hard masked.
Mais bon, dans ce cas, cette bibliothèque ne devrait même plus être installée sur ton système...

mcsky2 wrote:
Code:
[I--] [M ] media-sound/mpg123-0.65 (0)
existe toujours mais il existe une version plus recente qui n'a pas été mise a jour par un "emerge -unDaN world":

Si portage de fait pas la mise à jour, c'est que ton système est mal maintenu.
Un coup de nettoyage dans le fichier world et un petit coup de depclean ne ferait sans doute pas de mal. À faire avec précautions, bien sûr !
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum