Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hitchhiker-sources (gentoo-sources+reiser4+aufs2+tuxonice)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sat Mar 01, 2008 1:41 am    Post subject: hitchhiker-sources (gentoo-sources+reiser4+aufs2+tuxonice) Reply with quote

hitchhiker-sources
available in berkano overlay, for those who like me are lazy ;)

Currently (since 2009-04-30) I use these patches:
- latest micro release from kernel.org
- Reiser4
- Gentoo patches
- AUFS2
- TuxOnIce
- march=native option

Direct link to ebuilds: http://websvn.liveforge.org/wsvn/berkano/trunk/sys-kernel/hitchhiker-sources/
Or use layman -a berkano 8)

And thanks to Douglas Adams for writing the funniest science-fiction series ever!
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF


Last edited by yngwin on Thu Apr 30, 2009 7:18 pm; edited 4 times in total
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5610
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Mar 01, 2008 11:30 am    Post subject: Reply with quote

thanks :)
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
Darknight
Guru
Guru


Joined: 26 Jan 2004
Posts: 455
Location: Italy

PostPosted: Wed Mar 19, 2008 12:31 am    Post subject: Reply with quote

Very nice! I will try them for sure.
Back to top
View user's profile Send private message
cjubon
Guru
Guru


Joined: 03 Jul 2007
Posts: 440
Location: Vienna/Europe

PostPosted: Wed Mar 19, 2008 9:42 am    Post subject: Reply with quote

Nice!

I used to patch my kernel with reiser4. Could you tell me what's the advantage of udf-2.50?

Thanks.
_________________
Mandrake Dec 2001 · Debian "Woody" Aug 2002 · Gentoo Jan 2004 · Funtoo Oct 2009
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sat Mar 22, 2008 10:47 am    Post subject: Reply with quote

It adds support for media formatted with udf-2.50. I've been told Vista writes DVDs with udf-2.50 by default, for example. Also Bluray disks use it. See also:
http://www.gossamer-threads.com/lists/linux/kernel/865419
http://en.wikipedia.org/wiki/Universal_Disk_Format
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
cjubon
Guru
Guru


Joined: 03 Jul 2007
Posts: 440
Location: Vienna/Europe

PostPosted: Sun Mar 23, 2008 5:08 pm    Post subject: Reply with quote

Thanks for your answer, yngwin.
_________________
Mandrake Dec 2001 · Debian "Woody" Aug 2002 · Gentoo Jan 2004 · Funtoo Oct 2009
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sun Mar 30, 2008 6:24 pm    Post subject: Reply with quote

New version is released, which brings us up to date with vanilla 2.6.24.4 and gentoo-sources 2.6.24-r4.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Fri Apr 11, 2008 11:00 am    Post subject: Reply with quote

New version -hh3, which is equivalent to gentoo-sources 2.6.24-r5.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
cjubon
Guru
Guru


Joined: 03 Jul 2007
Posts: 440
Location: Vienna/Europe

PostPosted: Sat Apr 12, 2008 4:50 pm    Post subject: Reply with quote

Just installed hh3, very nice. Thank you :-).
_________________
Mandrake Dec 2001 · Debian "Woody" Aug 2002 · Gentoo Jan 2004 · Funtoo Oct 2009
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sat Apr 19, 2008 7:33 pm    Post subject: Reply with quote

Today I updated the ebuilds to the latest versions:
2.6.24-hh4 (with genpatches-2.6.24-7) and
2.6.25-hh1 (with genpatches-2.6.25-2).
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
UnHoly616
n00b
n00b


Joined: 15 Oct 2005
Posts: 33
Location: Tallinn/EstOnia

PostPosted: Sat May 03, 2008 6:20 pm    Post subject: Reply with quote

Hey, I like these sources because I am too lazy to make ebuilds myself :D
But... :? Most time all mirrors for reiser4 patches are down. If there is more mirrors for reiser4 patches, please add these to your ebuild.
Thanks and keep up the good work!
_________________
There is no spoon!
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sun May 11, 2008 10:10 am    Post subject: Reply with quote

New ebuild: hitchhiker-sources-2.6.25-r3! Based on the latest gentoo patches, as included in gentoo-sources-2.6.25-r3. As this is a security update everyone is strongly advised to update to this version. I will probably remove the earlier versions from the overlay for this reason, later today.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Tue Jun 17, 2008 3:04 pm    Post subject: Reply with quote

New release: hitchhiker-sources-2.6.25-r5

Has:
- vanilla kernel 2.6.25.7
- genpatches 2.6.25-6 (only just released) for gentoo-sources-2.6.25-r5
- reiser4 for 2.6.25
- udf-2.50 for 2.6.25

As always, you are advised to update.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Fri Jul 04, 2008 11:55 am    Post subject: Reply with quote

Hmm, I seem to make it a habit to announce only every other release. Either way, we are now at 2.6.25-hh7, which has the latest patches from gentoo-sources, as well as the latest vanilla update to 2.6.25.10, with Reiser4 and UDF-2.50 added as usual. The kernel devs strongly encourage people to update.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
cjubon
Guru
Guru


Joined: 03 Jul 2007
Posts: 440
Location: Vienna/Europe

PostPosted: Sun Jul 06, 2008 6:34 pm    Post subject: Reply with quote

Thanks. This time, however, I've got a problem: nvidia-drivers-71.86.01 won't compile any more. I tried several times, also temporarily disabling distcc and ccache, but the error is always the same:
Code:
/var/tmp/portage/x11-drivers/nvidia-drivers-71.86.01/work/NVIDIA-Linux-x86-71.86.01-pkg0/usr/src/nv/nv-vm.c: In function ‘nv_flush_caches’:
/var/tmp/portage/x11-drivers/nvidia-drivers-71.86.01/work/NVIDIA-Linux-x86-71.86.01-pkg0/usr/src/nv/nv-vm.c:363: error: implicit declaration of function ‘global_flush_tlb’
distcc[19796] ERROR: compile /var/tmp/portage/x11-drivers/nvidia-drivers-71.86.01/work/NVIDIA-Linux-x86-71.86.01-pkg0/usr/src/nv/nv-vm.c on localhost failed
make[3]: *** [/var/tmp/portage/x11-drivers/nvidia-drivers-71.86.01/work/NVIDIA-Linux-x86-71.86.01-pkg0/usr/src/nv/nv-vm.o] Error 1
Any ideas?
_________________
Mandrake Dec 2001 · Debian "Woody" Aug 2002 · Gentoo Jan 2004 · Funtoo Oct 2009
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Mon Jul 07, 2008 12:01 am    Post subject: Reply with quote

No, sorry. 173.14.09 works for me.

Edit: this looks like bug 223047, but that should be fixed in 71.86.04, so try that version.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
cjubon
Guru
Guru


Joined: 03 Jul 2007
Posts: 440
Location: Vienna/Europe

PostPosted: Mon Jul 07, 2008 7:09 pm    Post subject: Reply with quote

yngwin wrote:
should be fixed in 71.86.04, so try that version
Yes, this version compiles flawlessly, but it makes hang my computer on X startup. The ~x86 keyword seems to be taken seriously in this case.

I'll stick with 2.6.24-hh3 for the while. This does not break my NFS exports either (2.6.25 does).
Thanks for your efforts, yngwin.
_________________
Mandrake Dec 2001 · Debian "Woody" Aug 2002 · Gentoo Jan 2004 · Funtoo Oct 2009
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sun Jul 13, 2008 9:27 pm    Post subject: Reply with quote

New release, hitchhiker-sources-2.6.25-r8 is available now in berkano overlay. It adds the new linux-2.6.25.11 patch.

http://lkml.org/lkml/2008/7/13/113 wrote:
It contains one bugfix, any user of the 2.6.25 kernel on x86-64 with
untrusted local users is very STRONGLY recommended to upgrade.

_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
cjubon
Guru
Guru


Joined: 03 Jul 2007
Posts: 440
Location: Vienna/Europe

PostPosted: Mon Jul 14, 2008 12:32 pm    Post subject: Reply with quote

Hi, yngwin, just one question from a non-developer: why did you include the reiser4-new-export_ops-fix.patch in 2.6.24, but not in 2.6.25? Is there any relation to nfs-exports? On my system, where the portage tree is on a reiser4 partition and should be exported via nfs to my other gentoo boxes, the nfs-services won't start with 2.6.25-hh7 at boot, but they do with 2.6.24-hh3.

Thanks.
_________________
Mandrake Dec 2001 · Debian "Woody" Aug 2002 · Gentoo Jan 2004 · Funtoo Oct 2009
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Mon Jul 14, 2008 6:36 pm    Post subject: Reply with quote

cjubon wrote:
Hi, yngwin, just one question from a non-developer: why did you include the reiser4-new-export_ops-fix.patch in 2.6.24, but not in 2.6.25?

Because the patch got applied upstream and is part of the reiser4-for-2.6.25.patch.

cjubon wrote:
Is there any relation to nfs-exports? On my system, where the portage tree is on a reiser4 partition and should be exported via nfs to my other gentoo boxes, the nfs-services won't start with 2.6.25-hh7 at boot, but they do with 2.6.24-hh3.

I don't know if it has anything to do with nfs — I don't use nfs myself. You'd better ask on the reiserfs mailing list.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Thu Jul 17, 2008 2:52 pm    Post subject: Reply with quote

Gentoo-sources has reached version 2.6.26. This includes read-only support for UDF-2.50. There is no updated patch for udf write support yet. Also, there is no new Reiser4 patch yet, but the one for 2.6.25 applies. For these reasons I am not making a new release at this point. You can patch gentoo-sources with reiser4 by hand or use helium-sources, if you need Reiser4.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sat Aug 09, 2008 1:08 pm    Post subject: Reply with quote

I've made a new release, hitchhiker-sources-2.6.26-r1, based on 2.6.26.2. I've added the following patches:
- Reiser4
- Gentoo patches
- SquashFS-lzma
- AUFS

I hope you enjoy it. :D
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 414
Location: Berlin

PostPosted: Sat Aug 09, 2008 2:40 pm    Post subject: Reply with quote

yngwin wrote:
I've made a new release, hitchhiker-sources-2.6.26-r1, based on 2.6.26.2. I've added the following patches:
- Reiser4
- Gentoo patches
- SquashFS-lzma
- AUFS

I hope you enjoy it. :D


Thanks, works great :D

CooSee ' Ya
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Tue Sep 09, 2008 12:58 am    Post subject: Reply with quote

New release, hitchhiker-sources-2.6.26-r2, based on 2.6.26.5. I've added the following patches:
- Reiser4
- Gentoo patches
- SquashFS-lzma
- AUFS
- some Fedora patches for eee-pc, e1000-ich9, at76, atl2

Enjoy :D
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
cjubon
Guru
Guru


Joined: 03 Jul 2007
Posts: 440
Location: Vienna/Europe

PostPosted: Fri Sep 12, 2008 8:00 am    Post subject: Reply with quote

Works nicely. Thank you.

Just had to reconfigure with regard to the ivtv driver (which is part of the kernel now), uninstall media-tv/ivtv (which is no more needed), and create an ebuild for media-tv/ivtv-utils which are not in portage. For those interested in the ebuild, see here: https://bugs.gentoo.org/show_bug.cgi?id=234756

Cheers
_________________
Mandrake Dec 2001 · Debian "Woody" Aug 2002 · Gentoo Jan 2004 · Funtoo Oct 2009
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum