Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge totem fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
torleif
n00b
n00b


Joined: 25 Feb 2008
Posts: 12

PostPosted: Mon Feb 25, 2008 10:38 pm    Post subject: emerge totem fails Reply with quote

Hi
I ran revdep-rebuild on on my gentoo amd64 system and it tries to rebuild some packages.
When it emerges media-video/totem I get this error:

x86_64-pc-linux-gnu-gcc: /usr/lib64/libGL.so: No such file or directory
make[5]: *** [bvw-test] Error 1
make[5]: Leaving directory `/var/tmp/portage/media-video/totem-2.20.3/work/totem-2.20.3/src/backend'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/var/tmp/portage/media-video/totem-2.20.3/work/totem-2.20.3/src/backend'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/media-video/totem-2.20.3/work/totem-2.20.3/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/media-video/totem-2.20.3/work/totem-2.20.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-video/totem-2.20.3/work/totem-2.20.3'
make: *** [all] Error 2
*
* ERROR: media-video/totem-2.20.3 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 2779: Called gnome2_src_compile
* environment, line 2132: Called die
* The specific snippet of code:
* emake || die "compile failure"
* The die message:
* compile failure
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/media-video/totem-2.20.3/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/media-video/totem-2.20.3/temp/environment'.
*

* Messages for package media-video/totem-2.20.3:

*
* ERROR: media-video/totem-2.20.3 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 2779: Called gnome2_src_compile
* environment, line 2132: Called die
* The specific snippet of code:
* emake || die "compile failure"
* The die message:
* compile failure
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/media-video/totem-2.20.3/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/media-video/totem-2.20.3/temp/environment'.
*


I see this error: x86_64-pc-linux-gnu-gcc: /usr/lib64/libGL.so

In /usr/lib64 I have a symlink libGL.so.1 which points to libGL.so.169.09, but I dont have a libGL.so.
Can I just make a symlink libGL.so that points to libGL.so.169.09 ?
I think NVIDIA driver made the libGL.so.169.09, since 169.09 is the version of my graphics driver.

Any Ideas?

Torleif
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7209
Location: Pelotas, BR

PostPosted: Mon Feb 25, 2008 11:03 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads (no crossposting please)
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum