Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] mono 1.2.5 e compilatore vb
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
DevOne
Guru
Guru


Joined: 13 Jul 2005
Posts: 419

PostPosted: Mon Feb 25, 2008 8:36 am    Post subject: [RISOLTO] mono 1.2.5 e compilatore vb Reply with quote

Ciao a tutti,
ho installato mono, ma non trovo nessun riferimento al compilatore per visual basic .net!!

L'unico file che ho trovato è "mbas" appartenente ad una precedente versione di mono, e comunque
non è funzionante perchè nell'eseguirlo, dice che non esiste l'assembly /..../mbas.exe

Come posso risolvere il problema?

Grazie a tutti per la disponibilità

Gianni
_________________
Real-time cooperative softair: http://www.softairrealfight.net
Qt generic-compass contribution: https://codereview.qt-project.org/#/c/92017
Open-source Virtual Keyboard QT widget: https://www.linux-apps.com/p/1132203/


Last edited by DevOne on Sun Mar 02, 2008 6:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Mon Feb 25, 2008 9:26 am    Post subject: Reply with quote

provato ad installare dev-lang/mono-basic?
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
DevOne
Guru
Guru


Joined: 13 Jul 2005
Posts: 419

PostPosted: Mon Feb 25, 2008 10:50 am    Post subject: Reply with quote

Onip wrote:
provato ad installare dev-lang/mono-basic?


Non so devo controllare...
non è una dipendenza che si porta da solo?
_________________
Real-time cooperative softair: http://www.softairrealfight.net
Qt generic-compass contribution: https://codereview.qt-project.org/#/c/92017
Open-source Virtual Keyboard QT widget: https://www.linux-apps.com/p/1132203/
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Mon Feb 25, 2008 3:33 pm    Post subject: Reply with quote

DevOne wrote:
Onip wrote:
provato ad installare dev-lang/mono-basic?


Non so devo controllare...
non è una dipendenza che si porta da solo?

non credo. ho mono installato con le use flag X e ntpl abilitate (non ce ne sono altre) e mono-basic non è installato.
Back to top
View user's profile Send private message
DevOne
Guru
Guru


Joined: 13 Jul 2005
Posts: 419

PostPosted: Tue Feb 26, 2008 9:31 am    Post subject: Reply with quote

In effetti, se provo ad installare mono-basic (che forse implementa il compilatore visual basic, ma quello vecchio)
mi chiede di fare il downgrade di mono, dalla versione 1.2.5 alla 1.2.4 (che conferma quanto scritto sopra).

Quindi, come è possibile? (anche perchè nella versione mono per windows, vbnc è presente e funzionante!)
_________________
Real-time cooperative softair: http://www.softairrealfight.net
Qt generic-compass contribution: https://codereview.qt-project.org/#/c/92017
Open-source Virtual Keyboard QT widget: https://www.linux-apps.com/p/1132203/
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Tue Feb 26, 2008 9:37 am    Post subject: Reply with quote

prova a smascherare la versione di mono-basic corrispondente a quella di mono installata.
Back to top
View user's profile Send private message
DevOne
Guru
Guru


Joined: 13 Jul 2005
Posts: 419

PostPosted: Wed Feb 27, 2008 11:55 am    Post subject: Reply with quote

magowiz wrote:
prova a smascherare la versione di mono-basic corrispondente a quella di mono installata.


Ma la cosa cmq non mi torna.
Cioè, ho mono 1.2.5 stabile e poi dovrei avere il compilatore vb non stabile?!

Cioè il compilatore c sharp penso sia già incluso in mono, perchè quello vb non dovrebbe essere presente??
_________________
Real-time cooperative softair: http://www.softairrealfight.net
Qt generic-compass contribution: https://codereview.qt-project.org/#/c/92017
Open-source Virtual Keyboard QT widget: https://www.linux-apps.com/p/1132203/
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Wed Feb 27, 2008 3:12 pm    Post subject: Reply with quote

DevOne wrote:
magowiz wrote:
prova a smascherare la versione di mono-basic corrispondente a quella di mono installata.


Ma la cosa cmq non mi torna.
Cioè, ho mono 1.2.5 stabile e poi dovrei avere il compilatore vb non stabile?!

Cioè il compilatore c sharp penso sia già incluso in mono, perchè quello vb non dovrebbe essere presente??


in realtà credo che i pacchetti seguano dei test separati, quindi può essere che una versione di mono diventi stabile ma un suo corrispettivo plugin non lo sia. Infatti se guardi nell'ebuild di mono-basic-1.2.5 troverai :
Code:
RDEPEND="=dev-lang/mono-${PV}*"


che significa che quel particolare componente ha bisogno della STESSA versione di mono per girare, quindi mono-basic-1.2.5 con mono-1.2.5, mono-basic-1.2.4 con mono-1.2.4.
Back to top
View user's profile Send private message
DevOne
Guru
Guru


Joined: 13 Jul 2005
Posts: 419

PostPosted: Thu Feb 28, 2008 4:03 pm    Post subject: Reply with quote

magowiz wrote:
che significa che quel particolare componente ha bisogno della STESSA versione di mono per girare, quindi mono-basic-1.2.5 con mono-1.2.5, mono-basic-1.2.4 con mono-1.2.4.


Eh capisco....
ma a questo punto, se devo smascherare mono-basic-1.2.5, mi smaschero direttamente mono-1.2.6
almeno così posso usufruire delle migliorie!

Devo provare in ogni caso...
_________________
Real-time cooperative softair: http://www.softairrealfight.net
Qt generic-compass contribution: https://codereview.qt-project.org/#/c/92017
Open-source Virtual Keyboard QT widget: https://www.linux-apps.com/p/1132203/
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Fri Feb 29, 2008 11:00 am    Post subject: Reply with quote

DevOne wrote:
magowiz wrote:
che significa che quel particolare componente ha bisogno della STESSA versione di mono per girare, quindi mono-basic-1.2.5 con mono-1.2.5, mono-basic-1.2.4 con mono-1.2.4.


Eh capisco....
ma a questo punto, se devo smascherare mono-basic-1.2.5, mi smaschero direttamente mono-1.2.6
almeno così posso usufruire delle migliorie!

Devo provare in ogni caso...


c'è stato un periodo in cui usavo praticamente solo versioni testing di mono, non ho mai avuto problemi. Comunque effettivamente se vuoi essere aggiornato ti conviene smascherare il testing (magari in maniera definitiva con "dev-lang/mono ~x86" ) poi comunque dovrai smascherare anche il corrispettivo mono-basic.
Back to top
View user's profile Send private message
DevOne
Guru
Guru


Joined: 13 Jul 2005
Posts: 419

PostPosted: Sat Mar 01, 2008 7:32 pm    Post subject: Reply with quote

magowiz wrote:
c'è stato un periodo in cui usavo praticamente solo versioni testing di mono, non ho mai avuto problemi. Comunque effettivamente se vuoi essere aggiornato ti conviene smascherare il testing (magari in maniera definitiva con "dev-lang/mono ~x86" ) poi comunque dovrai smascherare anche il corrispettivo mono-basic.



Il problema è che ora ho mono-1.2.6, ma mono-basic è rimasto alla versione 1.2.4 e quindi mi vuole fare il downgrade di mono
1.2.6 alla versione 1.2.4!!!

Ma non è possibile che per usare il compilatore vb, devo fare tutto questo!?
_________________
Real-time cooperative softair: http://www.softairrealfight.net
Qt generic-compass contribution: https://codereview.qt-project.org/#/c/92017
Open-source Virtual Keyboard QT widget: https://www.linux-apps.com/p/1132203/
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Sat Mar 01, 2008 7:36 pm    Post subject: Reply with quote

DevOne wrote:
magowiz wrote:
c'è stato un periodo in cui usavo praticamente solo versioni testing di mono, non ho mai avuto problemi. Comunque effettivamente se vuoi essere aggiornato ti conviene smascherare il testing (magari in maniera definitiva con "dev-lang/mono ~x86" ) poi comunque dovrai smascherare anche il corrispettivo mono-basic.



Il problema è che ora ho mono-1.2.6, ma mono-basic è rimasto alla versione 1.2.4 e quindi mi vuole fare il downgrade di mono
1.2.6 alla versione 1.2.4!!!

Ma non è possibile che per usare il compilatore vb, devo fare tutto questo!?


è normale che sia così perchè non hai ancora smascherato mono-basic , devi fare anche :
Code:
echo "dev-lang/mono-basic ~x86">>/etc/portage/package.keywords

dovresti comunque dare un'occhiata a questa sezione dell'handbook : http://www.gentoo.org/doc/it/handbook/handbook-x86.xml?part=3&chap=3
Back to top
View user's profile Send private message
DevOne
Guru
Guru


Joined: 13 Jul 2005
Posts: 419

PostPosted: Sun Mar 02, 2008 6:54 pm    Post subject: Reply with quote

Ok ho risolto, avevo dimenticato di smascherare il pacchetto!

Ok adesso tutto apposto.

Grazie
Ciao
_________________
Real-time cooperative softair: http://www.softairrealfight.net
Qt generic-compass contribution: https://codereview.qt-project.org/#/c/92017
Open-source Virtual Keyboard QT widget: https://www.linux-apps.com/p/1132203/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum