Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
A7N8X Deluxe Problems with first boot after install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Mnementh
n00b
n00b


Joined: 05 Jul 2003
Posts: 7

PostPosted: Sun Jul 06, 2003 1:42 am    Post subject: A7N8X Deluxe Problems with first boot after install Reply with quote

Hardware:
A7N8X Deluxe
MSI Geforce 4 4200
Sony DRU500A DVD writer
2 Seagate SATA 80GB HDD's
1 WD 70GB ATA100 HDD (boot drive with Gentoo installed)
1GB DDR 2700
Athlon XP 2200+
Hauppauge DVB card

Problem:

I have tried to install a stage 1 gentoo build all of which compiles with no errors, I have followed the install instructions to the letter. My problem occurs when trying to boot after exiting the chroot after compiling the kernel and installing lilo.

The pc locks (with no errors) at the following point:

NFORCE2: IDE controller on PCI bus 00 dev 48
NFORCE2: chipset revision 162
NFORCE2: not 100% native mode: will probe irqs later
AMD_IDE: Bios didn't set cable bits correctly. Enabling workaround
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
AMD_IDE: PCI device 10de:0065 (nVidia Corporation) (rev a2) UDMA100 controller on pci00:09.0
ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA hdb:DMA
ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA hdd:DMA


Now I have to admit I am a complete n00b when it comes to linux so I'm not 100% sure of what I'm doing so I could really do with some help here as I have tried everything I can think of to resolve the problem.

So far I have tried the following kernels:
gaming-sources
gentoo-sources
gs-sources
development-sources (2.5.74)
mm-sources

I have tried all of the above with various kernel options and modules etc. Every one gives the same error on booting.

I have also emerged nforce-net, nvidia-kernel and nvidia-glx all with no problems. I have even tried using the kernel config from the liveCD as this boots the machine with no problems but upon booting from the hdd I get the same problem.

I'm trying to keep this short so I won't post any config files unless somebody requests them, I have searched the forums for 2 days trying to come up with a solution to this so please excuse me if it's been answered before but I have not been able to find anything.

I have tried everything I have found on the forums such as enabling AMD viper support etc. with no joy so I'm now posting a request for help...

Many thanks in advance, if any more info is required just shout at me for being a moron and not supplying it in the first place :wink:

Mnementh
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43763
Location: 56N 3W

PostPosted: Sun Jul 06, 2003 3:35 pm    Post subject: Reply with quote

Mnementh,

I've got a very similar set up but I chickened out of the SATA drives when I found lots of stuff on the net about poor or non-existant support.

Looking at my dmesg:-

AMD_IDE: PCI device 10de:0065 (nVidia Corporation) (rev a2) UDMA100 controller on pci00:09.0
ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
hda: Maxtor 6Y160P0, ATA DISK drive

the next thing mine does is detects hda. This suggests a few things.
Disable the SATA drives meanwhile. There is a link on the motherboard for that.

Check that your hda is set up right. It should be set to master or one drive, if there is no hdb and it needs to be at the end of the IDE cable too, or you will get poor performance.

I don't think it makes any difference with modern boot loaders but check with parted that your /boot partition is marked bootable too.

Regards,

NeddySeagoon
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Wedge_
Advocate
Advocate


Joined: 08 Aug 2002
Posts: 3614
Location: Scotland

PostPosted: Sun Jul 06, 2003 5:11 pm    Post subject: Reply with quote

I have the same board, although without any SATA drives, and I've used it with gentoo-sources, gs-sources, and mm-sources. I get the same warnings on booting:
Code:
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
NFORCE2: IDE controller at PCI slot 00:09.0
NFORCE2: chipset revision 162
NFORCE2: not 100% native mode: will probe irqs later
AMD_IDE: Bios didn't set cable bits corectly. Enabling workaround.
AMD_IDE: PCI device 10de:0065 (nVidia Corporation) (rev a2) UDMA100 controller on pci00:09.0
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA


but it doesn't seem to cause any problems. One thing I would try is remove all ACPI support from the kernel. I always seem to have problems booting when I enable it.
_________________
Per Ardua Ad Astra
The Earth is the cradle of the mind, but we cannot live forever in a cradle - Konstantin E. Tsiolkovsky
Gentoo Radeon FAQ
Back to top
View user's profile Send private message
bosje
Tux's lil' helper
Tux's lil' helper


Joined: 01 Nov 2002
Posts: 75
Location: Utrecht

PostPosted: Sun Jul 06, 2003 9:10 pm    Post subject: Reply with quote

It seems that you have not compiled the Silicon Image Chipset support (in ATA - IDE section of the kernel) into your kernel. This is needed for your SATA disk.

But take care. After booting from your ide0 master disk (hda), the disk-identifieres will be switched: your master on ide0 will become /dev/hdc and the SATA disk will become /dev/hda! You probably added root=/dev/hda2 to your kernel line in grub.conf. But at the time this line is read, hda has become hde. I solved the problem by forcing the ide-addresses at startup. I added
Quote:
ide1=0x1f0,0x3f6,14 ide0=0x170,0x376,15
to my commandline in grub.conf. This also keeps my cdwriter at hdc. I am not certain the values in your system are the same. You can find them in dmesg, just after the listing of the ide devices.

Switching of ide's does not take place if you boot from you SATA disk (in the bios set first bootdevice to scsi).
You also have to set hdparm -X66 -d1 for the SATA to gain some speed.
Finally I am not very happy with my SATA disk (Seagate Barracuda 120GB). When I write large datafiles (eg 1GB), my system hangs without exception. Even when disabling ACPI and setting
Quote:
echo max_kb_per_request:15 > /proc/ide/hda/settings

Hope this helps.
Success
Mike
Back to top
View user's profile Send private message
Mnementh
n00b
n00b


Joined: 05 Jul 2003
Posts: 7

PostPosted: Mon Jul 07, 2003 12:57 pm    Post subject: Reply with quote

NeddySeagoon wrote:


Check that your hda is set up right. It should be set to master or one drive, if there is no hdb and it needs to be at the end of the IDE cable too, or you will get poor performance.

I don't think it makes any difference with modern boot loaders but check with parted that your /boot partition is marked bootable too.


I have tried this with the SATA drives disconnected and disabled on the motherboard, /dev/hda1 shows up as active in fdisk and is set as /boot (ext3), /dev/hda2 is swap and /dev/hda3 is /root (reiserfs).

Wedge_ wrote:
I have the same board, although without any SATA drives, and I've used it with gentoo-sources, gs-sources, and mm-sources. I get the same warnings on booting:
Code:
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
NFORCE2: IDE controller at PCI slot 00:09.0
NFORCE2: chipset revision 162
NFORCE2: not 100% native mode: will probe irqs later
AMD_IDE: Bios didn't set cable bits corectly. Enabling workaround.
AMD_IDE: PCI device 10de:0065 (nVidia Corporation) (rev a2) UDMA100 controller on pci00:09.0
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA


but it doesn't seem to cause any problems. One thing I would try is remove all ACPI support from the kernel. I always seem to have problems booting when I enable it.


I removed all instances of ACPI from every kernel I've tried after reading on these boards that this might be the cause of my problems, it has no effect unfortunately it still locks up at the same point it doesn't appear to be detecting my hdd even though the livecd does with no problems

bosje wrote:
It seems that you have not compiled the Silicon Image Chipset support (in ATA - IDE section of the kernel) into your kernel. This is needed for your SATA disk.

But take care. After booting from your ide0 master disk (hda), the disk-identifieres will be switched: your master on ide0 will become /dev/hdc and the SATA disk will become /dev/hda! You probably added root=/dev/hda2 to your kernel line in grub.conf. But at the time this line is read, hda has become hde. I solved the problem by forcing the ide-addresses at startup. I added
Quote:
ide1=0x1f0,0x3f6,14 ide0=0x170,0x376,15
to my commandline in grub.conf. This also keeps my cdwriter at hdc. I am not certain the values in your system are the same. You can find them in dmesg, just after the listing of the ide devices.

Switching of ide's does not take place if you boot from you SATA disk (in the bios set first bootdevice to scsi).
You also have to set hdparm -X66 -d1 for the SATA to gain some speed.
Finally I am not very happy with my SATA disk (Seagate Barracuda 120GB). When I write large datafiles (eg 1GB), my system hangs without exception. Even when disabling ACPI and setting
Quote:
echo max_kb_per_request:15 > /proc/ide/hda/settings

Hope this helps.
Success
Mike


There didn't apear to be any options in most of the kernels for the SIL chipset the only one I found anything in was the development-2.5.74 kernel and I tried that one with it loaded directly into the kernel, as a module and without it at all, every time the same error. I'm starting to think it might not be the kernel and might be a problem with some of the other settings I've used such as USE and CFLAGS etc. As I am a self confessed n00b to all of this I tried to only use settings I understood and left everything else at defaults. (I'm not a n00b with PC's or troubleshooting I work doing PC support, just a n00b with this form of linux I want to get away from Windoze and don't want to use a bloated prepackaged windoze alike distro like Mandrake or RH.)

I'm also using Lilo not Grub and only have the following in there:

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
lba32 #also tried linear here and nothing at all but still the same error
default=linux

image=/boot/bzImage
label=linux
read-only
root-/dev/hda3


I have also tried booting with linux noapic and linux ide0=noautotune ide1=noautotune

I'm going bald over this as I really want to get gentoo on this machine as I've heard lots of great things about it and the people on these boards all seem happy to help. I will keep persevering till I fix this I just need some help atm...

Mnementh
_________________
The day you don't learn something is the day you die
Back to top
View user's profile Send private message
bosje
Tux's lil' helper
Tux's lil' helper


Joined: 01 Nov 2002
Posts: 75
Location: Utrecht

PostPosted: Mon Jul 07, 2003 7:42 pm    Post subject: Reply with quote

Sorry, I forgot to mention the kernel sources I use: vanilla-sources. Your board has the SiI3112 Serial ATA: IDE controller at PCI slot 01:0b.0. You need to have CONFIG_BLK_DEV_SIIMAGE=y (Silicon Image driver) in your .config. You can find it in the IDE/ATA section at 3/4th of the section. Try it. I have the same board, the same CPU and the same HD. It works

Your next problem will be the stability of the system. Sometimes it hangs during booting, sometimes I can work for hours. I still have no solution for that. Maybe it is because the SATA-driver shares irq 11 with various other devices?
Back to top
View user's profile Send private message
Mnementh
n00b
n00b


Joined: 05 Jul 2003
Posts: 7

PostPosted: Mon Jul 07, 2003 8:56 pm    Post subject: Reply with quote

bosje wrote:
Sorry, I forgot to mention the kernel sources I use: vanilla-sources. Your board has the SiI3112 Serial ATA: IDE controller at PCI slot 01:0b.0. You need to have CONFIG_BLK_DEV_SIIMAGE=y (Silicon Image driver) in your .config. You can find it in the IDE/ATA section at 3/4th of the section. Try it. I have the same board, the same CPU and the same HD. It works

Your next problem will be the stability of the system. Sometimes it hangs during booting, sometimes I can work for hours. I still have no solution for that. Maybe it is because the SATA-driver shares irq 11 with various other devices?


Woohoo!!!!

typical the one kernel I didn't want to try because every doc I've read on it says it's stable but it doesn't support all the latest hardware and that ends up being the one that solves my problem!!

Thank you all for your help it's very much appreciated it's nice to find a community of people who don't belittle n00bs and are willing to help each other out. I hope to be around here for a long time and maybe be able to help others in time (and of course get lots of help myself...) :wink:

Oh well time to install kde

/me goes to find a good book to while away the compile time...

Mnementh
_________________
The day you don't learn something is the day you die
Back to top
View user's profile Send private message
RagManX
Apprentice
Apprentice


Joined: 13 Jul 2002
Posts: 220
Location: Tennessee

PostPosted: Wed Jul 09, 2003 8:57 pm    Post subject: Reply with quote

Let me just throw in info on what I had to do with this same motherboard. I couldn't boot with vanilla or gentoo sources. Once I went to mm-sources, I disabled ACPI in the .config as well, and my system booted fine. Since I'm running fine with mm-sources, I haven't gone back to the other kernel sources to see if that fixes it. Might want to try that if you go to a different kernel - turn off power save kernel features and see if you run OK.

RagManX
_________________
http://www.gamingideas.com/ - an open discussion site for game improvement and new game ideas
Back to top
View user's profile Send private message
isnogood
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2003
Posts: 96

PostPosted: Thu Jul 10, 2003 12:11 pm    Post subject: Reply with quote

I do have the same message about the cable bits (motherboard is a biostar with amd athlon xp).I don't use sata so that shouldn't be the problem.The / partition on /dev/hda3 shows up as /dev/root.
It did only cause a minor problem when I tried to do set the PIO mode to 4 - that got rid of my root partition.
Did see some emails about the problem on the kernel mailing list but those are all about correcting the spelling in the error message from 'corectly' to 'correctly'. [/quote]
Back to top
View user's profile Send private message
Mnementh
n00b
n00b


Joined: 05 Jul 2003
Posts: 7

PostPosted: Sat Jul 12, 2003 12:51 pm    Post subject: Reply with quote

RagManX wrote:
Let me just throw in info on what I had to do with this same motherboard. I couldn't boot with vanilla or gentoo sources. Once I went to mm-sources, I disabled ACPI in the .config as well, and my system booted fine. Since I'm running fine with mm-sources, I haven't gone back to the other kernel sources to see if that fixes it. Might want to try that if you go to a different kernel - turn off power save kernel features and see if you run OK.

RagManX


I disabled acpi in the .config for all of the kernels I tried after the first attempt. There is no option in the bios on my mobo (rev 2.0 bios 1004) for acpi, or at least if there is I've never found it, all power management of any kind is turned off as my machines are left running 24/7 and I hate suspend mode etc. I tried mm-sources and couldn't get that to boot, I'm still having problems getting my SATA drives to work but thats another problem for another time :wink: I prefer to try and work things out myself before asking questions it's the only way to learn in my opinion...

Mnementh
_________________
The day you don't learn something is the day you die
Back to top
View user's profile Send private message
drekka
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2003
Posts: 111

PostPosted: Sat Jul 12, 2003 1:51 pm    Post subject: Reply with quote

Hi all,
Just adding my experience:

Asus A7N8X Deluxe
2 x Seagate 120G SATA drives - raid 0

I'm running the ac sources. I originally had similar problems (being new to Gentoo as well), but eventually worked it out. The first thing is to ensure that you have sources with both the silraid and ataraid drivers. Both a new. I downloaded about 6 or 7 diferent sources and grep'd the source code to see if they had silraid.o and ataraid.o (the compiled files).

I downloaded the following sources: ck, gaming, gentoo, pfeifer, wolks, xfs, ac, gss, development. Only some of the sources I downloaded had both - ac, pfiefer and gss. I chose ac.

The next thing is that when configuring the kernel, make sure you activate the "Prompt for development or incomplete code" option under "Code maturity" first. It's the first menu option. This enables you to access the settings for ataraid (last menu item on "ATA/IDE/MEM..." - "IDE ATA and ATAPI Block Devices" menu. Once you turn this on you can then also choose "Silicon Image Medley software raid" which will appear below it. This will compile both of the drivers into the kernel.

Be care in that during the installation you do not have the devfs file system running so the raid set will appear as /dev/ataraid/d0 and your partitions as /dev/ataraid/d0p1, /dev/ataraid/d0p2, etc.

Once you have finished setting up and reboot, you will have the devfs file system running (required by Gentoo so be sure to include it in your kernel, although the system will run without it;-) For some reason (I don't know why) with devfs running the raid set changes it's name to /dev/ataraid/disc0/disc for the raid set and /dev/ataraid/disc0/part1, etc for the partitions.

This means that when you are setting up your fstab file and lilo.conf (of what ever the grub config file is) you must use these names rather than the non-devfs names.

Hope this helps.
Derek.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum