Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ejecting Cd to change cds in the middle of a wine install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Phenomic69
n00b
n00b


Joined: 20 Jun 2003
Posts: 56

PostPosted: Sat Jul 12, 2003 3:06 am    Post subject: Ejecting Cd to change cds in the middle of a wine install Reply with quote

I only have one working cd drive currently ( I am working on the other, it has messed up tracking) I want to install bf1942 in winex 3(transgaming version). In the middle of the isntall i have to switch cds, linux wont let me, It says the device is busy wheni do umount /dev/cdrom or eject /dev/cdrom, I have tried umount with the force an d the lazy flags didnt work. I also cant eject it with the button, How can i switch cds?
Back to top
View user's profile Send private message
aardvark
Guru
Guru


Joined: 30 Jun 2002
Posts: 576

PostPosted: Sat Jul 12, 2003 8:28 am    Post subject: Re: Ejecting Cd to change cds in the middle of a wine instal Reply with quote

Phenomic69 wrote:
I only have one working cd drive currently ( I am working on the other, it has messed up tracking) I want to install bf1942 in winex 3(transgaming version). In the middle of the isntall i have to switch cds, linux wont let me, It says the device is busy wheni do umount /dev/cdrom or eject /dev/cdrom, I have tried umount with the force an d the lazy flags didnt work. I also cant eject it with the button, How can i switch cds?


Try to find out which process is occupying the cd

Code:
 
lsof | grep /mnt/cdrom


You may need to emerge lsof first.
After you see which app is causing the trouble, kill it.
Oh and in case that is Winex, then there's a problem!?!?

BTW do you have fam-oss enabled? try disable that too
Back to top
View user's profile Send private message
punkisdead
n00b
n00b


Joined: 29 Jun 2003
Posts: 9

PostPosted: Sat Jul 12, 2003 5:24 pm    Post subject: Reply with quote

Make sure that you're current directory is not /mnt/cdrom when you are trying to run the installer. Because when you go to umount the cdrom it thinks that it is still in use....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum