Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
>=hal-0.5.10 to wreak HAVOC on xkblayouts everywhere!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2591
Location: userland

PostPosted: Sat Feb 23, 2008 10:32 pm    Post subject: >=hal-0.5.10 to wreak HAVOC on xkblayouts everywhere! Reply with quote

Sorry for the alarmist topic, but here is a solution for an issue that caused me a few gray hairs: If you run a recent xorg-server (1.4.0.90 here) and upgrade to hal-0.5.10, hald will take over keyboard layout management. Ok, first it will crash X upon start, to avoid this you need to update to >=xf86-input-evdev-1.2.0 also.
But after this, the layout specified in the InputDevice section of xorg.conf will have no effect at all, and hal will use the default 'us' layout no matter what. To specify your own layout, create a new file '/etc/hal/fdi/policy/99-keymap.fdi' with the content:
Code:
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
<device>
<match key="info.capabilities" contains="input.keys">
<merge key="input.xkb.layout" type="string"> $YOURXKBLAYOUT </merge>
<merge key="input.xkb.variant" type="string"> $YOURXKBVARIANT </merge>
</match>
</device>
</deviceinfo>

(adapted to your needs of course) and restart hald and xdm. Since the keyboard layout is controlled by hal now, and input devices are hot-plugged, you can safely erase your InputDevice sections if you don't need any special configuration features.

The desktop environments all have a way to specify a per-user layout. If you are using this feature in KDE, you should select 'Evdev managed keyboard' as keyboard type, it's bound to be the same or similar for Gnome and XFCE (I would be grateful if someone could verify this though). I gathered this solution from several related forum posts and this bug.

EDIT: I found that after the upgrade to hal-0.5.10, X crashes right after waking up from S3 (suspend-to-ram). Will investigate further as time allows.
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Mon Feb 25, 2008 2:58 am    Post subject: Reply with quote

Yet another reason to dislike HAL. (other than killing astronauts... ;))
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2591
Location: userland

PostPosted: Mon Feb 25, 2008 8:43 am    Post subject: Reply with quote

yabbadabbadont wrote:
Yet another reason to dislike HAL. (other than killing astronauts... ;))

It wasn't HAL's fault, he was given conflicting orders, as the so very anglo-saxon looking Dr. Chandra explains in 2010. Same here, I guess.
Back to top
View user's profile Send private message
ad34
n00b
n00b


Joined: 15 Nov 2007
Posts: 11

PostPosted: Thu Mar 13, 2008 8:54 pm    Post subject: Reply with quote

I cant fix this problem with my french pc104 latin9 keyboard

I created /etc/hal/fdi/policy/99-keymap.fdi


first : why 99 ?


dont change anything, still the same problem

i ve got xorg 1.4.0.90 r3 and hal 0.5.10

here s my file , do u think it s ok ?
Code:

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <!-- Mouse configuration -->
    <match key="info.capabilities" contains="input.mouse">
      <merge key="input.x11_driver" type="string">evdev</merge>
    </match>

   <match key="info.capabilities" contains="input.keys">
      <!-- Option "XkbModel" "pc104" -->
      <merge key="input.xkb.model" type="string">pc104</merge>
      <merge key="input.xkb.layout" type="string">fr</merge>
      <merge key="input.xkb.rules" type="string">xorg</merge>
      <merge key="input.xkb.variant" type="string">latin9</merge>
   </match>

  </device>
</deviceinfo>
Back to top
View user's profile Send private message
shpokas
n00b
n00b


Joined: 12 Aug 2003
Posts: 28

PostPosted: Fri Mar 14, 2008 9:17 am    Post subject: Reply with quote

ad34 wrote:

here s my file , do u think it s ok ?


check your file against /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi
(copy it to /etc/hal/fdi/policy/ and edit to suit your needs)

more info in this thread: https://forums.gentoo.org/viewtopic-t-641870-start-0-postdays-0-postorder-asc-highlight-10keymap+fdi.html
Back to top
View user's profile Send private message
Shiznitz
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jun 2004
Posts: 106
Location: Northern California

PostPosted: Fri Mar 14, 2008 9:33 pm    Post subject: Reply with quote

I haven't tried this solution for a few reasons (I just keep downgrading back to 5.9 of hal after world updates). First, this seems like a stupid amount of work and HAL shouldn't interfere like this. Second, hal >=0.5.10 will also ruin things such as mounting my drives through KDE and recognizing my DVD drive. I haven't seen much written about this in the forums, so I'm assuming my problem may be unique. Either way, it seems like a lot of work for something that shouldn't really be happening.


Shiznitz
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum