Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HAL/ntfs-3g] problème de règle
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Pixys
l33t
l33t


Joined: 23 May 2005
Posts: 669

PostPosted: Sat Feb 23, 2008 9:50 pm    Post subject: [HAL/ntfs-3g] problème de règle Reply with quote

Bonsoir,
j'ai un HDD formaté (salement) en ntfs que je manipule (lecture/écriture) avec ntfs-3g ; pour faire ceci, j'ai créé (un peu au hasard) une règle HAL ici : /etc/hal/fdi/policy/10-ntfs-policy.fdi
Code:
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
   <device>
       <match key="volume.fstype" string="ntfs">
           <match key="@block.storage_device:storage.hotpluggable" bool="true">
               <merge key="volume.fstype" type="string">ntfs-3g</merge>
               <merge key="volume.policy.mount_filesystem" type="string">ntfs-3g</merge>
               <append key="volume.mount.valid_options" type="strlist">locale=</append>
           </match>
       </match>
   </device>
</deviceinfo>


ça fonctionnait bien jusqu'à la dernière mise à jour de ntfs-3g: maintenant je ne peux plus écrire mais je peux toujours lire (je précise que les droits sont bons)

Tout d'abord auriez-vous une idée pour mon problème et ensuite où trouver de la doc sur HAL et sur les règles parce que je n'y comprends rien...
merci.


Last edited by Pixys on Sun Feb 24, 2008 10:51 am; edited 1 time in total
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Sun Feb 24, 2008 12:44 am    Post subject: Reply with quote

Hum j'ai le même problème... moi la règle est ignorée et le disque est monté avec NTFS au lieu de ntfs-3g depuis une maj indéterminée :/

Vérifié avec mount pour voir si ce n'est pas le même problème que moi.
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
Pixys
l33t
l33t


Joined: 23 May 2005
Posts: 669

PostPosted: Sun Feb 24, 2008 8:49 am    Post subject: Reply with quote

c'est bizarre ce que me renvoie mount:

Code:
pegase pixys # mount
rootfs on / type rootfs (rw)
/dev/root on / type reiser4 (rw,atom_max_size=0x1f6c1,atom_max_age=0x927c0,atom_min_size=0x100,atom_max_flushers=0x1,cbk_cache_slots=0x10)
proc on /proc type proc (rw,nosuid,nodev,noexec)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec)
udev on /dev type tmpfs (rw,nosuid)
none on /dev/pts type devpts (rw,nosuid,noexec)
shm on /dev/shm type tmpfs (rw,nosuid,nodev,noexec)
/dev/sda2 on /mnt/winxp type fuseblk (rw,noexec,nosuid,nodev,noatime,allow_other,blksize=4096)
/dev/sda5 on /home type reiser4 (rw,noexec,nosuid,nodev,noatime)
/dev/sda6 on /incoming type reiser4 (rw,noexec,nosuid,nodev,noatime)
/dev/sda7 on /backup type ext2 (rw,noexec,nosuid,nodev,noatime)
usbfs on /proc/bus/usb type usbfs (rw,noexec,nosuid,devmode=0664,devgid=85)
nfsd on /proc/fs/nfsd type nfsd (rw,noexec,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
debugfs on /sys/kernel/debug type debugfs (rw,noexec,nosuid,nodev)


en plus, j'ai aussi une partition ntfs (win_xp) sur lequel je peux lire et écrire sans problème.
Je suppose que mon HDD externe c'est ça:
Code:
usbfs on /proc/bus/usb type usbfs (rw,noexec,nosuid,devmode=0664,devgid=85)
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sun Feb 24, 2008 9:43 am    Post subject: Reply with quote

D'après le wiki, il y a des façons plus simple pour avoir l'automontage des disques en NTFS,comme le simple ajout d'un fichier /sbin/mount.ntfs.

À tester.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
Pixys
l33t
l33t


Joined: 23 May 2005
Posts: 669

PostPosted: Sun Feb 24, 2008 11:13 am    Post subject: Reply with quote

effectivement dans le wiki on peut faire créer un fichier /sbin/mout.ntfs:

Code:
#!/bin/bash
ntfs-3g "$@" -o locale=fr_FR.utf8


le problème c'est qu'on remplace "$@" par quoi ? pour une partition statique, il faut mettre le point de montage mais pour un device dynamique ?


Last edited by Pixys on Sun Feb 24, 2008 1:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sun Feb 24, 2008 12:03 pm    Post subject: Reply with quote

$@ est une variable prédéfinie en bash. C'est l'équivalent de $1 $2 $3 etc.
Tu n'as normalement pas besoin d'y toucher.

Quote:
Bash manpage

Expands to the positional parameters, starting from one. When the
expansion occurs within double quotes, each parameter expands to a
separate word. That is, "$@" is equivalent to
"$1" "$2" ...
If the double-quoted expansion occurs within a word, the expansion of
the first parameter is joined with the beginning part of the original
word, and the expansion of the last parameter is joined with the last
part of the original word.
When there are no positional parameters, "$@" and
$@
expand to nothing (i.e., they are removed).

_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
Pixys
l33t
l33t


Joined: 23 May 2005
Posts: 669

PostPosted: Sun Feb 24, 2008 1:19 pm    Post subject: Reply with quote

OK
en fait si je pose la question c'est parce qu'avec la syntax telle quelle:
Code:
#!/bin/bash
ntfs-3g "$@" -o locale=fr_FR.utf8


il me renvoit:
Code:
pegase pixys # /sbin/mount.ntfs
ntfs-3g: No device is specified.
Please type 'ntfs-3g --help' for more information.


j'en reviens donc à ma question: comment je fais pour définir le périphérique ?
merci bcp.
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sun Feb 24, 2008 1:22 pm    Post subject: Reply with quote

Avec /sbin/mount.ntfs /dev/sdxy.
Tu ne dois normalement pas utiliser cette commande. Elle est automatiquement appelée par la commande mount lors d'un montage quand l'option i n'est pas spécifiée.

Quote:
mount manpage

-i Don't call the /sbin/mount.<filesystem> helper even if it exists.


Après, il vaut voir comment configurer ton environnement (KDE, GNOME, XFCE, ...)
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
Pixys
l33t
l33t


Joined: 23 May 2005
Posts: 669

PostPosted: Sun Feb 24, 2008 1:42 pm    Post subject: Reply with quote

bon en fait c'est assez confus pour moi parce que je ne comprends pas trop comment tout ça fonctionne.
mon environnement c'est fluxbox, mon file manager c'est thunar avec l'extension thunar-volman. Ce que je veux c'est que quand je branche un HDD ou une clef usb ils apparaissent dans thunar directement afin que je puisse lire/écrire dessus...
avant cette mise à jour, ça fonctionnait (sauf pour les cd audio qu'on ne monte pas mais ça, je ne sais pas qui est le responsable entre HAL ou thunar-volman et c'est une autre histoire)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum