Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qjackctl segmentation fault
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6347
Location: /usr/lib64/lv2

PostPosted: Sat Jul 25, 2009 2:27 am    Post subject: qjackctl segmentation fault Reply with quote

I'm trying to run qjackctl as a regular user, which I think I'm supposed to be able to do, assuming I've set up RT correctly.

If I try to run it as a regular user, I get the error "Segmentation fault". That's all - nothing more. As root, I can run it.

As root, it runs, but in the terminal is this:

Code:

QGtkStyle cannot be used together with the GTK_Qt engine.
Qt: Session management error: None of the authentication protocols specified are supported


Why does it not run as a regular user?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
chrbecke
Guru
Guru


Joined: 12 Jul 2004
Posts: 598
Location: Berlin - Germany

PostPosted: Sat Jul 25, 2009 8:11 am    Post subject: Reply with quote

emerge notice for x11-libs/qt-gui-4.5.2-r2 wrote:
WARN: postinst
If you get the following error when setting Qt to use the GTK style:
"QGtkStyle cannot be used together with the GTK_Qt engine."
make sure you have GTK configured to NOT use the GTK_Qt engine and
export GTK2_RC_FILES="$HOME/.gtkrc-2.0" in your environment.

Don't know if this applies to your qt-gui version.

You should try to get a backtrace from the crash when run as a regular user.

HTH.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6347
Location: /usr/lib64/lv2

PostPosted: Sat Jul 25, 2009 2:52 pm    Post subject: Reply with quote

How do I get a backtrace?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Nerevar
l33t
l33t


Joined: 31 May 2008
Posts: 720

PostPosted: Sat Jul 25, 2009 2:56 pm    Post subject: Reply with quote

Add the debug use flag to the pkg and see:
http://www.gentoo.org/proj/en/qa/backtraces.xml
Code:
USE="debug" emerge -1 qjackctl
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6347
Location: /usr/lib64/lv2

PostPosted: Sat Jul 25, 2009 3:37 pm    Post subject: Reply with quote

Interestingly enough, qjackctl started running under a regular user after recompiling. I changed some kernel options recently, so if it wasn't that, maybe it just needed to be recompiled for some other reason.

Thanks for the info, though. I still found it useful. 8)
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum