Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[shutdown] "umount: /: device is busy" (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
cuicui
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 208

PostPosted: Sun Sep 02, 2007 7:51 am    Post subject: [shutdown] "umount: /: device is busy" (résolu) Reply with quote

Bonjour,

Depuis quelques temps, lorsque j'arrête Gentoo, j'ai parfois l'erreur "umount: /: device is busy" après l'étape "Remounting remaining filesystems readonly".

- C'est intermittent et pas reproductible
- Visiblement c'est suite aux commandes sync du script halt.sh
- Les processus sont bien tous tués quand le sync à lieu
- J'ai deux disques: un SATA, un PATA, qui tournent avec libata
- Si je boot et j'utilise Gentoo sans interface graphique et sans démarrer l'interface graphique ça semble ne pas se produire...
- ... mais si je lance l'interface graphique (soit manuellement soit en rajoutant xdm dans un runlevel) et si je la ferme proprement et complètement (plus aucun process lié à Gnome), il m'arrive d'avoir l'erreur.

Des idées???

/etc/fstab:

Code:
/dev/sda6               /               ext3            noatime         0 1
/dev/sda1               /boot           ext2            noatime         1 2
/dev/sda5               /home           ext3            noatime         0 1
/dev/sdb1               /store          xfs             defaults        0 1
/dev/sda4               none            swap            sw              0 0
/dev/sda8               /store2         ext3            noatime         0 1
/dev/sda9               /mnt/win/d      vfat   defaults,umask=000       0 0
/dev/sda7               /divar          reiserfs        notail,noatime  0 0

none                    /proc           proc            defaults        0 0
/divar/var              /var            none            bind            0 0

none            /dev/shm        tmpfs   nodev,nosuid,noexec             0 0


mount:

Code:

/dev/sda6 on / type ext3 (rw,noatime)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec)
udev on /dev type tmpfs (rw,nosuid)
devpts on /dev/pts type devpts (rw,nosuid,noexec)
/dev/sda1 on /boot type ext2 (rw,noatime)
/dev/sda5 on /home type ext3 (rw,noatime)
/dev/sdb1 on /store type xfs (rw)
/dev/sda8 on /store2 type ext3 (rw,noatime)
/dev/sda9 on /mnt/win/d type vfat (rw,umask=000)
/dev/sda7 on /divar type reiserfs (rw,noatime,notail)
/divar/var on /var type none (rw,bind)
none on /dev/shm type tmpfs (rw,noexec,nosuid,nodev)
usbfs on /proc/bus/usb type usbfs (rw,noexec,nosuid,devmode=0664,devgid=85)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
/dev/sda2 on /media/disk type fuseblk (rw,nosuid,nodev,noatime,allow_other,blksize=4096)


dmesg:

Quote:
scsi0 : ata_piix
scsi1 : ata_piix
ata1: PATA max UDMA/133 cmd 0x000101f0 ctl 0x000103f6 bmdma 0x0001fc00 irq 14
ata2: PATA max UDMA/133 cmd 0x00010170 ctl 0x00010376 bmdma 0x0001fc08 irq 15
ata1.00: ATA-7: Maxtor 6B200P0, BAH41BM0, max UDMA/133
ata1.00: 398297088 sectors, multi 16: LBA48
ata1.00: configured for UDMA/133
scsi 0:0:0:0: Direct-Access ATA Maxtor 6B200P0 BAH4 PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] 398297088 512-byte hardware sectors (203928 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sd 0:0:0:0: [sda] 398297088 512-byte hardware sectors (203928 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sda: sda1 sda2 sda3 < sda5 sda6 sda7 sda8 sda9 > sda4
sd 0:0:0:0: [sda] Attached SCSI disk
sd 0:0:0:0: Attached scsi generic sg0 type 0
ata_piix 0000:00:1f.2: MAP [ P0 -- P1 -- ]
ACPI: PCI Interrupt 0000:00:1f.2[A] -> GSI 18 (level, low) -> IRQ 17
PCI: Setting latency timer of device 0000:00:1f.2 to 64
scsi2 : ata_piix
scsi3 : ata_piix
ata3: SATA max UDMA/133 cmd 0x0001d400 ctl 0x0001d002 bmdma 0x0001c400 irq 17
ata4: SATA max UDMA/133 cmd 0x0001cc00 ctl 0x0001c802 bmdma 0x0001c408 irq 17
ata4.00: ata_hpa_resize 1: hpa sectors (586072368) is smaller than sectors (625142448)
ata4.00: ATA-7: ST3320620AS, 3.AAE, max UDMA/133
ata4.00: 625142448 sectors, multi 16: LBA48 NCQ (depth 0/32)
ata4.00: ata_hpa_resize 1: hpa sectors (586072368) is smaller than sectors (625142448)
ata4.00: configured for UDMA/133
scsi 3:0:0:0: Direct-Access ATA ST3320620AS 3.AA PQ: 0 ANSI: 5
sd 3:0:0:0: [sdb] 625142448 512-byte hardware sectors (320073 MB)
sd 3:0:0:0: [sdb] Write Protect is off
sd 3:0:0:0: [sdb] Mode Sense: 00 3a 00 00
sd 3:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sd 3:0:0:0: [sdb] 625142448 512-byte hardware sectors (320073 MB)
sd 3:0:0:0: [sdb] Write Protect is off
sd 3:0:0:0: [sdb] Mode Sense: 00 3a 00 00
sd 3:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sdb: sdb1
sd 3:0:0:0: [sdb] Attached SCSI disk
sd 3:0:0:0: Attached scsi generic sg1 type 0


Last edited by cuicui on Tue Feb 19, 2008 11:39 am; edited 1 time in total
Back to top
View user's profile Send private message
tatoo
n00b
n00b


Joined: 01 Sep 2007
Posts: 8

PostPosted: Sun Sep 02, 2007 9:18 am    Post subject: Reply with quote

salut , je ne te serai peut être pas d'une grande aide mais puisque celà ce produit uniquement lorsque tu lances l'interface graphique j'ai pensé à un truc , utilises tu kde ou gnome ? car tout deux utilisent des outils à la automount (je ne sais plus leur nom car je tourne sous fvwm me concernant) donc intérraisse toi je pense plutot à çà ...

sinan ton fstab me semble bon .
Back to top
View user's profile Send private message
cuicui
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 208

PostPosted: Mon Sep 03, 2007 2:47 pm    Post subject: Reply with quote

tatoo wrote:
salut , je ne te serai peut être pas d'une grande aide mais puisque celà ce produit uniquement lorsque tu lances l'interface graphique j'ai pensé à un truc , utilises tu kde ou gnome ? car tout deux utilisent des outils à la automount (je ne sais plus leur nom car je tourne sous fvwm me concernant) donc intérraisse toi je pense plutot à çà ...

sinan ton fstab me semble bon .

Avant le sync (lancé par le script halt.sh) j'ai fais la liste des points de montage et des processus en cours et il n'y avait rien de douteux. Pire: que ce soit un arrêt correct où un arrêt avec l'erreur, il n'y avait aucune différence. J'ai regardé du côté de l'USB et qu'il y ai un périphérique connecté ou non ça ne joue pas...

J'ai cherché un peu et la majorité des gens qui ont cette erreur on le problème pour un "vrai" point de montage, pas pour la racine.

Personne n'a une théorie ou plus d'infos sur la commande sync? Le script d'arrête de gentoo est assez complexe par rapport aux autres distribs donc j'ai pas trop envie d'y toucher...
Back to top
View user's profile Send private message
cuicui
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 208

PostPosted: Tue Feb 19, 2008 11:39 am    Post subject: Reply with quote

Finalement revenir en "stable" a résolu le problème.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum