Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] IMAP: NO Error in IMAP command received by server
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Gentoo_love
n00b
n00b


Joined: 18 Feb 2008
Posts: 8

PostPosted: Mon Feb 18, 2008 8:24 am    Post subject: [solved] IMAP: NO Error in IMAP command received by server Reply with quote

Всем Привет! Помогите настроить IMAP.
Ставил всё по этой инструкции http://www.gentoo.org/doc/ru/virt-mail-howto.xml?style=printable
База пользователей храниться в MySQL
По POP3 и SMTP соединяет без проблем
Всё установил, но вот какая проблема.
При попытке подключиться к IMAP (telnet 127.0.0.1 143)
Пишет:
Code:

Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA AUTH=CRAM-MD5 AUTH=CRAM-SHA1 AUTH=CRAM-SHA256 IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2005 Double Precision, Inc.  See COPYING for distribution information.
login
login NO Error in IMAP command received by server.

Из форумов я понял, что нужно поставить префикс перед Login (1 login)
Сделал префикс- всё работает.
IAMP версия "courier-imap-4.0.6-r2" (стабильная)
Конфигурация стандартная + инструкция.
В логах всё чисто Пишет
Code:
localhost imapd: Connection, ip=[::ffff:127.0.0.1]

Весь инет и google перерыл. Ничего не нашёл.
Вопрос: Как сделать что-бы работало без префикса ?
Нужно настроить Roundcubemail. Он будет работать с префиксом? Пока-что он не работает.
Зарание спасибо.


Last edited by Gentoo_love on Tue Feb 19, 2008 3:44 am; edited 1 time in total
Back to top
View user's profile Send private message
Azik
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2005
Posts: 149
Location: Russia, Ufa

PostPosted: Mon Feb 18, 2008 10:18 pm    Post subject: Reply with quote

А через почтовые клиенты нормально заходит?
_________________
From Siberia with Love!
Back to top
View user's profile Send private message
Gentoo_love
n00b
n00b


Joined: 18 Feb 2008
Posts: 8

PostPosted: Tue Feb 19, 2008 3:44 am    Post subject: Reply with quote

Azik wrote:
А через почтовые клиенты нормально заходит?

Как ни странно но через "evolution 2.12.0" Только-что зашёл нормально
Я раньше пробовал через Sylpheed (свой основной клиент) так не получалось.
Решил через другой попробовать. Все заработало. Потыкал настройки Sylpheed то-же всё получилось.
Оказывается если SMTP сервер не укажешь, то не работает.
Спасибо тебе.!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum