Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[GRUB] Pb lors du reboot [résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
knoax
n00b
n00b


Joined: 07 Dec 2007
Posts: 68

PostPosted: Sun Feb 17, 2008 4:49 pm    Post subject: [GRUB] Pb lors du reboot [résolu] Reply with quote

Bonjour tout le monde

Je viens t'installer une gentoo sur un vieux PC.

J'ai suivi le guide d'installation de Gentoo.

Mais lorsque je reboote mon PC, j'ai l'affichage suivant:


Code:
GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB
GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB ....



J'ai été sur google et j'ai trouvé le lien suivant:
http://www.gentoo.org/doc/fr/grub-error-guide.xml#doc_chap7

J'ai suivi les 2 recommandations mais j'ai tjs le meme pb

Voici mon /boot/grub/grub.conf
Code:
timeout 3
fallback 1

splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title=Gentoo Linux 2.6.23-r8
root (hd0,0)
kernel /boot/kernel-2.6.23-r8 root=/dev/hda3


title=Gentoo Linux 2.6.23-r8 (rescue shell)
root (hd0,0)
kernel /boot/kernel-2.6.23-r8 root=/dev/hda3 init=/bin/bb


Sinon j'ai 2 disques dur partitionnés comme suit
hda=20G0
hda1= partition boot
hda2= partition swap
hda3= partition racine "/"
hda4=partition étendu
hda5=partition étendu contenant la partition /var
hda5=partition étendu contenant la partition /tmp

hdb=40Go
hdb1= partition home

Piste probable:
Lorsque je suis arrivé à la fin de mon installation, je suis sortie de l'environnement chroot
puis j'ai démonté toutes mes partitions

Tout se passe bien mais lorsque je démonte mes partitions /dev et /proc, gentoo me dit que ces partitions sont busy
Idem lorsque je démonte la partition racine umount /mnt/gentoo

Sinon j'ai déjà installé une gentoo sur un autre PC (plus récent) et j'ai eu d'autre soucis (résolu) mais jamais le pb de grub lors du reboot.

J'ai plus d'idée, si des personnes ont des idées je serai preneur

Merci et bonne journée
Knoax
_________________
S'il n'y a pas de solution c'est qu'il n'y a pas de problème!
Les choses ne sont pas réellement difficile. C'est de ne rien faire qui les rend difficiles.


Last edited by knoax on Wed Feb 20, 2008 7:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Sun Feb 17, 2008 6:25 pm    Post subject: Reply with quote

Code:
kernel /boot/kernel-2.6.23-r8
t'as essayé ça plutôt
Code:
kernel /kernel-2.6.23-r8
?
_________________
The End of the Internet!
Back to top
View user's profile Send private message
knoax
n00b
n00b


Joined: 07 Dec 2007
Posts: 68

PostPosted: Wed Feb 20, 2008 5:09 pm    Post subject: Reply with quote

Merci de ta réponse rapide Truc

J'ai suivi ton conseil mais ça n'a pas marché.

J'ai cherché sur le web et j'ai trouvé un site qui expliquait mon pb.
En fait cela vient du bios, il semble que si le bios fait un auto détecte des disques durs, alors GRUB entre en boucle infini

Donc avant de posté mon pb, j'avais modifié mon bios de manière à ne pas avoir auto mais User Type HDD.
Cela ne marchait tjs pas

J'ai refais les tests mais le mode User Type HDD possède plusieurs type qui sont
- LBA
- Large
- Normal
- Manual

Après quelques tests, il suffisait d'utiliser le type LBA pour les 2 disques dur et tout fonctionne à merveille

Merci de votre aide
Knoax
_________________
S'il n'y a pas de solution c'est qu'il n'y a pas de problème!
Les choses ne sont pas réellement difficile. C'est de ne rien faire qui les rend difficiles.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum