Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[revdep-rebuild] toujours cassé
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
aconcagua
n00b
n00b


Joined: 17 Oct 2005
Posts: 65

PostPosted: Fri Feb 15, 2008 8:02 pm    Post subject: [revdep-rebuild] toujours cassé Reply with quote

Bonjour,

J'ai fait plusieurs revdep-rebuild et j'ai toujours les mêmes packages qui sont réinstallés encore et encore :
Code:

 #revdep-rebuild -X


 * Checking dynamic linking consistency
[ 47% ]  *   broken /usr/lib64/gcc/x86_64-pc-linux-gnu/3.4.6/lib-org-w3c-dom.la (requires /usr/lib/../lib64/libgcj.la)
 *   broken /usr/lib64/gcc/x86_64-pc-linux-gnu/3.4.6/lib-org-xml-sax.la (requires /usr/lib/../lib64/libgcj.la)
 *   broken /usr/lib64/gcc/x86_64-pc-linux-gnu/4.2.2/libgij.la (requires /usr/lib/../lib64/libgcj.la)
[ 48% ]  *   broken /usr/lib64/gcj-4.2.2/libjvm.la (requires /usr/lib/../lib64/libgcj.la)
[ 97% ]  *   broken /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/lib-org-w3c-dom.la (requires /usr/lib/../lib64/libgcj.la)
 *   broken /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/lib-org-xml-sax.la (requires /usr/lib/../lib64/libgcj.la)
[ 100% ]
 *   broken /usr/lib64/libswt-awt-gtk-3347.so (no version information available)
 *   broken /usr/lib64/tvbrowser/libDesktopIndicator.so (no version information available)
 * Generated new /root/.revdep-rebuild.3_rebuild

 * Assigning files to packages
 *   /usr/lib64/gcc/x86_64-pc-linux-gnu/3.4.6/lib-org-w3c-dom.la -> sys-devel/gcc
 *   /usr/lib64/gcc/x86_64-pc-linux-gnu/3.4.6/lib-org-xml-sax.la -> sys-devel/gcc
 *   /usr/lib64/gcc/x86_64-pc-linux-gnu/4.2.2/libgij.la -> sys-devel/gcc
 *   /usr/lib64/gcj-4.2.2/libjvm.la -> sys-devel/gcc
 *   /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/lib-org-w3c-dom.la -> sys-devel/gcc
 *   /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/lib-org-xml-sax.la -> sys-devel/gcc
 *   /usr/lib64/libswt-awt-gtk-3347.so -> dev-java/swt
 *   /usr/lib64/tvbrowser/libDesktopIndicator.so -> media-tv/tvbrowser
 * Generated new /root/.revdep-rebuild.4_packages_raw and /root/.revdep-rebuild.4_package_owners

 * Cleaning list of packages to rebuild
 * Generated new /root/.revdep-rebuild.4_packages

 * Assigning packages to ebuilds
 * Generated new /root/.revdep-rebuild.4_ebuilds

 * Evaluating package order
!!! A file listed in the Manifest could not be found: /usr/portage/local/layman/arcon/x11-libs/cairo/cairo-1.4.12.ebuild
 * Generated new /root/.revdep-rebuild.5_order

 * All prepared. Starting rebuild
emerge --oneshot  =media-tv/tvbrowser-2.6.3 =sys-devel/gcc-3.4.6-r2 =sys-devel/gcc-4.2.2 =dev-java/swt-3.3.1.1

Si je refais un revdep-rebuild -X après, toujours les mêmes packages à réémerger ....

J'utilise gentoolkit-0.2.4_pre7 (une version instable donc) mais je ne pense pas que çà vienne de là.

Une idée ?
Back to top
View user's profile Send private message
ceric35
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 114

PostPosted: Sun Feb 17, 2008 8:56 am    Post subject: Reply with quote

Probleme connu.

https://forums.gentoo.org/viewtopic-t-512148-start-0-postdays-0-postorder-asc-highlight-revdep+gcc.html
https://bugs.gentoo.org/show_bug.cgi?id=125728
https://forums.gentoo.org/viewtopic-t-444323.html

Si j'ai bien compris, il faut désactiver le useflag "gcj" de gcc
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum