Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Niente accelerazione grafica con ati-drivers-8.452 [Risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Fri Feb 15, 2008 3:01 pm    Post subject: Niente accelerazione grafica con ati-drivers-8.452 [Risolto] Reply with quote

Ciao a tutti.
Ho letto e riletto i post relativi a problemi simili al mio sia sul forum che altrove, sperimentato un sacco, ma ancora niente.
Sul mio portatile ASUS ho questa scheda video:
Code:
candasus linux # lspci | grep Radeon
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
su un architettura a 64 bit (con processore AMD Athlon 64 Mobile).
Uso i driver proprietari ati-drivers-8.452 su kernel gentoo-sources-2.6.23-r8.
Sono passato a questi dopo aver provato per un po' quelli open, ma anche avendo configurato tutto a dovere non andavano bene.
Ho compilato il kernel come indicato nella guida del wiki e l'ho seguita passo passo, ma non riesco ad ottenere l'accelerazione grafica.
Questo il mio xorg.conf:
Code:
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Mouse1" "SendCoreEvents"
    Option         "AIGLX" "true"
EndSection

Section "Files"
    RgbPath      "/usr/lib/X11/rgb"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/misc/"
    FontPath     "/usr/share/fonts/Type1/"
    FontPath     "/usr/share/fonts/100dpi/"
    FontPath     "/usr/share/fonts/75dpi/"
    FontPath     "/usr/share/fonts/default/ghostscript"
    FontPath     "/usr/share/fonts/ttf-bitstream-vera"
EndSection

Section "Module"
    Load  "dbe"
    Load  "extmod"
    Load  "fbdevhw"
    Load  "type1"
    Load  "freetype"
    Load  "glx"
    Load  "xtrap"
    Load  "record"
    Load  "GLcore"
    Load  "dri"
    Load  "i2c"
    Load  "drm"
    Load  "bitmap"
    Load  "ddc"
EndSection

Section "InputDevice"
   Identifier   "Mouse0"
   Driver       "synaptics"
   Option       "Protocol" "auto-dev"
   Option       "Device" "/dev/input/mouse1"
   Option       "LeftEdge"      "1700"
   Option       "RightEdge"     "5300"
   Option       "TopEdge"       "1700"
   Option       "BottomEdge"    "4200"
   Option       "FingerLow"     "25"
   Option       "FingerHigh"    "30"
   Option       "MaxTapTime"    "180"
   Option       "MaxTapMove"    "220"
   Option       "VertScrollDelta" "100"
   Option       "MinSpeed"        "0.09"
   Option       "MaxSpeed"        "0.18"
   Option       "AccelFactor"     "0.0015"
   Option       "SHMConfig"       "on"
   Option       "TapButton2"      "2"
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver     "mouse"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "XkbLayout" "it"
    Option         "CoreKeyboard"
    Option         "XkbRules"  "xorg"
    Option         "XkbModel"  "pc105"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Acer"
    ModelName      "Acer AL1916W"
    Option         "DPMS"
    HorizSync      30.0 - 81.0
    VertRefresh    56.0 - 75.0
    Modeline       "1280x1024_60.00"  108.88  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync
    DisplaySize    330 210 # Dimensioni del monitor in millimetri!
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "fglrx"
    VendorName     "ATI"
    Option         "BusType" "PCI"
    BoardName   "RV350 [Mobility Radeon 9600 M10]"
    Option       "Accel" "true"
    Option       "backingstore" "true"
    Option       "XAANoOffscreenPixmaps" "true"
    Option       "DRI" "true"
    Option       "mtrr" "off"
    Option       "UseInternalAGPGART" "no" #perchè non l'ho compilato come modulo
    BusID       "PCI:1:0:0"
    Option         "EnablePageFlip" "on"
    Option         "RenderAccel" "on"
    Option         "AccelMethod" "EXA"
    Option          "BIOSHotkeys" "on"
    Option         "ColorTiling" "on"
    Option          "MetaModes" "1280x1024"
    Option "AddARGBGLXVisuals" "True
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1280x1024_60.00"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "enable"
EndSection
E questi i Warning e gli errori riscontrati in Xorg.0.log:
Code:
candasus linux # cat /var/log/Xorg.0.log | grep WW
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(WW) fglrx(0): Only one display is connnected,so single mode is enabled
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *
(WW) fglrx(0): Option "EnablePageFlip" is not used
(WW) fglrx(0): Option "RenderAccel" is not used
(WW) fglrx(0): Option "AccelMethod" is not used
(WW) fglrx(0): Option "BIOSHotkeys" is not used
(WW) fglrx(0): Option "ColorTiling" is not used
(WW) fglrx(0): Option "MetaModes" is not used
(WW) fglrx(0): Option "AddARGBGLXVisuals" is not used
(WW) Mouse1: No Device specified, looking for one...
candasus linux # cat /var/log/Xorg.0.log | grep EE
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 2
(EE) fglrx(0): [pcie] Failed to gather memory of size 262144Kb for PCIe. Error (-1014)
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(EE) AIGLX: Screen 0 is not DRI capable

Dove sbaglio?
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)


Last edited by canduc17 on Tue Feb 26, 2008 7:59 am; edited 1 time in total
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Fri Feb 15, 2008 3:43 pm    Post subject: Reply with quote

GLcore in xorg.conf mi pare che vada commentato (controlla)
Controlla la sezione DRM nel kernel che probabilmente non è attivata
Aggiungi questa sezione nell'xorg.conf
Code:
Section "DRI"
    Mode 0666
EndSection

EDIT: segui la guida di questo link:
http://www.gentoo.org/doc/it/dri-howto.xml
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Fri Feb 15, 2008 4:39 pm    Post subject: Reply with quote

Tigerwalk wrote:
GLcore in xorg.conf mi pare che vada commentato (controlla)
Non cambia nulla abilitata o meno...

Tigerwalk wrote:
Controlla la sezione DRM nel kernel che probabilmente non è attivata
Certo che non è attivata, nella guida dice di non attivarla!

Tigerwalk wrote:
Aggiungi questa sezione nell'xorg.conf
Code:
Section "DRI"
    Mode 0666
EndSection
Fatto, ma non cambia nulla...

Tigerwalk wrote:
EDIT: segui la guida di questo link:
http://www.gentoo.org/doc/it/dri-howto.xml
Ma è per i driver open!
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Fri Feb 15, 2008 9:07 pm    Post subject: Reply with quote

canduc17 wrote:
Tigerwalk wrote:
GLcore in xorg.conf mi pare che vada commentato (controlla)
Non cambia nulla abilitata o meno...

Tigerwalk wrote:
Controlla la sezione DRM nel kernel che probabilmente non è attivata
Certo che non è attivata, nella guida dice di non attivarla!

Tigerwalk wrote:
Aggiungi questa sezione nell'xorg.conf
Code:
Section "DRI"
    Mode 0666
EndSection
Fatto, ma non cambia nulla...

Tigerwalk wrote:
EDIT: segui la guida di questo link:
http://www.gentoo.org/doc/it/dri-howto.xml
Ma è per i driver open!

A me, così va l'accelerazione ed il 3D.....(prova...)
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Sat Feb 16, 2008 7:29 pm    Post subject: Reply with quote

Ho già provato tutto, ma non mi funziona...non capisco come tu sia riuscito a fare funzionare i driver closed seguendo la guida per quelli open!
Altre idee?
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
xveilsidex
Guru
Guru


Joined: 27 Dec 2005
Posts: 370
Location: Bari

PostPosted: Sat Feb 16, 2008 7:38 pm    Post subject: Reply with quote

canduc17 wrote:
Ho già provato tutto, ma non mi funziona...non capisco come tu sia riuscito a fare funzionare i driver closed seguendo la guida per quelli open!
Altre idee?

Sul fisso , con un ati 9800 pro quindi abbastanza vecchiotta i driver nuovi non funzionano. Ho dovuto fare il downgrade di qualche versione prima di trovare quella giusta per la mia scheda. Il consiglio che ti posso dare è provare driver piu vecchi.
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Sat Feb 16, 2008 7:55 pm    Post subject: Reply with quote

Tipo tu che versione hai installato per quella scheda?
Però il supporto AIGLX c'è sollo dalla 8.42.3 in poi...
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Sun Feb 17, 2008 9:46 am    Post subject: Reply with quote

Scusa l'altra volta ero di fretta, adesso ti do delle info più precise che spero possano aoitarti!
Code:
qlist -Iv | grep ati-drivers
x11-drivers/ati-drivers-8.42.3

Code:
glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: ATI Mobility Radeon X1600

Code:
uname -r
2.6.23-gentoo-r3

Code:
cat /usr/src/linux/.config | grep DRM
CONFIG_DRM=m
CONFIG_DRM_TDFX=m
CONFIG_DRM_R128=m
CONFIG_DRM_RADEON=m
CONFIG_DRM_I810=m
CONFIG_DRM_I830=m
CONFIG_DRM_I915=m
CONFIG_DRM_MGA=m
CONFIG_DRM_SIS=m
CONFIG_DRM_VIA=m
CONFIG_DRM_SAVAGE=m

Code:
agpgart e intel-agp
in /etc/modules.autoload.d/kernel-2.6

questa è la guida che ho seguito:
http://www.gentoo.org/doc/it/dri-howto.xml
Comunque, alla fine, sono riuscito a far funzionare compiz solo seguendo questo howto, tanto l'anima è la stessa....
Se ti serve altro fammi sapere!
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
xveilsidex
Guru
Guru


Joined: 27 Dec 2005
Posts: 370
Location: Bari

PostPosted: Sun Feb 17, 2008 11:01 am    Post subject: Reply with quote

io ho ancora gli 8.32.5! Non m interessa compiz e robe varie sul desktop per questo rimango con quelli !
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Sun Feb 17, 2008 2:18 pm    Post subject: Reply with quote

xveilsidex wrote:
io ho ancora gli 8.32.5! Non m interessa compiz e robe varie sul desktop per questo rimango con quelli !
8O ...ah beh, grazie...allora se non usassi l'accelerazione 3D andrebbero bene tutti!
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Tue Feb 26, 2008 7:59 am    Post subject: Reply with quote

Ho risolto chiedendo sul forum internazionale qui.

Il problema stava nello xorg.conf, con il seguente và tutto a meraviglia:
Code:
Section "ServerLayout"
   Identifier    "aticonfig-Layout[all]"
   Screen   0    "aticonfig-Screen[0]" 0 0
   InputDevice   "Keyboard0" "CoreKeyboard"
   InputDevice   "Mouse0" "CorePointer"
   InputDevice   "Mouse1" "SendCoreEvents"
EndSection

Section "ServerFlags"
   Option      "AllowMouseOpenFail" "true"
#  Option      "AIGLX" "off"
#      uncomment  the above if you have lockups and such while running 3d stuff
EndSection

Section "Files"
    RgbPath      "/usr/lib/X11/rgb"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/misc/"
    FontPath     "/usr/share/fonts/Type1/"
    FontPath     "/usr/share/fonts/100dpi/"
    FontPath     "/usr/share/fonts/75dpi/"
    FontPath     "/usr/share/fonts/default/ghostscript"
    FontPath     "/usr/share/fonts/ttf-bitstream-vera"
EndSection

Section "Module"
   Load  "bitmap"
   Load  "fb"
   Load  "fglrx"
   Load  "GLcore"
   Load  "vbe"
   SubSection "extmod"
      Option      "omit XFree86-DGA"
   EndSubSection
EndSection

Section "InputDevice"
   Identifier   "Mouse0"
   Driver       "synaptics"
   Option       "Protocol" "auto-dev"
   Option       "Device" "/dev/input/mouse1"
   Option       "LeftEdge"      "1700"
   Option       "RightEdge"     "5300"
   Option       "TopEdge"       "1700"
   Option       "BottomEdge"    "4200"
   Option       "FingerLow"     "25"
   Option       "FingerHigh"    "30"
   Option       "MaxTapTime"    "180"
   Option       "MaxTapMove"    "220"
   Option       "VertScrollDelta" "100"
   Option       "MinSpeed"        "0.09"
   Option       "MaxSpeed"        "0.18"
   Option       "AccelFactor"     "0.0015"
   Option       "SHMConfig"       "on"
   Option       "TapButton2"      "2"
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver     "mouse"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "XkbLayout" "it"
    Option         "CoreKeyboard"
    Option         "XkbRules"  "xorg"
    Option         "XkbModel"  "pc105"
EndSection

Section "Monitor"
   Identifier  "aticonfig-Monitor[0]"
   DisplaySize  330 210
   Option      "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]"
   Driver      "fglrx"
   Option      "TexturedVideo" "on"
   Option      "Textured2D" "on"
   Option      "TexturedXrender" "true"
#  Option      "XAANoOffscreenPixmaps" "true"
#   you may not need the above, so leave it commented initially.
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]"
   Device     "aticonfig-Device[0]"
   Monitor    "aticonfig-Monitor[0]"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "DRI"
   Group   "video"
   Mode    0660
EndSection

Section "Extensions"
   Option   "Composite" "enable"
EndSection

Anche compiz-fusion và benissimo.

Saluto.
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum