Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas com a codificação "ISO-8859-1 e UTF-8" Resolvido
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
herkusPT
n00b
n00b


Joined: 15 Feb 2008
Posts: 17

PostPosted: Fri Feb 15, 2008 1:58 pm    Post subject: Problemas com a codificação "ISO-8859-1 e UTF-8" R Reply with quote

Estou com este problema a muito tempo, e estou farto de fazer pesquisa para ver se o resolvo, quando as coisas funcionam bem na consola fora do x (ctrl + alt + f1) no x nem por isso.

Estes são os ficehiros que eu ja mexi

/etc/rc.conf

UNICODE="no"

/etc/conf.d/keymap

KEYMAP="pt-latin1"
SET_WINDOWKEYS="yes"
EXTENDED_KEYMAPS="backspace keypad euro"
DUMPKEYS_CHARSET="iso-8859-1"


/etc./conf.d/consolefonte

CONSOLEFONT="lat9u-16"
CONSOLETRANSLATION="8859-1_to_uni"

/etc/env.d/02locale

LANG="pt_PT"
LC_CTYPE="pt_PT"
LC_NUMERIC="pt_PT"
LC_TIME="pt_PT"
LC_COLLATE="pt_PT"
LC_MONETARY="pt_PT"
LC_MESSAGES="pt_PT"
LC_PAPER="pt_PT"
LC_NAME="pt_PT"
LC_ADDRESS="pt_PT"
LC_TELEPHONE="pt_PT"
LC_MEASUREMENT="pt_PT"
LC_IDENTIFICATION="pt_PT"
LC_ALL=""


Com estas configurações esta tudo certo fora do X ç ã á .. tudo funciona direitinho.

quado arranco com o gnome todas as pastas que criei na consola fora do X aparecen direitinhas mas se criar uma pasta ai a coisa funciona mal porque aparece direi no gnomo mas na consola fora do X não aparecem caracteres estranhas.

Depois de ter feito algumas pesquisas e teste acho que o problema esta no gnome porque ele escreve as pasta no formato UTF-8 quando supostamente devia escrevr em ISO-8859-1.

Acho que o gnome por defeito escreve os ficheiros em UTF-8 como posso modificar isso, se é que dá.

PS Espero ter esplicado tudo direito.

HerkusPT
_________________
HerkusPT


Last edited by herkusPT on Mon Feb 18, 2008 8:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
herkusPT
n00b
n00b


Joined: 15 Feb 2008
Posts: 17

PostPosted: Mon Feb 18, 2008 7:52 pm    Post subject: Já resolvi o problema Reply with quote

Já resolvi o problema :p vou deixar aqui as configurações que fiz para quem quiser ou para comentários.

Configuração do kernel Linux Kernel v2.6.22-gentoo-r10 Configuration


File systems ---> DOS/FAT/NT Filesystems --->

<*> MSDOS fs support
<*> VFAT (Windows-95) fs support
(860) Default codepage for FAT │ │
(iso-8859-15) Default iocharset for FAT │ │
<*> NTFS file system support │ │
[ ] NTFS debugging support │ │
[*] NTFS write support │ │

File systems ---> --- Base native language support │ │


│ │ (iso-8859-15) Default NLS Option │ │
│ │ <M> Codepage 437 (United States, Canada) │ │
│ │ <M> Codepage 737 (Greek) │ │
│ │ <M> Codepage 775 (Baltic Rim) │ │
│ │ <M> Codepage 850 (Europe) │ │
│ │ <M> Codepage 852 (Central/Eastern Europe) │ │
│ │ <M> Codepage 855 (Cyrillic) │ │
│ │ <M> Codepage 857 (Turkish) │ │
│ │ <M> Codepage 860 (Portuguese) │ │
│ │ <M> Codepage 861 (Icelandic) │ │
│ │ <M> Codepage 862 (Hebrew) │ │
│ │ <M> Codepage 863 (Canadian French) │ │
│ │ <M> Codepage 864 (Arabic) │ │
│ │ <M> Codepage 865 (Norwegian, Danish) │ │
│ │ <M> Codepage 866 (Cyrillic/Russian) │ │
│ │ <M> Codepage 869 (Greek) │ │
│ │ <M> Simplified Chinese charset (CP936, GB2312) │ │
│ │ <M> Traditional Chinese charset (Big5) │ │
│ │ <M> Japanese charsets (Shift-JIS, EUC-JP) │ │
│ │ <M> Korean charset (CP949, EUC-KR) │ │
│ │ <M> Thai charset (CP874, TIS-620) │ │
│ │ <M> Hebrew charsets (ISO-8859-8, CP1255) │ │
│ │ <M> Windows CP1250 (Slavic/Central European Languages) │ │
│ │ <M> Windows CP1251 (Bulgarian, Belarusian) │ │
│ │ <M> ASCII (United States) │ │
│ │ <M> NLS ISO 8859-1 (Latin 1; Western European Languages) │ │
│ │ <M> NLS ISO 8859-2 (Latin 2; Slavic/Central European Languages) │ │
│ │ <M> NLS ISO 8859-3 (Latin 3; Esperanto, Galician, Maltese, Turkish) │ │
│ │ <M> NLS ISO 8859-4 (Latin 4; old Baltic charset) │ │
│ │ <M> NLS ISO 8859-5 (Cyrillic) │ │
│ │ <M> NLS ISO 8859-6 (Arabic) │ │
│ │ <M> NLS ISO 8859-7 (Modern Greek) │ │
│ │ <M> NLS ISO 8859-9 (Latin 5; Turkish) │ │
│ │ <M> NLS ISO 8859-13 (Latin 7; Baltic) │ │
│ │ <M> NLS ISO 8859-14 (Latin 8; Celtic) │ │
│ │ <*> NLS ISO 8859-15 (Latin 9; Western European Languages with Euro) │ │
│ │ <M> NLS KOI8-R (Russian) │ │
│ │ <M> NLS KOI8-U/RU (Ukrainian, Belarusian) │ │
│ │ --- NLS UTF-8 │ │
│ │

ficheiro /etc/rc.conf

# /etc/rc.conf: Global startup script configuration settings

# UNICODE specifies whether you want to have UNICODE support in the console.
# If you set to yes, please make sure to set a UNICODE aware CONSOLEFONT and
# KEYMAP in the /etc/conf.d/consolefont and /etc/conf.d/keymaps config files.

UNICODE="no"

# Set EDITOR to your preferred editor.
# You may use something other than what is listed here.

#EDITOR="/bin/nano"
EDITOR="/usr/bin/vim"
#EDITOR="/usr/bin/emacs"

# DISPLAYMANAGER has moved to /etc/conf.d/xdm

# XSESSION is a new variable to control what window manager to start
# default with X if run with xdm, startx or xinit. The default behavior
# is to look in /etc/X11/Sessions/ and run the script in matching the
# value that XSESSION is set to. The support scripts are smart enough to
# look in all bin directories if it cant find a match in /etc/X11/Sessions/,
# so setting it to "enlightenment" can also work. This is basically used
# as a way for the system admin to configure a default system wide WM,
# allthough it will work if the user export XSESSION in his .bash_profile, etc.
#
# NOTE: 1) this behaviour is overridden when a ~/.xinitrc exists, and startx
# is called.
# 2) even if ~/.xsession exists, if XSESSION can be resolved, it will
# be executed rather than ~/.xsession, else KDM breaks ...
#
# Defaults depending on what you install currently include:
#
# Gnome - will start gnome-session
# kde-<version> - will start startkde (look in /etc/X11/Sessions/)
# Xfce4 - will start a XFCE4 session
# Xsession - will start a terminal and a few other nice apps

XSESSION="Gnome"

ficheiro /etc/conf.d/keymap

# /etc/conf.d/keymaps

# Use KEYMAP to specify the default console keymap. There is a complete tree
# of keymaps in /usr/share/keymaps to choose from.

KEYMAP="pt-latin1 euro2"

# Should we first load the 'windowkeys' console keymap? Most x86 users will
# say "yes" here. Note that non-x86 users should leave it as "no".

SET_WINDOWKEYS="yes"


# The maps to load for extended keyboards. Most users will leave this as is.

#EXTENDED_KEYMAPS=""
EXTENDED_KEYMAPS="backspace keypad euro"


# Tell dumpkeys(1) to interpret character action codes to be
# from the specified character set.
# This only matters if you set UNICODE="yes" in /etc/rc.conf.
# For a list of valid sets, run `dumpkeys --help`

DUMPKEYS_CHARSET="iso-8859-15"

ficheiro /etc/conf.d/consolefont

# /etc/conf.d/consolefont

# CONSOLEFONT specifies the default font that you'd like Linux to use on the
# console. You can find a good selection of fonts in /usr/share/consolefonts;
# you shouldn't specify the trailing ".psf.gz", just the font name below.
# To use the default console font, comment out the CONSOLEFONT setting below.
# This setting is used by the /etc/init.d/consolefont script (NOTE: if you do
# not want to use it, run "rc-update del consolefont" as root).

CONSOLEFONT="lat9w-16"

# CONSOLETRANSLATION is the charset map file to use. Leave commented to use
# the default one. Have a look in /usr/share/consoletrans for a selection of
# map files you can use.

CONSOLETRANSLATION="8859-15_to_uni"

/etc/env.d/02locale

LANG="pt;pt_PT;pt_BR"
LC_CTYPE="pt_PT.ISO-8859-15"
LC_NUMERIC="pt_PT.ISO-8859-15"
LC_TIME="pt_PT.ISO-8859-15"
LC_COLLATE="pt_PT.ISO-8859-15"
LC_MONETARY="pt_PT.ISO-8859-15"
LC_MESSAGES="pt_PT.ISO-8859-15"
LC_PAPER="pt_PT.ISO-8859-15"
LC_NAME="pt_PT.iso885915"
LC_ADDRESS="pt_PT.ISO-8859-15"
LC_TELEPHONE="pt_PT.ISO-8859-15"
LC_MEASUREMENT="pt_PT.ISO-8859-15"
LC_IDENTIFICATION="pt_PT.ISO-8859-15"
LC_ALL=""
G_FILENAME_ENCODING="iso-8859-15"

Não esquecer fazer

localedef -c -i pt_PT -f ISO-8859-15 pt.PT.8859-15

env-update && source /etc/profile


Estão aqui as minhas configurações aparentemente tudo esta a funcionar bem a escrta de ficheiro já é feita corectamente.

A unica coisa que não esta a funcionar bem é o mozilla-firefox e o mozilla-thunderbierd que não sei porque mas não aparece em português, não sei porque pois tenho isto definido no

make.conf

LINGUAS="en en_US en_GB pt pt_PT pt_BR es es_ES"

perante estas configurações qual será o problema ??

obrigado e deculpem alguma coisa.
_________________
HerkusPT
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum