Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Java] Quel JDK/JRE en v6 ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Mon Feb 11, 2008 11:39 pm    Post subject: [Java] Quel JDK/JRE en v6 ? Reply with quote

Salut,

Bon voilà, j'ai quelques applis Java qui nécessitent java 1.6, et le sun-jdk me fait chier.
D'abord il est linké à alsa-0.9 alors que j'ai la version 1.x, du coup des qu'une appli joue un son elle plante.
Ensuite y'a ce bug avec xcb (toujours du aux liens du binaire proprio), bon ça spamme un peu la console mais ça marche avec LIBXCB_ALLOW_SLOPPY_LOCK="true".
Puis c'est lourd, lent.... Mais ça toutes les implémentations sont pareil !

Bon ce qui me gêne c'est surtout le problème n'° 1, mais je ne voit pas comment changer ça (j'ai déjà viré l'UseFlag alsa pour le jdk), le blackdown-jdk est toujours en 1.4 et le jdk d'ibm est aussi en binaire, donc je pense qu'il aura les mêmes problèmes de liens vers des bibliothèques obsolètes que celui de sun.

Et vous quel java utilisez-vous ?
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue Feb 12, 2008 8:10 am    Post subject: Re: [Java] Quel JDK/JRE en v6 ? Reply with quote

GentooUser@Clubic wrote:

D'abord il est linké à alsa-0.9 alors que j'ai la version 1.x, du coup des qu'une appli joue un son elle plante.

T'es sur là? j'ai le sun-jdk-1.6.0.03 avec le USE alsa et j'ai qu'une version d'alsa d'installée (1.0.15). Et de fait, si on vérifies l'ebuild:
Code:

alsa? ( media-libs/alsa-lib )

il se fiche de la version a priori. En plus il n'y a plus de version 0.9 d'alsa dans portage depuis belle lurette.
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
Bapt
Veteran
Veteran


Joined: 14 Apr 2003
Posts: 1152
Location: Paris

PostPosted: Tue Feb 12, 2008 9:12 am    Post subject: Reply with quote

Sinon tu te compile openjdk, ça marche très bien et c'est libre (je l'utilise sans problème chez moi) http://icedtea.classpath.org/wiki/Main_Page (je ne sais pas ce qu'il en est d'un point de vue ebuild, je le compile à la main.
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Tue Feb 12, 2008 2:24 pm    Post subject: Reply with quote

kwenspc -> À l'exécution j'ai ce message
Quote:
/opt/sun-jdk-1.6.0.04/bin/java: relocation error: /opt/sun-jdk-1.6.0.04/jre/lib/i386/libjsoundalsa.so: symbol __snd_pcm_hw_params_get_channels_min, version ALSA_0.9 not defined in file libasound.so.2 with link time reference


Bapt -> Je vais compiler ça dans mon home et si ça marche bien j'essaierai de faire un ebuild si y'en as pas déjà un de dispo (je déteste installer un truc sans passer par portage)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum