Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Driver] insmod OK mais pas apres reboot (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
nexus6
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2007
Posts: 92

PostPosted: Mon Feb 11, 2008 12:14 pm    Post subject: [Driver] insmod OK mais pas apres reboot (résolu) Reply with quote

Bonjour,

J'ai un petit souci sur mon laptop pour installer un pilote en module. Le pilote est un pilote pour wifi Ralink RT2860.

Malgré quelques soucis de compréhension et en allant fouiner sur google, j'ai réussi à compiler le pilote et à l'insérer avec la commande

Code:
insmod rt2860sta.ko


Tout passe bien (malgré que maintenant je me casse la tête à configurer la connexion, mais je reviendrais la dessus plus tard si je n'y arrive pas ^^). Cependant, au reboot du PC, le driver ne se charge pas.

Pour ce qui est du fichier config.mk, j'ai compilé le pilote avec le gestionnaire de réseau (wifi-radar), mais j'ai aussi installé WPA_SUPPLICANT. Mais de toute manière, je ne pense pas que mon souci de chargement automatique de pilote provienne de la.

Question : comment pourrais-je faire pour qu'au reboot le pilote se charge automatiquement?

Merci pour vos conseils !


Last edited by nexus6 on Mon Feb 11, 2008 10:24 pm; edited 3 times in total
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3098
Location: Paris

PostPosted: Mon Feb 11, 2008 12:37 pm    Post subject: Reply with quote

Ben c'est écrit dans la doc gentoo :)
Insére le nom de ton module (sans l'extension) dans /etc/modules.autoload.d/kernel-2.6 et lance update-modules et c'est fini...
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
DidgeriDude
Guru
Guru


Joined: 30 Jan 2005
Posts: 347

PostPosted: Mon Feb 11, 2008 12:44 pm    Post subject: Reply with quote

Pour un chargement automatique au démarrage, je mettrais le module rt2860sta.ko dans /lib/module/<version du moyau>/net puis un petit:
Code:
# echo "rt2860sta" >> /etc/modules.autoload.d/kernel-2.6
# update-modules
devrait faire l'affaire !
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Mon Feb 11, 2008 12:51 pm    Post subject: Reply with quote

Oui, c'est tout indiqué dans le handbook :roll:
Et le update-modules ne sert à rien là, ce n'est que pour les modifs dans le /etc/modules.d/
/etc/modules.autoload.d/kernel-2.6 est simplement lu par les scripts d'init au démarrage.

Sinon, pour ta balise du forum que tu cherches : [quote]blabla[/quote] (ou [code]blabla[/code]), et pas besoin de mettre autant d'infos pour une simple question comme ça :roll:
Back to top
View user's profile Send private message
nexus6
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2007
Posts: 92

PostPosted: Mon Feb 11, 2008 12:51 pm    Post subject: Merci ! Reply with quote

Merci beaucoup ! je testerais dés ce soir et mettrait bientôt [résolu] dans le topic :)
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3098
Location: Paris

PostPosted: Mon Feb 11, 2008 1:11 pm    Post subject: Reply with quote

geekounet wrote:
Et le update-modules ne sert à rien là, ce n'est que pour les modifs dans le /etc/modules.d/
/etc/modules.autoload.d/kernel-2.6 est simplement lu par les scripts d'init au démarrage.

Roooooh, que de chemin parcouru depuis modules-update en 2004... :)
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Mon Feb 11, 2008 1:23 pm    Post subject: Reply with quote

El_Goretto wrote:
geekounet wrote:
Et le update-modules ne sert à rien là, ce n'est que pour les modifs dans le /etc/modules.d/
/etc/modules.autoload.d/kernel-2.6 est simplement lu par les scripts d'init au démarrage.

Roooooh, que de chemin parcouru depuis modules-update en 2004... :)

Heu, de mes souvenirs depuis 2004, ça a toujours été comme ça :P
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3098
Location: Paris

PostPosted: Mon Feb 11, 2008 1:28 pm    Post subject: Reply with quote

Bah, j'ai toujours cru qu'il fallait lancer ce modules-update apres avoir modifié le fichier.
Je regarderai dans mon gentoo handbook collector de 2004 (oui, je garde tout...) si c'est la sénilité précoce qui a frappé :)
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
nexus6
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2007
Posts: 92

PostPosted: Mon Feb 11, 2008 7:30 pm    Post subject: Woops ! Reply with quote

Suite et pas encore sortie du pétrin :roll:

La tentative de l'auto-load du module s'effectue bien, mais ne fonctionne pas (failed to load driver). Je n'ai pas le message exact, le boot étant trop rapide et je n'ai rien à présenter ici qui pourrait-être extrait de /var/log.

Aussi, j'ai tentais de charger le module manuellement, et là, surprise! Le module ne se charge plus. En revanche, syslog-ng m'indique :

Code:
udev-net.sh : /etc/init.d/net.ra0 doesn't exist or is not executable
8O

Donc je vérifie le path et effectivement, net.ra0 n'existe pas (ou plus!). C'est à ne rien y comprendre. Du coup, je ne sais pas comment regénérer ce fichier qui devait exister car lors de la toute première installation, l'interface ra0 était bien pésente.

Donc, je n'ai plus la possibilité de charger ce pilote, et je n'ai pas de script pour effectuer un rc-update add.

Quelques idées seront vraiment les bienvenues :?
Back to top
View user's profile Send private message
nexus6
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2007
Posts: 92

PostPosted: Mon Feb 11, 2008 7:49 pm    Post subject: lsmod Reply with quote

Ah oui, j'oubliais :

Un lsmod m'indique bien rt2860sta

Et le modinfo :

Code:

Nexus6 ~ # modinfo rt2860sta
filename:       /lib/modules/2.6.23-gentoo-r6VerSus/kernel/net/wireless/rt2860sta.ko
description:    RT2860 Wireless Lan Linux Driver
version:        1.5.0.0
license:        GPL
vermagic:       2.6.23-gentoo-r6VerSus SMP preempt mod_unload
depends:       
alias:          pci:v00001814d00000601sv*sd*bc*sc*i*
alias:          pci:v00001814d00000681sv*sd*bc*sc*i*
alias:          pci:v00001814d00000701sv*sd*bc*sc*i*
alias:          pci:v00001814d00000781sv*sd*bc*sc*i*
srcversion:     B9CC38CC4930C9DD8ACAA24
parm:           mac:rt28xx: wireless mac addr (charp)
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Mon Feb 11, 2008 7:58 pm    Post subject: Reply with quote

Pour recréer le fichier :
Code:
cd /etc/init.d/
ln -s net.lo net.ra0

Y'a toujours pas d'outils sous Gentoo pour créer ces interfaces automatiquement en fonction du contenu de /etc/conf.d/net


Pour le module modprobe rt2860sta suivi de dmesg | tail devrais te donner plus d'infos
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3098
Location: Paris

PostPosted: Mon Feb 11, 2008 9:19 pm    Post subject: Reply with quote

@geekounet:
Hahahaaaaa, ok, c'est OFF, mais j'avais raison: en 2004 on modifiait le kernel-2.x, et on faisait ensuite modules-update "pour incorporer [nos] changements au fichier /etc/modules.conf". HAhaaaaa, j'ai encore un neurone de vaillant, ça me rassure :p
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
nexus6
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2007
Posts: 92

PostPosted: Mon Feb 11, 2008 10:23 pm    Post subject: Woo woo :) Reply with quote

GentooUser@Clubic wrote:
Pour recréer le fichier :
Code:
cd /etc/init.d/
ln -s net.lo net.ra0

Y'a toujours pas d'outils sous Gentoo pour créer ces interfaces automatiquement en fonction du contenu de /etc/conf.d/net


Pour le module modprobe rt2860sta suivi de dmesg | tail devrais te donner plus d'infos


:D Merci ça fonctionne ! Au départ pas de changement, j'ai enlevé et remis le pilote, rebooté le PC et voilà le driver chargé au démarrage !

:arrow: Résolu ! ^^
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Mon Feb 11, 2008 10:43 pm    Post subject: Reply with quote

El_Goretto wrote:
@geekounet:
Hahahaaaaa, ok, c'est OFF, mais j'avais raison: en 2004 on modifiait le kernel-2.x, et on faisait ensuite modules-update "pour incorporer [nos] changements au fichier /etc/modules.conf". HAhaaaaa, j'ai encore un neurone de vaillant, ça me rassure :p

Ha effectivement, maintenant que tu le dis, t'as raison en fait...
Ptin, alzheimer à 20 ans, c'est triste :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum