Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SSH service no work.. [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
KingYes
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2008
Posts: 142
Location: Israel

PostPosted: Sat Feb 09, 2008 5:14 pm    Post subject: SSH service no work.. [SOLVED] Reply with quote

Hey all.
I installed the SSH service, and i see running on 'ps xa' list. But its no running.. i mean i can't connect to port 22 (or other port on /etc/ssh/config....).

How i can found my mistake ?

Thanks all.


Last edited by KingYes on Sun Feb 10, 2008 2:48 am; edited 1 time in total
Back to top
View user's profile Send private message
vad3r
Guru
Guru


Joined: 02 May 2004
Posts: 461
Location: Munich, Germany

PostPosted: Sat Feb 09, 2008 5:17 pm    Post subject: Reply with quote

Please paste the output from a ssh connection: ssh -vvvvv Your.IP.Address
_________________
-- http://www.linuxaddicted.de/ | Please help to answer open questions
Back to top
View user's profile Send private message
KingYes
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2008
Posts: 142
Location: Israel

PostPosted: Sat Feb 09, 2008 5:37 pm    Post subject: Reply with quote

From 'ssh -vvvvv localhost' command:

Code:
OpenSSH_4.7p1, OpenSSL 0.9.8g 19 Oct 2007
debug1: Reading configuration data /etc/ssh/ssh_config
/etc/ssh/ssh_config: line 39: Bad configuration option: LoginGraceTime
/etc/ssh/ssh_config: line 40: Bad configuration option: PermitRootLogin
/etc/ssh/ssh_config: line 43: Bad configuration option: MaxAuthTries
/etc/ssh/ssh_config: line 63: Bad configuration option: PermitEmptyPasswords
/etc/ssh/ssh_config: line 88: Bad configuration option: UsePAM
/etc/ssh/ssh_config: line 91: Bad configuration option: AllowTcpForwarding
/etc/ssh/ssh_config: line 93: Bad configuration option: X11Forwarding
/etc/ssh/ssh_config: line 94: Bad configuration option: X11DisplayOffset
/etc/ssh/ssh_config: line 95: Bad configuration option: X11UseLocalhost
/etc/ssh/ssh_config: line 98: Bad configuration option: PrintMotd
/etc/ssh/ssh_config: line 107: Bad configuration option: UseDNS
/etc/ssh/ssh_config: line 116: Bad configuration option: Subsystem
/etc/ssh/ssh_config: line 117: Bad configuration option: AllowUsers
/etc/ssh/ssh_config: terminating, 13 bad configuration options


And, this is my config:
Code:
#   $OpenBSD: sshd_config,v 1.75 2007/03/19 01:01:29 djm Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options change a
# default value.

Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

# Only allow protocol v2 connections
Protocol 2

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 768

# Logging
# obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

# Shouldn't take more than 30secs to type a password
LoginGraceTime 30
PermitRootLogin no
#StrictModes yes
# Pam takes presidence
MaxAuthTries 3

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile   .ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication no

# Pam takes presidence
PermitEmptyPasswords no

# Change to no to disable s/key passwords
# Allow both PAM and this config (PAM first) & s/key passwords
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

# Useful for securing VNC sessions
AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes
X11DisplayOffset 10
X11UseLocalhost yes

# I usually put something really mean in /etc/motd or cron `fortune -s 150 hitchhiker`
PrintMotd yes
#PrintLastLog yes
TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
UseDNS no
#PidFile /var/run/sshd.pid
#MaxStartups 10
#PermitTunnel no

# no default banner path
#Banner /some/path

# override default of no subsystems
Subsystem   sftp   /usr/lib64/misc/sftp-server
AllowUsers MyUser

# Example of overriding settings on a per-user basis
#Match User anoncvs
#   X11Forwarding no
#   AllowTcpForwarding no
#   ForceCommand cvs server



Thanks you about your fast repaly :)
Back to top
View user's profile Send private message
MostAwesomeDude
Guru
Guru


Joined: 12 Aug 2007
Posts: 373

PostPosted: Sat Feb 09, 2008 8:29 pm    Post subject: Reply with quote

Your /etc/ssh/ssh_config appears to be a copy of your /etc/ssh/sshd_config, which is not a Good Thing. Here, you can have mine:
Code:
ForwardX11 yes
Protocol 2


Seriously, a blank /etc/ssh/ssh_config would work fine. "Protocol 2" is not a bad idea, but you probably don't need it with modern servers.
_________________
Don't believe the "n00b" under my name.
Back to top
View user's profile Send private message
KingYes
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2008
Posts: 142
Location: Israel

PostPosted: Sat Feb 09, 2008 9:16 pm    Post subject: Reply with quote

So.. what i am need change for its will run ok ?
Back to top
View user's profile Send private message
fabien29200
n00b
n00b


Joined: 12 Jun 2006
Posts: 32

PostPosted: Sat Feb 09, 2008 11:30 pm    Post subject: Reply with quote

There are 2 configuration files for ssh :

/etc/ssh/ssh_config which is the configuration for the client SSH
/etc/ssh/sshd_config which the configuration for the server SSH

And in the trace of ssh, we can see it is complaining about wrong options. These options are only for the server.
So did you copy your server configuration onto the client configuration ?

You just have to edit /etc/ssh/ssh_config.
Delete all the lines and paste the 2 lines MostAwesomeDude paste on his post. This should work after that.
Back to top
View user's profile Send private message
KingYes
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2008
Posts: 142
Location: Israel

PostPosted: Sun Feb 10, 2008 2:47 am    Post subject: Reply with quote

fabien29200 and MostAwesomeDude.. Big Thanks !! Now all work ok. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum