Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
netboot/install problems on Octane2
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message

Joined: 09 Mar 2004
Posts: 33
Location: Norway

PostPosted: Wed Feb 06, 2008 1:50 am    Post subject: netboot/install problems on Octane2 Reply with quote


Im trying to get Gentoo running on an Octane2.

                   System: IP30
                Processor: 400 Mhz R12000, with FPU
     Primary I-cache size: 32 Kbytes
     Primary D-cache size: 32 Kbytes
     Secondary cache size: 2 Mbytes
              Memory size: 2048 Mbytes
                  Network: ef0 ethernet (100/10 base-T)
                SCSI Disk: scsi(0)disk(1)
                    Audio: RAD Audio Processor
                 Graphics: ODYSSEY

This machine has no cdrom and I currently have to use serial console.

I have set up a working dhcp/bootp and tftp on my nslu2.
Im booting the machine with the following command:
bootp(): root=/dev/ram0 console=ttyS0,9600

This produces the following output:
>> bootp(): root=/dev/ram0 console=ttyS0,9600
Setting $netaddr to (from server )
Obtaining  from server
9299224+305944 entry: 0xa800000020568000

And from there on its nothing. The machine doesnt seem to freeze because I can reset it without cutting the power, it just looks like the linux kernel is not outputing to serial console.

I have tride booting it with various options: console=ttyS1,9600, with no root option and with no options at all. To no avail, the same thing happens, after the bootimage is transfered there is no more ouput to the console.

I have tried these two images: ip30-r10k+-20050530.img and ip30-r10k+-20060112.img. Same result with both.

I talked to some nice and helpfull people in #gentoo-mips@Freenode, but their advice did not help. Does anyone have a clue or hint as to how I should proceed to get this machine up and running?

It would be much appreciated :)
When in danger,
when in doubt!
Run in circles,
scream and shout!
Back to top
View user's profile Send private message
Retired Dev
Retired Dev

Joined: 20 Sep 2003
Posts: 548
Location: Brisbane, QLD, Australia

PostPosted: Fri Feb 08, 2008 9:09 am    Post subject: Reply with quote

Well... the fact that you have a PROM prompt, suggests your serial cable works... so we can rule that out. ;-) And it would seem, it is loading the kernel, but the kernel won't boot.

Silly question... what do you get if you MD5sum or SHA1sum the original compressed file?

d3270f74cbd58179ee3261fafb460aa762835d48  ip30-r10k+-20060112.img.bz2

is the SHA1sum.... the MD5sum is

be01f74a1f76e45f63b77758351186f8  ip30-r10k+-20060112.img.bz2

I doubt the image is corrupt... but just making sure. Did it decompress properly?
Stuart Longland (a.k.a Redhatter, VK4MSL)
I haven't lost my mind - it's backed up on a tape somewhere...

Gentoo/MIPS Cobalt developer, Mozilla herd member.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum