Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[UDEV] udev non mi fornisce ID_FS_TYPE [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4498
Location: Somewere around the world

PostPosted: Sat Feb 02, 2008 5:19 pm    Post subject: [UDEV] udev non mi fornisce ID_FS_TYPE [RISOLTO] Reply with quote

Non riesco ad ottenere da udev le informazioni sulla variabile ID_FS_TYPE, che dovrebbe contenere il filesystem utilizzato su un block device.

Le uniche informazioni che ottengo sono le seguenti:
Code:
heavensdoor ~ # udevinfo -q all -n /dev/sda1
P: /block/sda/sda1
N: sda1
S: disk/by-id/scsi-SATA_ST9120821A_5PL34WY9-part1
S: disk/by-id/ata-ST9120821A_5PL34WY9-part1
S: disk/by-path/pci-0000:00:1f.1-scsi-0:0:0:0-part1
E: DEVTYPE=partition
E: ID_VENDOR=ATA
E: ID_MODEL=ST9120821A
E: ID_REVISION=3.06
E: ID_SERIAL=SATA_ST9120821A_5PL34WY9
E: ID_SERIAL_SHORT=5PL34WY9
E: ID_TYPE=disk
E: ID_BUS=scsi
E: ID_ATA_COMPAT=ST9120821A_5PL34WY9
E: ID_PATH=pci-0000:00:1f.1-scsi-0:0:0:0

Tra loro dovrebbe esserci anche ID_FS_TYPE ma purtroppo non compare. Dove sta il problema? Che cosa posso fare per ottenere ID_FS_TYPE?
Uso udev-115-r1 con gentoo-sources-2.6.23-r6.

Ad esempio questo accade su una ubuntu:
Code:
udevinfo -q all -n /dev/sda1
P: /block/sda/sda1
N: sda1
S: disk/by-id/scsi-1ATA_ST3320620AS_9RV03FVK-part1
S: disk/by-id/ata-ST3320620AS_9RV03FVK-part1
S: disk/by-path/pci-0000:00:0e.0-scsi-0:0:0:0-part1
S: disk/by-uuid/b380f89b-40d8-47c3-92eb-2f0d3d788615
S: disk/by-label/DATAFS
E: DEVTYPE=partition
E: ID_VENDOR=ATA
E: ID_MODEL=ST3320620AS
E: ID_REVISION=3.AA
E: ID_SERIAL=1ATA_ST3320620AS_9RV03FVK
E: ID_SERIAL_SHORT=ATA_ST3320620AS_9RV03FVK
E: ID_TYPE=disk
E: ID_BUS=scsi
E: ID_ATA_COMPAT=ST3320620AS_9RV03FVK
E: ID_PATH=pci-0000:00:0e.0-scsi-0:0:0:0
E: ID_FS_USAGE=filesystem
E: ID_FS_TYPE=ext3
E: ID_FS_VERSION=1.0
E: ID_FS_UUID=b380f89b-40d8-47c3-92eb-2f0d3d788615
E: ID_FS_UUID_ENC=b380f89b-40d8-47c3-92eb-2f0d3d788615
E: ID_FS_LABEL=DATAFS
E: ID_FS_LABEL_ENC=DATAFS
E: ID_FS_LABEL_SAFE=DATAFS

_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne


Last edited by Cazzantonio on Mon Feb 04, 2008 2:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
comio
Advocate
Advocate


Joined: 03 Jul 2003
Posts: 2191
Location: Taranto

PostPosted: Sat Feb 02, 2008 10:39 pm    Post subject: Re: [UDEV] udev non mi fornisce ID_FS_TYPE Reply with quote

io ottengo tutte le informazioni con udev-118-r1. Non so perché a te non escano.

ciao

luigi
_________________
RTFM!!!!

e

http://www.comio.it
:)
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4498
Location: Somewere around the world

PostPosted: Sun Feb 03, 2008 8:58 am    Post subject: Reply with quote

Appunto, vorrei scoprirlo... Questa cosa mi capita in due installazioni diverse, per cui mi viene il sospetto che possa essere una cosa di kernel.

Mi faresti il favore di passarmi il tuo .config e il tuo emerge --info?
Se per comodità puoi mandarmelo per mail il mio indirizzo è il mio nick (minuscolo) su gmail.com.
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
xveilsidex
Guru
Guru


Joined: 27 Dec 2005
Posts: 370
Location: Bari

PostPosted: Sun Feb 03, 2008 9:45 am    Post subject: Reply with quote

Cazzantonio wrote:
Appunto, vorrei scoprirlo... Questa cosa mi capita in due installazioni diverse, per cui mi viene il sospetto che possa essere una cosa di kernel.

Mi faresti il favore di passarmi il tuo .config e il tuo emerge --info?
Se per comodità puoi mandarmelo per mail il mio indirizzo è il mio nick (minuscolo) su gmail.com.

Probabilmente hai ragione , perchè io ho il tuo stesso udev e il tuo stesso kernel e facendo udevinfo -q all -n /dev/sda7 mi compare ID_FS_TYPE=ext3
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4498
Location: Somewere around the world

PostPosted: Sun Feb 03, 2008 2:56 pm    Post subject: Reply with quote

@xveilsidex mica potresti mandarmi per posta il tuo .config?
Ringrazio comio ma purtroppo il suo è il file di configurazione di un kernel 2.6.24, per cui è un po' troppo diverso dal mio per poter capire esattamente le differenze sostanziali
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
xveilsidex
Guru
Guru


Joined: 27 Dec 2005
Posts: 370
Location: Bari

PostPosted: Sun Feb 03, 2008 4:16 pm    Post subject: Reply with quote

Cazzantonio wrote:
@xveilsidex mica potresti mandarmi per posta il tuo .config?
Ringrazio comio ma purtroppo il suo è il file di configurazione di un kernel 2.6.24, per cui è un po' troppo diverso dal mio per poter capire esattamente le differenze sostanziali

certo, non ci sono problemi !
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4498
Location: Somewere around the world

PostPosted: Mon Feb 04, 2008 2:49 pm    Post subject: Reply with quote

Allora, intanto grazie a tutti per i vostri file di configurazione. Ho controllato un po' la configurazione del kernel e l'unica cosa che mi è venuto in mente di abilitare è stata l'opzione CONFIG_CONFIGFS_FS.
Ho riavviato ma non era ancora cambiato nulla, al che non sapendo che fare ho semplicemente riemerso udev, e a questo punto ha funzionato 8O

Non so bene come ho risolto ma diciamo che in qualche modo ho risolto... :)
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum