Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemi DVD xine
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
vezzo
n00b
n00b


Joined: 31 Oct 2007
Posts: 27

PostPosted: Sat Feb 02, 2008 5:58 pm    Post subject: Problemi DVD xine Reply with quote

Ho un problema con i DVD nel senso che inserisco il DVD e viene montato correttamente e riesco a vedere i file vob, ma se cerco di aprire il dvd con xine mi esce un errore:

Code:

-errore nel motore di xine-
non c'è alcun plug-in di input disponibile per trattare
'dvd://'
forse la sintassi di MRL è errata o il file o lasorgente di stream non esiste.


e poi

Code:

La sorgente non può essere letta.
Può darsi che tu non abbia i permessi sufficenti, o la sorgente non contiene dati (p.e. disco non insterito)


non so davvero cosa possa essere...please qualcuno mi può aiutare?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sat Feb 02, 2008 6:13 pm    Post subject: Reply with quote

ehm... dire non funziona non basta.
Dovresti cortesemente accludere almeno le use flag con le quali hai compilato xine. A naso ti sei perso il supporto dvd ed codec per strada quindi verifica le use flag che hai impostato (mi pare che sia proprio dvd).
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
vezzo
n00b
n00b


Joined: 31 Oct 2007
Posts: 27

PostPosted: Sat Feb 02, 2008 6:37 pm    Post subject: Reply with quote

scusa ero sicuro di averle scritte....
queste sono quelle del make.conf
Code:
USE="acpi alsa -arts avahi cairo cdr dbus dvd dvdr dvdread encode gif gnome gtk hal jpeg -kde mad mp3 mpeg nvidia ogg opengl pdf png -qt3 -qt3support -qt4 quicktime samba spell svg tiff truetype vorbis win32codecs unicode X xml xvmc"

e queste di package.use
Code:
media-libs/xine-lib vcd

e per chiudere in bellezza l'output di eix
Code:
[I] media-libs/xine-lib
     Available versions:  (1)  1.1.8 ~1.1.9 1.1.9.1 ~1.1.9.1-r1 1.1.10
   {+X +a52 +alsa +dts +dvd +mad +modplug +musepack +theora +v4l +vorbis +xcb +xv -aalib -arts -debug -fbcon -flac -gtk -imagemagick -jack -libcaca -mmap -oss -real -samba -truetype X a52 aac aalib alsa altivec arts debug directfb dts dvd dxr3 esd fbcon flac gnome gtk imagemagick ipv6 jack libcaca mad mmap mng modplug musepack nls opengl oss pulseaudio real samba sdl speex theora truetype v4l vcd vidix vorbis wavpack win32codecs xcb xinerama xv xvmc}
     Installed versions:  1.1.10(1)(14:10:25 02/02/2008)(X a52 alsa dts dvd gnome gtk ipv6 mad modplug musepack nls opengl samba theora truetype v4l vcd vorbis win32codecs xcb xv xvmc -aac -aalib -altivec -arts -debug -directfb -dxr3 -esd -fbcon -flac -imagemagick -jack -libcaca -mmap -mng -oss -pulseaudio -real -sdl -speex -vidix -wavpack -xinerama)
     Homepage:            http://xine.sourceforge.net
     Description:         Core libraries for Xine movie player

Il fatto è che ho cercato in ogni dove ma il mio problema non l'ha avuto nessuno e l'unico che l'ha avuto ha aggiunto il suo utente al gruppo optical e tutto ha funzionato tra le altre cose ho avuto lo stesso problema con k3b prima di decidere di passare a gnome.
Back to top
View user's profile Send private message
Flameeyes
Retired Dev
Retired Dev


Joined: 30 Mar 2005
Posts: 187
Location: Dublin, Ireland

PostPosted: Sat Feb 02, 2008 7:15 pm    Post subject: Reply with quote

Usa dvd:/ non dvd://, altrimenti prova ad aprire / come percorso del DVD.
_________________
You want to know what I'm working on right now? Just follow my blog.
Back to top
View user's profile Send private message
vezzo
n00b
n00b


Joined: 31 Oct 2007
Posts: 27

PostPosted: Sat Feb 02, 2008 7:21 pm    Post subject: Reply with quote

uguale stessi errori a parte che /dev/hdb è diventato /dev/dvd
Back to top
View user's profile Send private message
HoX
Guru
Guru


Joined: 11 Nov 2006
Posts: 385

PostPosted: Sat Feb 02, 2008 9:07 pm    Post subject: Reply with quote

Su vlc la path da dare è dvd:///dev/dvd (nb: 3 slash dopo dvd:) e penso che la stessa cosa valga per xine. Provare per credere
Back to top
View user's profile Send private message
vezzo
n00b
n00b


Joined: 31 Oct 2007
Posts: 27

PostPosted: Sat Feb 02, 2008 10:59 pm    Post subject: Reply with quote

nulla ne con xine ne con vlc se però passo i vob funzia tutto
Back to top
View user's profile Send private message
Flameeyes
Retired Dev
Retired Dev


Joined: 30 Mar 2005
Posts: 187
Location: Dublin, Ireland

PostPosted: Sat Feb 02, 2008 11:21 pm    Post subject: Reply with quote

No, per xine NON ci vanno tre slash.

Assicurati che /dev/dvd esista, che sia leggibile dal tuo utente, e prova --verbose=3
_________________
You want to know what I'm working on right now? Just follow my blog.
Back to top
View user's profile Send private message
vezzo
n00b
n00b


Joined: 31 Oct 2007
Posts: 27

PostPosted: Sun Feb 03, 2008 7:52 am    Post subject: Reply with quote

se facci un ls -al in /dev trovo:
Code:
lrwxrwxrwx  1 root root             3  3 feb  2008 cdrom -> hda
lrwxrwxrwx  1 root root             3  3 feb  2008 cdrom1 -> hdb
lrwxrwxrwx  1 root root             3  3 feb  2008 cdrw -> hda
lrwxrwxrwx  1 root root             3  3 feb  2008 dvd -> hda
lrwxrwxrwx  1 root root             3  3 feb  2008 dvd1 -> hdb
lrwxrwxrwx  1 root root             3  3 feb  2008 dvdrw -> hda

quindi a quanto sembra il device è leggibile dal mio utente!!!!!
Back to top
View user's profile Send private message
HoX
Guru
Guru


Joined: 11 Nov 2006
Posts: 385

PostPosted: Sun Feb 03, 2008 10:43 am    Post subject: Reply with quote

vezzo wrote:
se facci un ls -al in /dev trovo:
Code:
lrwxrwxrwx  1 root root             3  3 feb  2008 cdrom -> hda
lrwxrwxrwx  1 root root             3  3 feb  2008 cdrom1 -> hdb
lrwxrwxrwx  1 root root             3  3 feb  2008 cdrw -> hda
lrwxrwxrwx  1 root root             3  3 feb  2008 dvd -> hda
lrwxrwxrwx  1 root root             3  3 feb  2008 dvd1 -> hdb
lrwxrwxrwx  1 root root             3  3 feb  2008 dvdrw -> hda

quindi a quanto sembra il device è leggibile dal mio utente!!!!!


potresti descrivere un attimo la tua macchina? hai due unita cdrom? gli hd sono sata? Io (con un cdrom) avevo solo hdc... hda e hdb erano riservate per gli harddisk (che tra l'altro non avevo perche' era SATA=sda)
Back to top
View user's profile Send private message
vezzo
n00b
n00b


Joined: 31 Oct 2007
Posts: 27

PostPosted: Sun Feb 03, 2008 11:02 am    Post subject: Reply with quote

le unità sono :

/dev/sda -> Hard Disk SATA
/dev/hda -> Masterizzatore DVD
/dev/hdb -> Lettore DVD
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sun Feb 03, 2008 11:14 am    Post subject: Reply with quote

sei nei gruppi corretti?

se esegui
Code:
xine dvd://path_dove_è_montato_il_dvd

(di solito il path, se usi gnome-mount, è tipo /media/titolo_del_dvd)

funziona?
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
vezzo
n00b
n00b


Joined: 31 Oct 2007
Posts: 27

PostPosted: Sun Feb 03, 2008 11:19 am    Post subject: Reply with quote

adesso mi funziona però esce:
Code:
Questo è xine (X11 gui) - un riproduttore video libero v0.99.5.
(c) 2000-2007 Team di xine.
libdvdread: Using libdvdcss version 1.2.9 for DVD access
libdvdread: Attempting to use device /dev/hdb mounted on /media/MAX_COTTAFAVI___FEDE_POGGIPOLL for CSS authentication
libdvdread: Could not open /dev/hdb with libdvdcss.
libdvdread: Can't open /dev/hdb for reading
libdvdread: Device /dev/hdb inaccessible, CSS authentication not available.

*** libdvdread: CHECK_VALUE failed in nav_read.c:356 ***
*** for dsi->dsi_gi.zero1 == 0 ***


*** libdvdread: CHECK_VALUE failed in ../input/libdvdnav/nav_read.c:356 ***
*** for dsi->dsi_gi.zero1 == 0 ***


e non posso però selezionare il dvd dalla barra dei controlli...
Back to top
View user's profile Send private message
Flameeyes
Retired Dev
Retired Dev


Joined: 30 Mar 2005
Posts: 187
Location: Dublin, Ireland

PostPosted: Sun Feb 03, 2008 12:52 pm    Post subject: Reply with quote

vezzo wrote:
se facci un ls -al in /dev trovo:
Code:
lrwxrwxrwx  1 root root             3  3 feb  2008 cdrom -> hda
lrwxrwxrwx  1 root root             3  3 feb  2008 cdrom1 -> hdb
lrwxrwxrwx  1 root root             3  3 feb  2008 cdrw -> hda
lrwxrwxrwx  1 root root             3  3 feb  2008 dvd -> hda
lrwxrwxrwx  1 root root             3  3 feb  2008 dvd1 -> hdb
lrwxrwxrwx  1 root root             3  3 feb  2008 dvdrw -> hda

quindi a quanto sembra il device è leggibile dal mio utente!!!!!


No. Tu stai guardando i symlink. I symlink hanno _sempre_ i permessi a lrwxrwxrwx. Ciò non influisce sul fatto se tu possa accedere o meno ai _veri_ dispositivi.

Code:
ls -l /dev/hd{a,b}


Questo è il comando utile.
_________________
You want to know what I'm working on right now? Just follow my blog.
Back to top
View user's profile Send private message
vezzo
n00b
n00b


Joined: 31 Oct 2007
Posts: 27

PostPosted: Sun Feb 03, 2008 9:32 pm    Post subject: Reply with quote

ecco quello che vedo
Code:

# ls -l /dev/hd{a,b}
brw-rw-rw- 1 root cdrom 3,  0 Feb  3  2008 /dev/hda
brw-rw-rw- 1 root cdrom 3, 64 Feb  3  2008 /dev/hdb
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Sun Feb 03, 2008 9:55 pm    Post subject: Reply with quote

Verifica che il tuo utente appartenga al gruppo cdrom.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
vezzo
n00b
n00b


Joined: 31 Oct 2007
Posts: 27

PostPosted: Sun Feb 03, 2008 10:08 pm    Post subject: Reply with quote

Scen wrote:
Verifica che il tuo utente appartenga al gruppo cdrom.

appartiene
Back to top
View user's profile Send private message
xveilsidex
Guru
Guru


Joined: 27 Dec 2005
Posts: 370
Location: Bari

PostPosted: Mon Feb 04, 2008 10:07 am    Post subject: Reply with quote

ma se ti logghi come root riesci ad aprire xine e ad aprire i file?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Feb 04, 2008 11:04 am    Post subject: Reply with quote

Code:
brw-rw-rw-
ma non è un tantino strano? Io un device a blocchi world writable non lo ho mai visto.

Hai hal/dbus installati? Prova un revdep-rebuild od un emerge -1 e verifica che non ci siano regole strane aggiunte ad udev. Non è che hai tutto il sistema ~x86? Quale kernel usi? etc.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
pi.rosset
n00b
n00b


Joined: 05 Jan 2008
Posts: 7

PostPosted: Mon Feb 04, 2008 3:58 pm    Post subject: Reply with quote

Non vorrei dire una stupidaggine ma avevo lo stesso problema e l'ho risolto dentro il pannello di controllo di Xine (si apre cliccando sulla chiave inglese) e alla voce media, se non mi sbaglio, al posto di /dev/dvd gli ho messo il lettore, nel tuo caso /dev/hdb e dopo tutto ha funzionato regolarmente.
Non è che in fstab monti /dev/hdb da qualche parte?
Back to top
View user's profile Send private message
vezzo
n00b
n00b


Joined: 31 Oct 2007
Posts: 27

PostPosted: Mon Feb 04, 2008 10:13 pm    Post subject: Reply with quote

appunto mi ha tolto rw a g e o adesso ho solo brw------- però non funziona, anche dandogli il mio lettore dvd nel pannello di controllo...mi dice sempre che manca sto benedetto plug-in per leggere dvd:/ ho guardato anche sulle faq di xine e non dice nulla...
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Tue Feb 05, 2008 8:32 am    Post subject: Reply with quote

mhh.. ripeto.. ma se da console dai:
Code:
xine dvd://path_dove_è_montato_il_dvd

va o no?
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
vezzo
n00b
n00b


Joined: 31 Oct 2007
Posts: 27

PostPosted: Wed Feb 06, 2008 8:42 am    Post subject: Reply with quote

Si funziona, vedo il video e funzionano i menu, vanno i dvd originali e quelli fatti da me...però mi escono gli errori riportati sopra:

Code:
Questo è xine (X11 gui) - un riproduttore video libero v0.99.5.
(c) 2000-2007 Team di xine.
libdvdread: Using libdvdcss version 1.2.9 for DVD access
libdvdread: Attempting to use device /dev/hdb mounted on /media/MAX_COTTAFAVI___FEDE_POGGIPOLL for CSS authentication
libdvdread: Could not open /dev/hdb with libdvdcss.
libdvdread: Can't open /dev/hdb for reading
libdvdread: Device /dev/hdb inaccessible, CSS authentication not available.

*** libdvdread: CHECK_VALUE failed in nav_read.c:356 ***
*** for dsi->dsi_gi.zero1 == 0 ***


*** libdvdread: CHECK_VALUE failed in ../input/libdvdnav/nav_read.c:356 ***
*** for dsi->dsi_gi.zero1 == 0 ***
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum