Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
errore wine (installazione sw)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Fri Feb 01, 2008 7:08 pm    Post subject: errore wine (installazione sw) Reply with quote

Ciao. Io sto provando a installare un sw per gestire la stampa su cd con una stampante epson... l'ho installato con wine, ma sembrano esserci degli errori...

Code:

wine setup.exe
err:wineboot:pendingRename couldn't get file attributes (2)
err:wineboot:pendingRename couldn't get file attributes (2)
err:wineboot:pendingRename couldn't get file attributes (2)
fixme:spoolsv:serv_main (0 (nil))
Xlib:  extension "GLX" missing on display ":0.0".
err:wgl:X11DRV_WineGL_InitOpenglInfo  couldn't initialize OpenGL, expect problems
Xlib:  extension "GLX" missing on display ":0.0".
err:wgl:X11DRV_WineGL_InitOpenglInfo  couldn't initialize OpenGL, expect problems
matteo@morgan ~/Desktop/epson_pr/Printcd $ Xlib:  extension "GLX" missing on display ":0.0".
err:wgl:X11DRV_WineGL_InitOpenglInfo  couldn't initialize OpenGL, expect problems
err:ole:TLB_ReadTypeLib Loading of typelib L"c:\\Programmi\\Common Files\\InstallShield\\Professional\\RunTime\\IsProBE.tlb" failed with error 2


secondo voi quale può essere l' "error 2"?
Back to top
View user's profile Send private message
DANNO__
n00b
n00b


Joined: 30 Dec 2006
Posts: 20

PostPosted: Fri Feb 01, 2008 9:52 pm    Post subject: Reply with quote

Ma funzionano sti programmini???Io ho un hp ed esiste una suite apposita per linux :wink:
Da poco hai aggiornato x?Prova a dare eselect opengl set tuaschedavideo ,per il resto non so,prova a cercare nella lista compatibilità di wine,magari li trovi qualcosa
_________________
Il futuro è oggi...hardmask very-unstable at your own risk ~amd64
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Fri Feb 01, 2008 10:23 pm    Post subject: Reply with quote

Code:
$eselect opengl list
Available OpenGL implementations:
  [1]   xorg-x11 *


non ho molta scelta :D

ma il programmino hp per linux.. è per poter stampare su cd? ma immagino funzioni solo con stampanti hp.. vero? :(
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Sat Feb 02, 2008 9:13 am    Post subject: Reply with quote

Mah, l'errore fa pensare che ci sia appunto qualche problema sulle librerie OpenGL.

Con che USE hai compilato Wine? L'accelerazione 3D funziona correttamente? Che scheda video hai?
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Sat Feb 02, 2008 1:08 pm    Post subject: Reply with quote

secondo me il problema forse è opengl.. anche con ppracer (un giochino con tux che scivola sulla neve) ho problemi, non parte, e mi da errore GLX

La mia scheda video è una intel i865 integrata (driver xorg i810)


le USE di wine
Code:
app-emulation/wine-0.9.54  USE="X alsa cups dbus esd hal jpeg lcms ldap ncurses opengl scanner xml -gecko -jack -nas -oss -samba"
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Sat Feb 02, 2008 1:21 pm    Post subject: Reply with quote

lordalbert wrote:
secondo me il problema forse è opengl.. anche con ppracer (un giochino con tux che scivola sulla neve) ho problemi, non parte, e mi da errore GLX

E allora il problema non è Wine, ma la configurazione dell'accelerazione 3D del tuo sistema.

Hai seguito la Guida all'accelerazione hardware 3d?

Code:

glxinfo |grep rendering

restituisce
Code:

direct rendering: Yes

?

Il tuo utente appartiene al gruppo video?
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Sat Feb 02, 2008 3:45 pm    Post subject: Reply with quote

allora... ho scoperto che non avevo abilitato ne glx ne drm :D
Ho seguito la guida che mi hai indicato, ho compilato un paio di moduli nel kernel ed ora glx sembra abilitato... anche se

Code:
$ glxinfo|grep rendering
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)



Edit:

Ho provato adesso... e il risultato è diverso..

Code:

$ wine setup.exe
fixme:spoolsv:serv_main (0 (nil))
err:advapi:service_get_status service protocol error - failed to read pipe r = 0  count = 0!


Prima però si apriva la finestra dell'installer, adesso non più... cioè, nella barra delle applicazioni in basso c'è, però non si vede
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum