Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Странное "почти повисание" клавиатуры в xorg
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
nilreM
n00b
n00b


Joined: 22 Nov 2007
Posts: 19
Location: Voronezh

PostPosted: Thu Jan 31, 2008 9:41 am    Post subject: Странное "почти повисание" клавиатуры в xorg Reply with quote

С некоторых пор наблюдаю странное поведение клавиатуры в Xorg. Именно, всё отлично работает до некоторого момента... после чего клавиатура начинает дико тормозить.

После проявления проблемы, реакция системы на клавиши становится сильно замедленной. Т.е. чтобы напечатался символ, нужно держать клавишу секунды две-три. После этого, печатается символ и после обычной задержки (ок. 250мс) начинается нормальное его повторение как будто проблемы нет. После отжатия повторение прекращается немедленно. Задержка происходит только до первого появления символа и больше нигде.

Это касается не только алфавито-цифровых клавиш, а всех клавиш вообще. Т.е. чтобы нажать например Ctrl+Shift+A, нужно нажать Ctrl, подержать пару секунд, не отпуская нажать Shift, подержать их вместе пару секунд, и уже нажать A. Через пару секунд наступит реакция.

Мышь не глючит и система не тормозит вообще, т.е. при этом можно спокойно смотреть видео и т. д., работать с мышью.

После проявления, проблема локально решается перелогином в KDE, после чего опять может возникнуть. Система может проработать идеально несколько суток, или двадцать минут. Для проявления обязательно необходимо взамодействовать одновременно с мышью и клавиатурой. Чётко и гарантированно воспроизвести не получается, но замечаю, что чаще всего это проявляется, когда используется одновременно клавиатура и мышь, причём при комбинациях типа "нажал и удержи клавишу, далее протяжка мышью, потом отпускание мыши, потом клавиши", например, при выделении текста в окне konsole, в которой запущен mc.

Я использую kkbswitch в режиме переключателя, "по раскладке для каждого приложения".
Клавиатура настроена в xorg.conf следующим образом:
Code:

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option "XkbModel" "pc105"
    Option "XkbRules" "xorg"
    Option "XkbLayout" "us,ru(winkeys)"
    Option "XkbOptions"  "grp:ctrl_shift_toggle"
EndSection

Версии ПО: xorg-x11-7.2, xorg-server-1.3.0.0-r4, xf86-input-keyboard-1.1.1, xf86-input-mouse-1.2.3, setxkbmap-1.0.4, xmodmap-1.0.3, kkbswitch-1.4.3
Хотя, однако, недавно обновились некоторые из пакетов, связанных с Xorg (server, input-mouse), но проблема не исчезла.

Клавиатура Mitsumi Classic PS/2, материнская плата на машине на базе чипсета Intel 865PERL.

На других машинах с идентичной либо аналогичной настройкой, подобных странностей ни разу не замечал.

-----

Господа, так работать можно, но напрягает. :(
Посоветуйте что-нибудь для локализации и решения проблемы несчастному гентушнику :)
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Sun Feb 03, 2008 8:18 pm    Post subject: Reply with quote

В mc пару раз такое наблюдал.
Без него вроде бы нет.

Проверь если такое случается mc запущен или нет?

Если запущен, то скорее всего проблема с ним.
_________________
Lefsha
Back to top
View user's profile Send private message
nilreM
n00b
n00b


Joined: 22 Nov 2007
Posts: 19
Location: Voronezh

PostPosted: Sun Feb 03, 2008 8:26 pm    Post subject: Reply with quote

Quote:
Для проявления обязательно необходимо взамодействовать одновременно с мышью и клавиатурой. Чётко и гарантированно воспроизвести не получается, но замечаю, что чаще всего это проявляется, когда используется одновременно клавиатура и мышь, причём при комбинациях типа "нажал и удержи клавишу, далее протяжка мышью, потом отпускание мыши, потом клавиши", например, при выделении текста в окне konsole, в которой запущен mc.

Замечал, что такое случается с запущеным mc, причём, даже если mc - запущен где-то там через ssh. При этом, глюки распространяюся на всю систему.

Сомневаюсь, что это mc виноват. Почему это на X тогда распространяется, а не ограничивается конкрентым mc и не прекращается после выхода из него мышкой? Наблюдал такое и в консольном mysql-клиенте - тут уже точно mc не при чём.
Back to top
View user's profile Send private message
kolen
n00b
n00b


Joined: 05 Apr 2008
Posts: 2

PostPosted: Sat Apr 05, 2008 9:17 pm    Post subject: Reply with quote

Такая же проблема. При подвисании включается автоповтор символа. mc никак не влияет. Помогает перезагрузка, и то не всегда. Работает нормально до следующей перезагрузки.
Такое только в иксах, в консоли не наблюдается.
Back to top
View user's profile Send private message
nuclear-90
n00b
n00b


Joined: 25 Jan 2008
Posts: 6

PostPosted: Sun Apr 06, 2008 3:59 am    Post subject: Reply with quote

так же было и в убунте,помогло обновление пакетов :x
Back to top
View user's profile Send private message
kolen
n00b
n00b


Joined: 05 Apr 2008
Posts: 2

PostPosted: Sun Apr 06, 2008 3:20 pm    Post subject: Reply with quote

В общем, проблема оказалась в USB-мыши. dmesg выдает:
Code:
usb 1-1: reset low speed USB device using ohci_hcd and address 13


Если выдернуть мышь из USB и воткнуть обратно, иногда помогает. Говорят, что решается выгрузкой модуля usbhid и загрузкой вместо него usbmouse и usbkeyboard.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum