Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
проблема с udev и atheros 5212
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
phx_ern
n00b
n00b


Joined: 18 May 2007
Posts: 9

PostPosted: Wed Jan 30, 2008 6:37 pm    Post subject: проблема с udev и atheros 5212 Reply with quote

обновился до ядра 2.6.24-gentoo. проблема с драйвером беспроводной сети - rt2500. до обновления был пакет из портежа rt2500, утсановив ядро скомпилил модулем rt2500pci.
сразу же новый драйвер потребовал устройва wlan0 которое я создал в /etc/init.d и прописал в /etc/udev/rules.d/70-persistent-net.rules (заменил имя интерфейса с ra0 на wlan0) а так же подредактировал /etc/conf.d/net
при загрузке во время того как udev загружает модули происходит задержка секунд в 30 после чего вылезает сообщение
Code:
* UDEV: your system has a problem with assigning
* persistent names to following devices: wmaster0_rename
* Checking persistent-net rules:
* The rules create multiple entries assigning these names:
*   wmaster0


ifconfig -a:
Code:
eth0      Link encap:Ethernet  HWaddr 00:16:17:51:99:46
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:19 Base address:0x8000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wlan0     Link encap:Ethernet  HWaddr 00:13:D3:84:FE:1B
          inet addr:192.168.0.12  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::213:d3ff:fe84:fe1b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1474 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1471 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1338235 (1.2 Mb)  TX bytes:298352 (291.3 Kb)

wmaster0_ Link encap:UNSPEC  HWaddr 00-13-D3-84-FE-1B-42-e5-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)


cat /etc/udev/rules.d/70-persistent-net.rules:
Code:
# This file was automatically generated by the /lib/udev/write_net_rules
# program, probably run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single line.

# PCI device 0x1814:0x0201 (rt2500pci)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:13:d3:84:fe:1b", NAME="wlan0" - это я отредактировал

# PCI device 0x1814:0x0201 (rt2500pci) ipv6
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:13:d3:84:fe:1b:42:e5:00:00:00:00:00:00:00:00", NAME="wmaster0" - это я сам придумал исходя из ifconfig и предыдущей записи.

# PCI device 0x10ec:0x8168 (r8169)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:16:17:51:99:46", NAME="eth0"


получается что udev врет и нет нескольких таких записей которые описывают устройство wmaster0 (rules create multiple entries assigning these names: wmaster0)
cat /etc/udev/rules.d/* | grep wmaster выдает только мою запись.
пробовал ее(запись для wmaster0) вообще комментировать знаком # - то же самое

нид хелп.
кстати устройство wlan0 исправно работает, инет есть, но 20-30 секунд от загрузки это не мало, согласитесь=)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum