Joined: 12 May 2004
|Posted: Sun Jan 27, 2008 6:26 pm Post subject: [ GLSA 200801-12 ] xine-lib: User-assisted execution of arbi
|Gentoo Linux Security Advisory
Title: xine-lib: User-assisted execution of arbitrary code (GLSA 200801-12)
Date: January 27, 2008
xine-lib is vulnerable to multiple heap-based buffer overflows when
processing RTSP streams.
xine-lib is the core library package for the xine media player.
Vulnerable: < 22.214.171.124
Unaffected: >= 126.96.36.199
Architectures: All supported architectures
Luigi Auriemma reported that xine-lib does not properly check
boundaries when processing SDP attributes of RTSP streams, leading to
heap-based buffer overflows.
An attacker could entice a user to play specially crafted RTSP video
streams with a player using xine-lib, potentially resulting in the
execution of arbitrary code with the privileges of the user running the
There is no known workaround at this time.
All xine-lib users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/xine-lib-188.8.131.52"
Last edited by GLSA on Wed May 22, 2013 4:26 am; edited 2 times in total