Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
The desktop-effects overlay
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 14, 15, 16, 17  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ebichu
Apprentice
Apprentice


Joined: 03 Jul 2002
Posts: 231
Location: Manchester, England

PostPosted: Wed Mar 18, 2009 3:44 pm    Post subject: Reply with quote

keenblade wrote:
ebichu wrote:
...
EDIT: Actually I think it's because it's picking up the wrong KDE include files from /usr/include (installed by kdelibs:4.2) instead of from /usr/kde/3.5/include (installed by kdelibs:3.5). I don't have the kdeprefix use-flag set.

Hi, ebichu. You are right. I already mentioned this in my previous post. Use the patch there. It will work with the stable release, too :

keenblade wrote:

I can't emerge compizconfig-backend-kconfig-9999 for a long time. Anyone can nowadays?
...
There is a working patch for this bug at bugzilla. Could you apply it to the compizconfig-backend-kconfig-9999.ebuild ?
Solution is to run 'configure' without any prefix or as proposed in the patch, set it to correct 'kde-dir' read using 'kde-config -prefix'

Thanks keenblade, though I don't seem to have anything depending on compizconfig-backend-kconfig any more, so I no longer need to build it! EDIT: Ignore that, I didn't have compiz-fusion installed so it wasn't depending on compizconfig-backend-kconfig.

EDIT: It built fine with your patch. Thanks again, keenblade!
_________________
Ebichu wa chiizu ga daisuki dechu!


Last edited by ebichu on Wed Mar 18, 2009 6:05 pm; edited 2 times in total
Back to top
View user's profile Send private message
eros
n00b
n00b


Joined: 13 Mar 2004
Posts: 34

PostPosted: Wed Mar 18, 2009 3:51 pm    Post subject: Reply with quote

To anyone using compiz 0.8.2 ebuilds + nvidia-drivers and it's having redraw issues, there's a patch that's done wonders to me (works great!).

I have updated the compiz-plugins-main ebuild to apply the patch (local overlay), if anyone wants it please let me know.
_________________
w00t
Back to top
View user's profile Send private message
sternklang
Veteran
Veteran


Joined: 10 Sep 2005
Posts: 1641
Location: Somewhere in time and space

PostPosted: Thu Mar 19, 2009 2:58 am    Post subject: Reply with quote

eros wrote:
To anyone using compiz 0.8.2 ebuilds + nvidia-drivers and it's having redraw issues, there's a patch that's done wonders to me (works great!).

I have updated the compiz-plugins-main ebuild to apply the patch (local overlay), if anyone wants it please let me know.

compiz-plugins-main 0.8.2 in the destkop-effects overlay has been updated with this patch as well.
Back to top
View user's profile Send private message
mrazvan
n00b
n00b


Joined: 21 Nov 2006
Posts: 7
Location: Bucharest, Romania

PostPosted: Wed Mar 25, 2009 6:38 pm    Post subject: Reply with quote

[SOLVED] It seems that compiz-fusion from desktop-effects has new dependecies so everything is pulled in correctly. I just updated compiz-fusion.

sternklang wrote:
compiz-plugins-main 0.8.2 in the destkop-effects overlay has been updated with this patch as well.


Hello,

I have compiz-fusion installed on my system and I'm experiencing the nvidia redraw problem. I have checked compiz-fusion's dependencies and I can see it uses compiz-fusion-plugins-main, and not compiz-plugins-main. Although compiz-fusion-plugins-main is also in the desktop-effects overlay, only compiz-plugins-main is patched, right ? Does that mean i have to use compiz and not compiz-fusion from desktop-effects to get the patch ?

Any help is appreciated,
Razvan.
Back to top
View user's profile Send private message
overkll
Veteran
Veteran


Joined: 21 Sep 2004
Posts: 1249
Location: Austin, Texas

PostPosted: Wed Mar 25, 2009 7:13 pm    Post subject: Reply with quote

Ditto. What's the difference between compiz-plugins and compiz-fusion-plugins?
Back to top
View user's profile Send private message
DeathCarrot
Tux's lil' helper
Tux's lil' helper


Joined: 04 May 2006
Posts: 93
Location: Southampton, United Kingdom

PostPosted: Thu Mar 26, 2009 1:54 am    Post subject: Reply with quote

Compiz Fusion is being merged back into Compiz, so all you need is the Compiz stuff if desktop-effects is up to date with their package naming.
Back to top
View user's profile Send private message
Uncle_Psychosis
Guru
Guru


Joined: 31 Jan 2004
Posts: 387

PostPosted: Mon Apr 06, 2009 9:33 am    Post subject: Reply with quote

Eek!

Code:
 # emerge -uDavt world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libcompizconfig:0

  ('ebuild', '/', 'x11-libs/libcompizconfig-0.8.2', 'merge') pulled in by
    x11-libs/libcompizconfig required by world
    ~x11-libs/libcompizconfig-0.8.2 required by ('ebuild', '/', 'x11-libs/compizconfig-backend-kconfig-0.8.2', 'merge')
    ~x11-libs/libcompizconfig-0.8.2 required by ('ebuild', '/', 'dev-python/compizconfig-python-0.8.2', 'merge')
    (and 1 more)

  ('installed', '/', 'x11-libs/libcompizconfig-9999', 'nomerge') pulled in by
    x11-libs/libcompizconfig required by world
    ~x11-libs/libcompizconfig-9999 required by ('installed', '/', 'dev-python/compizconfig-python-9999', 'nomerge')

x11-wm/compiz:0

  ('installed', '/', 'x11-wm/compiz-9999', 'nomerge') pulled in by
    ~x11-wm/compiz-9999 required by ('installed', '/', 'dev-python/compizconfig-python-9999', 'nomerge')
    ~x11-wm/compiz-9999 required by ('installed', '/', 'x11-libs/libcompizconfig-9999', 'nomerge')
    x11-wm/compiz required by world
    (and 1 more)

  ('ebuild', '/', 'x11-wm/compiz-0.7.8-r3', 'merge') pulled in by
    ~x11-wm/compiz-0.7.8 required by ('ebuild', '/', 'x11-plugins/compiz-fusion-plugins-extra-0.7.8', 'merge')
    x11-wm/compiz required by world

  ('ebuild', '/', 'x11-wm/compiz-0.8.2', 'merge') pulled in by
    ~x11-wm/compiz-0.8.2 required by ('ebuild', '/', 'x11-libs/compizconfig-backend-kconfig-0.8.2', 'merge')
    ~x11-wm/compiz-0.8.2 required by ('ebuild', '/', 'x11-libs/libcompizconfig-0.8.2', 'merge')
    x11-wm/compiz required by world
    (and 1 more)

dev-python/compizconfig-python:0

  ('ebuild', '/', 'dev-python/compizconfig-python-0.8.2', 'merge') pulled in by
    dev-python/compizconfig-python required by world
    ~dev-python/compizconfig-python-0.8.2 required by ('ebuild', '/', 'x11-apps/ccsm-0.8.2', 'merge')

  ('installed', '/', 'dev-python/compizconfig-python-9999', 'nomerge') pulled in by
    dev-python/compizconfig-python required by world
    ~dev-python/compizconfig-python-9999 required by ('installed', '/', 'x11-apps/fusion-icon-9999', 'nomerge')

x11-libs/compiz-bcop:0

  ('ebuild', '/', 'x11-libs/compiz-bcop-0.7.8', 'merge') pulled in by
    ~x11-libs/compiz-bcop-0.7.8 required by ('ebuild', '/', 'x11-plugins/compiz-fusion-plugins-extra-0.7.8', 'merge')
    x11-libs/compiz-bcop required by world

  ('ebuild', '/', 'x11-libs/compiz-bcop-0.8.2', 'merge') pulled in by
    x11-libs/compiz-bcop required by world


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy "~x11-plugins/compiz-plugins-main-0.8.2" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-plugins/compiz-plugins-main-0.8.2 (masked by: ~x86 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "x11-wm/compiz-fusion-0.8.2" [ebuild])
(dependency required by "world" [argument])


Any ideas? I have all the compiz packages in package.keywords with the "**" flag (is this sensible by the way?)
Back to top
View user's profile Send private message
overkll
Veteran
Veteran


Joined: 21 Sep 2004
Posts: 1249
Location: Austin, Texas

PostPosted: Mon Apr 06, 2009 2:29 pm    Post subject: Reply with quote

As far as I can tell, the "live" (-9999) ebuilds have been removed from the overlay. I changed /etc/portage/package.keywords to use the -0.8.2 versions, and compiz only, not compiz-fusion packages.
Back to top
View user's profile Send private message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 911
Location: Mount Vernon, NY

PostPosted: Mon Apr 06, 2009 11:20 pm    Post subject: Reply with quote

Anyone else having problems running compiz-fusion on kernel 2.6.29? When I run that kernel, compiz will start but the computer will freeze at the splash screen. Doesn't happen on the 2.6.28 kernel. Compiz is latest from overlay, not live ebuilds.
_________________
Billy DeVincentis
Back to top
View user's profile Send private message
overkll
Veteran
Veteran


Joined: 21 Sep 2004
Posts: 1249
Location: Austin, Texas

PostPosted: Tue Apr 07, 2009 12:28 am    Post subject: Reply with quote

I don't have that issue, but...

In Gnome, everytime I go to shutdown or restart, the system locks up when the dialog box shows up. This also happens when I go to shutdown gedit. If I switch the window manager back to metacity, both work perfectly. I had both issues with 2.6.28 as well.

I believe it's an issue with the nvidia-drivers/compiz combination. This behaviour didn't start until nvidia-180* versions.

Other than that 2.6.29 works great for me, especially the ath9k wireless driver. :D

I saw a thread here re 2.6.29 issues, the most prevelant was the forcedeth net driver locking up the system. I think there were other net drivers that caused the same issue. I have another desktop machine (via velocity net driver), and it doesn't like 2.6.29 either. Random lockups. I haven't upgraded it to 2.6.29-gentoo-r1. AFAIK, that issue is resolved in the new revision.
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Tue Apr 07, 2009 1:05 am    Post subject: Reply with quote

Am using 2.6.29-zen1, nvidia-185.19 and, compiz-0.8.2 and not seeing these problems.
I do know that some of the 180.xx drivers will cause problems with logout/shutdown.
I have not seen such problems with nvidia-180.29 and 185.19.
Hope that helps narrow your problem down.
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 911
Location: Mount Vernon, NY

PostPosted: Tue Apr 07, 2009 2:18 am    Post subject: Reply with quote

Definitely an nvidia-driver problem, works fine with the 185.19 drivers.
_________________
Billy DeVincentis
Back to top
View user's profile Send private message
overkll
Veteran
Veteran


Joined: 21 Sep 2004
Posts: 1249
Location: Austin, Texas

PostPosted: Tue Apr 07, 2009 4:52 am    Post subject: Reply with quote

WOOT WOOT! Just upgraded to nvidia-drivers-185.19. Finally everything on my new laptop works like it should. nVidia deserves big fat "thank you" 's for diligently working out the wrinkles in their drivers over the past couple/few of months.

Last edited by overkll on Thu Apr 09, 2009 9:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
Uncle_Psychosis
Guru
Guru


Joined: 31 Jan 2004
Posts: 387

PostPosted: Tue Apr 07, 2009 3:34 pm    Post subject: Reply with quote

overkll wrote:
As far as I can tell, the "live" (-9999) ebuilds have been removed from the overlay. I changed /etc/portage/package.keywords to use the -0.8.2 versions, and compiz only, not compiz-fusion packages.


I didn't realise before that compiz-fusion is being merged into just plain "compiz". Given that until now I have been using the live "9999" ebuilds from the overlay, what (specifically) do I need to change?

These are the compiz and compiz-fusion packages that my machine has available:

Code:
# emerge -s compiz
Searching...   
[ Results for search key : compiz ]
[ Applications found : 15 ]
 
*  dev-python/compizconfig-python
      Latest version installed: 9999
      Homepage:      http://compiz-fusion.org
      Description:   Compizconfig Python Bindings (git)
      License:       GPL-2

*  x11-libs/compiz-bcop
      Latest version installed: 9999
      Homepage:      http://compiz-fusion.org
      Description:   Compiz Option code Generator (git)
      License:       GPL-2

*  x11-libs/compizconfig-backend-gconf
      Latest version installed: 9999
      Homepage:      http://compiz-fusion.org
      Description:   Compizconfig Gconf Backend (git)
      License:       GPL-2

*  x11-libs/compizconfig-backend-kconfig
      Latest version installed: 9999
      Homepage:      http://compiz-fusion.org
      Description:   Compizconfig Kconfig Backend (git)
      License:       GPL-2

*  x11-libs/libcompizconfig
      Latest version installed: 9999
      Homepage:      http://compiz-fusion.org
      Description:   Compiz Configuration System (git)
      License:       GPL-2

*  x11-plugins/compiz-fusion-plugins-extra
      Latest version installed: 9999
      Homepage:      http://compiz-fusion.org
      Description:   Compiz Fusion Window Manager Extra Plugins (git)
      License:       GPL-2

*  x11-plugins/compiz-fusion-plugins-main
      Latest version installed: 9999
      Homepage:      http://compiz-fusion.org
      Description:   Compiz Fusion Window Manager Plugins (git)
      License:       GPL-2

*  x11-plugins/compiz-fusion-plugins-unsupported
      Latest version installed: 9999
      Homepage:      http://compiz-fusion.org
      Description:   Compiz Fusion Window Decorator Unsupported Plugins (git)
      License:       GPL-2

*  x11-plugins/compiz-plugins-extra [ Masked ]
      Latest version available: 0.8.2
      Latest version installed: [ Not Installed ]
      Size of files: 2,562 kB
      Homepage:      http://www.compiz.org/
      Description:   Compiz Fusion Window Decorator Extra Plugins
      License:       GPL-2

*  x11-plugins/compiz-plugins-main [ Masked ]
      Latest version available: 0.8.2
      Latest version installed: [ Not Installed ]
      Size of files: 1,141 kB
      Homepage:      http://www.compiz.org/
      Description:   Compiz Fusion Window Decorator Plugins
      License:       GPL-2

*  x11-plugins/compiz-plugins-unsupported [ Masked ]
      Latest version available: 0.8.2
      Latest version installed: [ Not Installed ]
      Size of files: 1,027 kB
      Homepage:      http://www.compiz.org/
      Description:   Compiz Fusion Window Decorator Unsupported Plugins
      License:       GPL-2

*  x11-wm/compiz
      Latest version installed: 9999
      Homepage:      http://www.compiz.org/
      Description:   3D composite- and windowmanager
      License:       GPL-2 LGPL-2.1 MIT

*  x11-wm/compiz-fusion
      Latest version installed: 9999
      Homepage:      http://compiz-fusion.org
      Description:   Compiz Fusion (meta) package for optional deps
      License:       GPL-2
Back to top
View user's profile Send private message
overkll
Veteran
Veteran


Joined: 21 Sep 2004
Posts: 1249
Location: Austin, Texas

PostPosted: Tue Apr 07, 2009 3:59 pm    Post subject: Reply with quote

Per /usr/portage/local/layman/desktop-effects/Documentation/compiz-fusion-0.8.2-keywords, use these in /etc/portage/package.keywords:

Code:
=dev-python/compizconfig-python-0.8.2
=x11-apps/ccsm-0.8.2
=x11-apps/simple-ccsm-0.8.2
=x11-libs/compiz-bcop-0.8.2
=x11-plugins/compiz-plugins-main-0.8.2
=x11-plugins/compiz-plugins-extra-0.8.2
=x11-plugins/compiz-plugins-unsupported-0.8.2
=x11-themes/emerald-themes-0.5.2
=x11-wm/emerald-0.8.2
=x11-libs/libcompizconfig-0.8.2
=x11-libs/compizconfig-backend-kconfig-0.8.2
=x11-libs/compizconfig-backend-gconf-0.8.2
=x11-wm/compiz-fusion-0.8.2
=x11-wm/compiz-0.8.2

=x11-apps/fusion-icon-0.1


I don't have kde installed so I don't use "...backend-kconfig". I also don't use emerald, emerald-themes or simple-ccsm.
Back to top
View user's profile Send private message
Uncle_Psychosis
Guru
Guru


Joined: 31 Jan 2004
Posts: 387

PostPosted: Tue Apr 07, 2009 4:25 pm    Post subject: Reply with quote

overkll wrote:
Per /usr/portage/local/layman/desktop-effects/Documentation/compiz-fusion-0.8.2-keywords, use these in /etc/portage/package.keywords:

Code:
=dev-python/compizconfig-python-0.8.2
=x11-apps/ccsm-0.8.2
=x11-apps/simple-ccsm-0.8.2
=x11-libs/compiz-bcop-0.8.2
=x11-plugins/compiz-plugins-main-0.8.2
=x11-plugins/compiz-plugins-extra-0.8.2
=x11-plugins/compiz-plugins-unsupported-0.8.2
=x11-themes/emerald-themes-0.5.2
=x11-wm/emerald-0.8.2
=x11-libs/libcompizconfig-0.8.2
=x11-libs/compizconfig-backend-kconfig-0.8.2
=x11-libs/compizconfig-backend-gconf-0.8.2
=x11-wm/compiz-fusion-0.8.2
=x11-wm/compiz-0.8.2

=x11-apps/fusion-icon-0.1


I don't have kde installed so I don't use "...backend-kconfig". I also don't use emerald, emerald-themes or simple-ccsm.


Perfect, thanks. I had to remove the old compiz-fusion-plugins-{main/unsupported/extra} because they were blocking the new compiz-plugins packages.

Cheers
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Apr 18, 2009 5:30 pm    Post subject: Reply with quote

please fix:

Quote:
DEPEND="${RDEPEND}
>=dev-util/intltool-0.35
>=dev-util/pkgconfig-0.19
>=sys-devel/gettext-0.15
x11-libs/cairo[glitz]
gnome? ( gnome-base/gconf )
"


in x11-plugins/compiz-plugins-extra-0.8.2

(removing the glitz use-flag dependency)

since glitz doesn't seem to get developed any further upstream (and also got removed in fedora and other distros) and besides that causes trouble with nvidia drivers
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
thunderrd
n00b
n00b


Joined: 20 Aug 2010
Posts: 58

PostPosted: Fri Aug 20, 2010 3:35 pm    Post subject: cairo-dock and desktop-effects overlay Reply with quote

Hi all,

I could use some help with the desktop-effects overlay and cairo-dock. On a new installation of Gentoo, using Xfce and Compiz-Fusion, emerge reports the following when attempting to find cairo-dock. The desktop-effects overlay is installed and up-to date. I followed this guide to the letter:

http://www.glx-dock.org/ww_page.php?p=Paquet%20Gentoo&lang=en

Code:
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "~x11-misc/cairo-dock-1.6.3.1".
(dependency required by "x11-misc/cairo-dock-themes-1.6.3.1" [ebuild])
(dependency required by "cairo-dock-themes" [argument])


1.6.3.1 is a two-year-old version. Currently it is at 2.1.3.9.

I suspect that something is wrong with the way I have unmasked packages. What can I provide here so someone can help determine what I'm missing? Thanks for the help.
Back to top
View user's profile Send private message
d3x73r
n00b
n00b


Joined: 16 Apr 2010
Posts: 55
Location: Bahia/Brazil

PostPosted: Sat Oct 16, 2010 8:28 pm    Post subject: Reply with quote

Hi... I just added desktop-effects overlay, but i'm getting this message:

* "/var/lib/layman/desktop-effects/gnome-extra/avant-window-navigator/avant-window-navigator-9999.ebuild":
* Deprecation Warning: NEED_PYTHON variable is deprecated and will be banned on 2010-10-01.
* Use PYTHON_DEPEND variable instead of NEED_PYTHON variable.
* The ebuild needs to be fixed. Please report a bug, if it has not been already reported.
*
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2277
Location: Bardowick, Germany

PostPosted: Tue Oct 26, 2010 7:29 pm    Post subject: Reply with quote

Hi!

I have two issues with the overlay:
  1. compiz-fusion-9999 can not be emerged with emerald USE flag enabled, because it still depends on emerald-9999 which is no longer in the overlay.
  2. Now it is banned:
    Code:
     * Use PYTHON_DEPEND variable instead of NEED_PYTHON variable.
     * ERROR: gnome-extra/avant-window-navigator-9999 failed:
     *   NEED_PYTHON variable is banned

_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
smove
n00b
n00b


Joined: 03 Jul 2005
Posts: 52
Location: Germany

PostPosted: Tue Oct 26, 2010 8:22 pm    Post subject: Reply with quote

I found a bug in the compiz-plugins-main-0.9.2 and compiz-plugins-extra-0.9.2 ebuild.

Code:

>>> Configuring source in /var/tmp/portage/x11-plugins/compiz-plugins-main-0.9.2/work ...
>>> Working in BUILD_DIR: "/var/tmp/portage/x11-plugins/compiz-plugins-main-0.9.2/work/compiz-plugins-main-0.9.2_build"
 * Unable to locate CMakeLists.txt under:
 * "/var/tmp/portage/x11-plugins/compiz-plugins-main-0.9.2/work/compiz-plugins-main-0.9.2/CMakeLists.txt"
 * Consider not inheriting the cmake eclass.
 * ERROR: x11-plugins/compiz-plugins-main-0.9.2 failed:
 *   FATAL: Unable to find CMakeLists.txt
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_configure
 *   environment, line 2979:  Called cmake-utils_src_configure
 *   environment, line  770:  Called _execute_optionaly 'src_configure'
 *   environment, line  232:  Called enable_cmake-utils_src_configure
 *   environment, line 1129:  Called die
 * The specific snippet of code:
 *           die "FATAL: Unable to find CMakeLists.txt";
 *
 * If you need support, post the output of 'emerge --info =x11-plugins/compiz-plugins-main-0.9.2',
 * the complete build log and the output of 'emerge -pqv =x11-plugins/compiz-plugins-main-0.9.2'.
 * This ebuild is from an overlay named 'desktop-effects': '/usr/local/portage/layman/desktop-effects/'
 * The complete build log is located at '/var/tmp/portage/x11-plugins/compiz-plugins-main-0.9.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-plugins/compiz-plugins-main-0.9.2/temp/environment'.
 * S: '/var/tmp/portage/x11-plugins/compiz-plugins-main-0.9.2/work/compiz-plugins-main-0.9.2'


This error occurs for both ebuilds, because the initial working directory is wrong.
It has to be ../plugins-main instead of ../compiz-plugins-main-0.9.2 and
../plugins-extra instead of ../compiz-plugins-extra-0.9.2'.

I fixed it by adding the following line:
for compiz-plugins-main-0.9.2:
Code:

S="${WORKDIR}/plugins-main"


for compiz-plugins-extra-0.9.2
Code:

S="${WORKDIR}/plugins-extra"


So here are my ebuilds I used to install the packages:
http://xurv.org/~smove/files/x11-plugins/compiz-plugins-main/compiz-plugins-main-0.9.2.ebuild
http://xurv.org/~smove/files/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.9.2.ebuild

greets
smove
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2277
Location: Bardowick, Germany

PostPosted: Tue Oct 26, 2010 8:25 pm    Post subject: Reply with quote

fusion-icon-9999 can't be emerged:
Code:
* GIT NEW clone -->
 *    repository:               git://anongit.compiz-fusion.org/users/crdlb/fusion-icon
 *    at the commit:            5e2dc91599f559040fd0c9d2040cd8906e302825
 *    branch:                   master
 *    storage directory:        "/home/distfiles/git-src/fusion-icon"
 * Use PYTHON() instead of python variable. Use python_get_*() instead of PYVER* variables.
 * ERROR: x11-apps/fusion-icon-9999 failed:
 *   python_version() is banned
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called pkg_postinst
 *   environment, line 3100:  Called python_version
 *   environment, line 4823:  Called die
 * The specific snippet of code:
 *       die "${FUNCNAME}() is banned"
 *
 * If you need support, post the output of 'emerge --info =x11-apps/fusion-icon-9999',
 * the complete build log and the output of 'emerge -pqv =x11-apps/fusion-icon-9999'.
 * This ebuild is from an overlay named 'desktop-effects': '/var/lib/layman/desktop-effects/'
 * The complete build log is located at '/var/log/portage/x11-apps:fusion-icon-9999:20101026-202126.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-apps/fusion-icon-9999/temp/environment'.
 * S: '/var/tmp/portage/x11-apps/fusion-icon-9999/work/fusion-icon'

_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
summonbaka
n00b
n00b


Joined: 30 Jul 2009
Posts: 11
Location: Tokyo

PostPosted: Sat Oct 30, 2010 6:14 pm    Post subject: Reply with quote

d3x73r wrote:
Hi... I just added desktop-effects overlay, but i'm getting this message:

* "/var/lib/layman/desktop-effects/gnome-extra/avant-window-navigator/avant-window-navigator-9999.ebuild":
* Deprecation Warning: NEED_PYTHON variable is deprecated and will be banned on 2010-10-01.
* Use PYTHON_DEPEND variable instead of NEED_PYTHON variable.
* The ebuild needs to be fixed. Please report a bug, if it has not been already reported.
*


This is a bug/problem that has been in the ebuild for some time, and the NEED_PYTHON got banned at beggining of this month.

for every ebuild in /var/lib/layman/desktop-effects/ that has that problem you need to do this:

Remove (or edit) the NEED_PYTHON="$(version_number)"
and add PYTHON_DEPEND="$(major_version_number):$(version_number)"
or
PYTHON_DEPEND="*:$(version_number)"

in other words:
-- NEED_PYTHON="$(version_number)"
++ PYTHON_DEPEND="*:$(version_number)"

I would report it, but don't know a way to do it for overlays except from posting here.

EDIT:
More information as how to fix it is here:
http://www.gentoo.org/proj/en/Python/developersguide.xml

EDIT(bis):
I tried to re-install awn, but to no avail it fails in the checking of vala now. Need vala-0.7.10 and it's not on the tree anymore or the kist-overlay or in desktop-effects overlay. the desktop-effects overlay is not including some of the dependencies for avant-window-navigator, which include gir-repositories and vala plus the errors aforementioned.
Back to top
View user's profile Send private message
mathfeel
l33t
l33t


Joined: 03 Aug 2004
Posts: 700

PostPosted: Tue Nov 02, 2010 6:32 pm    Post subject: Reply with quote

I am having trouble emerging AWN due to this failure of libdesktop-agnostic:
Code:
Checking for gnome-desktop-2.0              : ok
 error: Your Vala compiler version (0, 10, 1) is too old. The project requires
version 0.7.10
 * ERROR: x11-libs/libdesktop-agnostic-9999 failed:
 *   Could not configure libdesktop-agnostic.

which seems kind of silly. Isn't 10 > 7?

The reason I am using the live ebuild is the other one failed as well:
Code:
[121/125] typelib: build/default/libdesktop-agnostic/DesktopAgnostic-1.0.gir -> build/default/libdesktop-agnostic/DesktopAgnostic-1.0.typelib
default/libdesktop-agnostic/DesktopAgnostic-1.0.gir:3:1: error: Unsupported version '1.0'
error parsing file default/libdesktop-agnostic/DesktopAgnostic-1.0.gir: Unsupported version '1.0'
Waf: Leaving directory `/var/tmp/portage/x11-libs/libdesktop-agnostic-0.3.90/work/libdesktop-agnostic-0.3.90/build'
Build failed
 -> task failed (err #1):
        {task: typelib DesktopAgnostic-1.0.gir -> DesktopAgnostic-1.0.typelib}
 * ERROR: x11-libs/libdesktop-agnostic-0.3.90 failed:
 *   Could not compile libdesktop-agnostic.

_________________
-----------------------------------------------------------
"In heaven all the interesting people are missing"
-- Friedrich Nietzsche
Back to top
View user's profile Send private message
summonbaka
n00b
n00b


Joined: 30 Jul 2009
Posts: 11
Location: Tokyo

PostPosted: Tue Nov 02, 2010 6:37 pm    Post subject: Reply with quote

mathfeel wrote:
I am having trouble emerging AWN due to this failure of libdesktop-agnostic:
Code:
Checking for gnome-desktop-2.0              : ok
 error: Your Vala compiler version (0, 10, 1) is too old. The project requires
version 0.7.10
 * ERROR: x11-libs/libdesktop-agnostic-9999 failed:
 *   Could not configure libdesktop-agnostic.

which seems kind of silly. Isn't 10 > 7?
There's a bug inthe live build that asks for 0.7.10
The reason I am using the live ebuild is the other one failed as well:
Code:
[121/125] typelib: build/default/libdesktop-agnostic/DesktopAgnostic-1.0.gir -> build/default/libdesktop-agnostic/DesktopAgnostic-1.0.typelib
default/libdesktop-agnostic/DesktopAgnostic-1.0.gir:3:1: error: Unsupported version '1.0'
error parsing file default/libdesktop-agnostic/DesktopAgnostic-1.0.gir: Unsupported version '1.0'
Waf: Leaving directory `/var/tmp/portage/x11-libs/libdesktop-agnostic-0.3.90/work/libdesktop-agnostic-0.3.90/build'
Build failed
 -> task failed (err #1):
        {task: typelib DesktopAgnostic-1.0.gir -> DesktopAgnostic-1.0.typelib}
 * ERROR: x11-libs/libdesktop-agnostic-0.3.90 failed:
 *   Could not compile libdesktop-agnostic.


For the live one to build you need gir-repositories and vala-0.7.10. I had just posted that and other problems above your post some days ago.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 14, 15, 16, 17  Next
Page 15 of 17

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum