Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Logitech Bluetooth Mouse doesn't work in X [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Fri Jan 25, 2008 2:35 pm    Post subject: Logitech Bluetooth Mouse doesn't work in X [Solved] Reply with quote

I've got a Dell Travel Mouse (actually a Logitech mouse) with Bluetooth connection.
Mouse get recognized well at boot; I've inserted this line
Code:
HIDD_OPTIONS="--connect <enter here your bluetooth mouse address>"
in /etc/conf.d/bluetooth as suggested in this guide, and in fact it's detected correctly:
Code:
candell canduc # hidd --show
00:07:61:9C:86:2E Logitech         (3) Button Mouse [046d:b006] connected
It's mapped on device /dev/input/mouse2:
Code:
candell canduc # candell canduc # cat /dev/input/mouse2

      ÿü(õ(
õ(î(õ(õ(ð(õ(õ( ò8ÿû8þû8þþþ þý÷úÿ
                                              ÿúúö
...etcetera.

But it doesn't work in X (and also in GNOME)...That's my xorg.conf for touchpad and for bluetooth mouse:
Code:
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Mouse1" "AlwaysCore"
EndSection

Section "InputDevice"
   Identifier     "Mouse0"
   Driver         "synaptics"
   Option         "Protocol" "auto-dev"
   Option         "Device" "/dev/input/mouse1"
   Option       "LeftEdge"      "1700"
   Option       "RightEdge"     "5300"
   Option       "TopEdge"       "1700"
   Option       "BottomEdge"    "4200"
   Option       "FingerLow"     "25"
   Option       "FingerHigh"    "30"
   Option       "MaxTapTime"    "180"
   Option       "MaxTapMove"    "220"
   Option       "VertScrollDelta" "100"
   Option       "MinSpeed"        "0.09"
   Option       "MaxSpeed"        "0.18"
   Option       "AccelFactor"     "0.0015"
   Option       "SHMConfig"       "on"
   Option       "TapButton2"      "2"
EndSection

Section "InputDevice"
        Identifier "Mouse1"
        Option      "Name" "Bluetooth Dell Travel Mouse"
        Driver     "evdev"
        Option    "Device" "/dev/input/mouse2"
        Option    "Protocol" "auto"
        Option    "Buttons" "5"
        Option    "ZAxisMapping" "4 5"
        Option    "SendCoreEvents" "true"
EndSection


I think that the problem is in Xorg configuration because this mouse works well with gpm...
Here's /var/log/Xorg.0.log:
Code:
...
(--) Mouse0 touchpad found
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(II) evdev brain: Rescanning devices (1).
(EE) PreInit returned NULL for "Mouse1"
(EE) No Input driver matching `mouse'
(II) XINPUT: Adding extended input device "evdev brain" (type: evdev brain)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
Synaptics DeviceInit called
SynapticsCtrl called.
Synaptics DeviceOn called
(--) Mouse0 auto-dev sets device to /dev/input/event4
(**) Option "Device" "/dev/input/event4"
(--) Mouse0 touchpad found
(II) evdev brain: Rescanning devices (2).
(II) evdev brain: Rescanning devices (3).
SynapticsCtrl called.
Any ideas?
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)


Last edited by canduc17 on Mon Jan 28, 2008 5:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
gentoo_ram
Guru
Guru


Joined: 25 Oct 2007
Posts: 417
Location: San Diego, California USA

PostPosted: Fri Jan 25, 2008 4:57 pm    Post subject: Reply with quote

I think you're using the wrong driver for Mouse1. If you want to use a /dev/input/mouse* device, you should be using the "mouse" driver. Change Driver "evdev" to Drive "mouse" and try again.
Back to top
View user's profile Send private message
Monkeh
Veteran
Veteran


Joined: 06 Aug 2005
Posts: 1656
Location: England

PostPosted: Fri Jan 25, 2008 5:16 pm    Post subject: Reply with quote

Just remove the device line. It's not required.
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Sat Jan 26, 2008 4:18 pm    Post subject: Reply with quote

gentoo_ram wrote:
I think you're using the wrong driver for Mouse1. If you want to use a /dev/input/mouse* device, you should be using the "mouse" driver. Change Driver "evdev" to Drive "mouse" and try again.
No, it doesn't work.

Monkeh wrote:
Just remove the device line. It's not required.
Ok, it has worked just at the first reboot...but (I really can't understand why) this mess my keyboard configuration up: several keys where changed or simply not responding.
In other boots, the mouse wasn't work anymore.

This is my actual config:
Code:
Section "InputDevice"
    Identifier "Mouse1"
    Driver     "mouse"
    Option     "Protocol" "auto-dev"
EndSection
...and it works well with gpm, but it doesn't work under X.
The same if i use the driver evdev...
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Mon Jan 28, 2008 5:02 pm    Post subject: Reply with quote

Solved with
Code:
emerge -vDNu world
emerge --depclean
revdep-rebuild
and with this xorg configuration:
Code:
Section "InputDevice"
    Identifier "Mouse1"
    Driver     "mouse"
EndSection
Now the mouse works perfectly.:)
Thaks everybody!
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum