Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto] xorg-server non si vuole aggiornare
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
GabrieleB
Guru
Guru


Joined: 22 Jul 2003
Posts: 317

PostPosted: Mon Jan 21, 2008 4:49 pm    Post subject: [risolto] xorg-server non si vuole aggiornare Reply with quote

Ciao, mi succede questo:
Code:
emerge -uD xorg-server
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) x11-base/xorg-server-1.3.0.0-r4 to /
 * MesaLib-6.5.2.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                  [ ok ]
 * xorg-server-1.3.0.0.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...            [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking xorg-server-1.3.0.0.tar.bz2 ;-) ...                           [ ok ]
 * checking MesaLib-6.5.2.tar.bz2 ;-) ...                                 [ ok ]
 *
 * ERROR: x11-base/xorg-server-1.3.0.0-r4 failed.
 * Call stack:
 *                       ebuild.sh, line 1717:  Called dyn_setup
 *                       ebuild.sh, line  768:  Called qa_call 'pkg_setup'
 *                       ebuild.sh, line   44:  Called pkg_setup
 *   xorg-server-1.3.0.0-r4.ebuild, line  334:  Called die
 * The specific snippet of code:
 *              use nptl && die "${diemsg}"
 *  The die message:
 *   You must build xorg-server and mesa with the same nptl USE setting.
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-base/xorg-server-1.3.0.0-r4/temp/build.log'.
 *

 * Messages for package x11-base/xorg-server-1.3.0.0-r4:

 *
 * ERROR: x11-base/xorg-server-1.3.0.0-r4 failed.
 * Call stack:
 *                       ebuild.sh, line 1717:  Called dyn_setup
 *                       ebuild.sh, line  768:  Called qa_call 'pkg_setup'
 *                       ebuild.sh, line   44:  Called pkg_setup
 *   xorg-server-1.3.0.0-r4.ebuild, line  334:  Called die
 * The specific snippet of code:
 *              use nptl && die "${diemsg}"
 *  The die message:
 *   You must build xorg-server and mesa with the same nptl USE setting.
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-base/xorg-server-1.3.0.0-r4/temp/build.log'.
 *

la riga strana e' "You must build xorg-server and mesa with the same nptl USE setting.": in /etc/make.conf ho le flag nptl e nptlonly da sempre (nel dubbio ho anche riemerso mesa-libs/mesa), quindi non mi spiego questo errore.

A voi funzica ?
_________________
Keyboard error. Press F1 to continue.


Last edited by GabrieleB on Tue Jan 22, 2008 9:24 am; edited 1 time in total
Back to top
View user's profile Send private message
lele_dj
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2007
Posts: 86

PostPosted: Mon Jan 21, 2008 5:02 pm    Post subject: Reply with quote

A me funziona ... l'unica cosa che mi viene in mente è di controllare le use del pacchetto "mesa-libs/mesa" in /etc/portage/package.use .... magari li è disabilitata
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Jan 21, 2008 5:13 pm    Post subject: Reply with quote

lele_dj wrote:
A me funziona ... l'unica cosa che mi viene in mente è di controllare le use del pacchetto "mesa-libs/mesa" in /etc/portage/package.use .... magari li è disabilitata

Difatti
Code:

if built_with_use media-libs/mesa nptl; then
                use nptl || die "${diemsg}"
        else
                use nptl && die "${diemsg}"
        fi

Controlla l'output di
Code:

emerge -pv xorg-server mesa

_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
GabrieleB
Guru
Guru


Joined: 22 Jul 2003
Posts: 317

PostPosted: Tue Jan 22, 2008 8:33 am    Post subject: Reply with quote

sbirciando sul forum internazionale ho scoperto che mesa nelle sule ultime versioni e' compilato forzando -nptl a causa di un buco. Quindi ho forzato anche xorg-server da package.use e tutto e' andato bene. Devo sono ricordarmi di ri-modificarlo quando uscira' la versione bugfixed di mesa.
_________________
Keyboard error. Press F1 to continue.
Back to top
View user's profile Send private message
CarloJekko
Veteran
Veteran


Joined: 31 Mar 2005
Posts: 1315
Location: Baia Domizia :-)

PostPosted: Tue Jan 22, 2008 12:27 pm    Post subject: Reply with quote

Io ti consiglio di fare così... Compila mesa 6.5.0-r1 (e non la 7.0.2) con le use nptl e quindi xorg-server
Mesa e xorg-server vanno compilate con le stesse USE nptl... ma stai attento .. Mesa 7 da problemi con nptl quindi l'hanno tolto dall'ebuild.
Ciao !
_________________
C.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum