Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ACL] probleme samba + acl
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Fri Jan 18, 2008 12:21 pm    Post subject: [ACL] probleme samba + acl Reply with quote

bonjours a tous

voila j'ai un probleme avec les acl :

j'ai une arborescence composé de plusieurs dossier, exemple :

racine
|
|--test1
|--test2

test1 et test2 ont chacun des droits particulier et des droits par defaut pour les nouveau fichiers créés.
jusqu'a là tout se passe bien et ça marche, mes clients sont sous windows.

quand un utilisateur deplace un dossier qui se trouve dans test1 vers test2, le dossier en question qui se trouve maintenant dans test2 conserve les droits qu'il avait quand il était dans test1 et ne prend pas les droits par defaut de test2 !!!

c'est très embettant ! du coup les utilisateurs qui n'avait pas accès a test1 n'ont pas accès a ce dossier !

quelqu'un a t'il déja eu ce probleme, y a t'il une solution ?
_________________
Pourquoi faire simple quand on peut faire compliqué ?
Back to top
View user's profile Send private message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Fri Jan 18, 2008 3:37 pm    Post subject: Reply with quote

bon ou tout simplement : quelqu'un n'a t'il pas ce probleme ?
_________________
Pourquoi faire simple quand on peut faire compliqué ?
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Fri Jan 18, 2008 3:52 pm    Post subject: Reply with quote

Nan c'est un comportement normal. Un fichier/répertoire déplacé conserve tous ses attributs, y compris les ACL. Donc il faut les remodifier ensuite :)
Back to top
View user's profile Send private message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Fri Jan 18, 2008 4:02 pm    Post subject: Reply with quote

bon bah c'est le bordel alors !ai je été trop préssé de me débarasser de m$ ?

donc la seul solution ce serai un bridage sur le dossier de depart uniquement et de mettre tout le rest en rwx pour anticiper le fait qu'il puisse aller ailleur ?!

jedéchante là

d'autant plus que maintenant c'est word qui me les casses avec ses fichier temp ...
_________________
Pourquoi faire simple quand on peut faire compliqué ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum