Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
keyboard deutsche tastatur geht nicht mehr
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 312
Location: LB

PostPosted: Wed Jan 16, 2008 4:21 pm    Post subject: keyboard deutsche tastatur geht nicht mehr Reply with quote

Ein fehler von vielen nach einem
emerge -uDNeav world

keyboard deutsche tastatur geht nicht mehr
*keine configurationsdatei wurde ge'ndert*
Auszug xorgconf
Code:

Section "InputDevice"
   Identifier   "Keyboard0"
   Driver   "kbd"
   Option   "CoreKeyboard"
   Option   "XkbRules" "xorg"
   #Option   "XkbModel" "pc105"
   #Option   "XkbOptions" "grp:toggle,grp_led:scroll"
#Option   "XkbLayout" "de"
   Option "XkbLayout"    "de,us"
     Option "XkbOptions"   "grp:alt_shift_toggle,grp_led:scroll"
   
   #Option   "XkbVariant" "nodeadkeys,winkeys"
   Option "XkbModel" "cymotionlinux"
   
    #Option "XkbOptions" "compose:rwin"
   #Option "CustomKeycodes" "off"
EndSection


logfile xorg
Code:

(II) Initializing extension GLX
(**) Option "CoreKeyboard"
(**) Keyboard0: always reports core events
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "cymotionlinux"
(**) Keyboard0: XkbModel: "cymotionlinux"
(**) Option "XkbLayout" "de,us"
(**) Keyboard0: XkbLayout: "de,us"
(**) Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
(**) Keyboard0: XkbOptions: "grp:alt_shift_toggle,grp_led:scroll"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(**) Option "Protocol" "IMPS/2"
(**) USB Mouse: Device: "/dev/input/mice"


Also irgendwie geht - de - gar nicht.
_________________
!! FUCK OFF # GNOME 3 # keep away from that developers - they are infected by Tablet-Cellphone-Android Virus :twisted:
AMD 64 X2 4200+ Asus M2NPV-VM Sockel AM2 - 6GB DDR800 - Monitor:Samsung 245B 1920x1200 GeForce 6150

achim
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5348
Location: Langen (Hessen), Germany

PostPosted: Wed Jan 16, 2008 4:46 pm    Post subject: Reply with quote

Was passiert wenn du als root in X "loadkeys de" eingibst?

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 312
Location: LB

PostPosted: Wed Jan 16, 2008 4:59 pm    Post subject: Reply with quote

output>
Code:
localhost achim # loadkeys de
Loading /usr/share/keymaps/i386/qwertz/de.map.gz

effekt auf Tastatur - keiner
_________________
!! FUCK OFF # GNOME 3 # keep away from that developers - they are infected by Tablet-Cellphone-Android Virus :twisted:
AMD 64 X2 4200+ Asus M2NPV-VM Sockel AM2 - 6GB DDR800 - Monitor:Samsung 245B 1920x1200 GeForce 6150

achim
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2171
Location: Bozen

PostPosted: Wed Jan 16, 2008 6:10 pm    Post subject: Reply with quote

Probier das mal:
https://forums.gentoo.org/viewtopic-t-641069.html
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2541
Location: de

PostPosted: Wed Jan 16, 2008 6:13 pm    Post subject: Reply with quote

Ich vermute mal, du hast auf xorg-Server 1.4.0.90 geupgradet (welche Wort...) und hast das Teil mit Hal-Unterstützung (Hal Version: 0.5.10) compiliert.

Wenn ja, dann hast du zwar in Deiner xorg.conf "de" stehen, "us" wird aber geladen.

Du hast dann folgende Möglichkeiten:
1. Downgrade Hal auf Version 0.5.9
2. Xorg-Server compilieren mit -hal
3. xorg.conf umschreiben

Grund für 3. ist wohl, daß diverse Optionen (Stichwort evdev bei Tastatur) im neuen Xorg-Server in Verbindung mit der neuen Hal-Version geändert wurden.
https://forums.gentoo.org/viewtopic-t-641870.html
Es gab da noch'n anderen Thread dazu, den ich jetzt aber nicht find.

Ich hab das Hal-Useflag aus dem Xorg-Server entfernt, und schon hat's wieder funktioniert.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2171
Location: Bozen

PostPosted: Wed Jan 16, 2008 6:59 pm    Post subject: Reply with quote

Na mal sehen, ob ich es hinbekommt. Hab mal hal bei xorg rausgenommen und das erste was passiert ist, war die Tatsache, dass die Maus nicht mehr wollte.
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 312
Location: LB

PostPosted: Wed Jan 16, 2008 7:08 pm    Post subject: Reply with quote

@musv
du hattest recht
hal und seine Schikane machens möglich

mir hat das geholfen
https://forums.gentoo.org/viewtopic-t-641870.html

Krampi wrote:
Temporary fix to get other layouts than "us":

Create /etc/hal/fdi/policy/x11-input.fdi
Write something like this to it:
Code:
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.layout" type="string">de</merge>
      <merge key="input.xkb.variant" type="string">nodeadkeys</merge>
    </match>
  </device>
</deviceinfo>


See:
http://www.mail-archive.com/debian-bugs-rc@lists.debian.org/msg118695.html
http://www.mail-archive.com/debian-bugs-rc@lists.debian.org/msg118725.html


Nur gehn jetzt wieder ein paar Tasten von meim Cherry (LINUX) Tastenbrett wieder nicht
Das ist doch zum Irre werden
_________________
!! FUCK OFF # GNOME 3 # keep away from that developers - they are infected by Tablet-Cellphone-Android Virus :twisted:
AMD 64 X2 4200+ Asus M2NPV-VM Sockel AM2 - 6GB DDR800 - Monitor:Samsung 245B 1920x1200 GeForce 6150

achim
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2171
Location: Bozen

PostPosted: Thu Jan 17, 2008 6:24 am    Post subject: Reply with quote

xorg ohne hal bringt bei mir gar nichts. Nachdem ich die Maus von evdev auf input/mice umgestellt habe, ging sie wieder. Aber alle Zeichen auf der Tastatur über den Zahlen machen Müll. Numlock-Lampe ist aus, wenn Numlock an ist und umgekehrt, Tastaturwiederholung geht nicht und wenn ich vom Framebuffer zu X wechsele werden irgendwelche Tastenkombinationen ausgelöst. Das geht voll in die Hose.
Back to top
View user's profile Send private message
Trude
n00b
n00b


Joined: 17 Jan 2008
Posts: 1

PostPosted: Thu Jan 17, 2008 1:36 pm    Post subject: Reply with quote

Bei mir hat es geholfen den globale evdev Useflag zu entfernen und x11-drivers/xf86-input-evdev zu deinstallieren. Danach lief wieder alles einwandfrei!
Back to top
View user's profile Send private message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1951
Location: My own world! I and Gentoo!

PostPosted: Thu Jan 17, 2008 7:08 pm    Post subject: Reply with quote

Ich nutze die Driver
keyboard
und
mouse
für Tastatur und Maus und habe keinerlei Probleme.

warum ihr evdev nutzt?, keine Ahnung.

Was soll der bringen?
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2171
Location: Bozen

PostPosted: Thu Jan 17, 2008 7:19 pm    Post subject: Reply with quote

Ich benutze evdev, damit ich bei meiner Maus die Tasten vorwärts-rückwarts benutzen kann. Also im Browser mit einemKlick vor und rurück.
Back to top
View user's profile Send private message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1951
Location: My own world! I and Gentoo!

PostPosted: Thu Jan 17, 2008 7:50 pm    Post subject: Reply with quote

aaaah, das heißt evdev unterstützt mehr Tasten. für die Maus

und am Keyboard?
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2171
Location: Bozen

PostPosted: Thu Jan 17, 2008 8:23 pm    Post subject: Reply with quote

So, einmal ausgetestet. No Sir, evdev rausnehmen ist bei mir keine L;esung. Jetyt geht gar nicht mehr, nicht mal mehr Umlaute, nur amerikanische Tastatur.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum