Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11-drivers/xf86-input-evdev-1.2.0 keyboard problem
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mschmarck
n00b
n00b


Joined: 16 Jan 2008
Posts: 13
Location: Winterthur, Switzerland

PostPosted: Wed Jan 16, 2008 1:30 pm    Post subject: Up = Screenshot and other problems Reply with quote

Hi!

I've got the same problems that Genetic has reported; ie. when I press <Cursor Up>, a screenshot in Gnome is taken. Ie. it seems as if the system thinks, that <Print Screen> key has been pressed. But unlike Genetic, I do not want to go the route of unmerging evdev and sticking with kbd.

In my xorg.conf, I've got:

Code:
Section "ServerLayout"
        Identifier     "Layout"
        Screen      0  "Screen LCD Office" 0 0
        InputDevice    "B16_b_02 USB-PS/2 Optical Mouse" "CorePointer"
        InputDevice    "Dell Dell USB Keyboard" "CoreKeyboard"
EndSection

Section "InputDevice"
        Identifier  "Dell Dell USB Keyboard"
        Driver      "evdev"
        Option      "XkbModel"    "evdev"
        Option      "Device"      "/dev/input/event1"
        Option      "evBits"      "+1"
        Option      "keyBits"     "~1-255 ~352-511"
        Option      "Pass"        "3"

        Option      "XkbRules"    "xorg"
        Option      "XkbLayout"   "ch"
        Option      "XkbOptions"  "eurosign:e,nbsp:level3,compose:caps"
EndSection


I do not have an FDI rule file created. My keyboard is a USB connected Dell USB Multimedia keyboard (dellusbmm as XkbModel).

Further, I've got another "problem". When I start Gnome, I always get an information window, which contains (in German):

Quote:
Die Einstellungen der X-Systemtastatur weichen von Ihren momentanen GNOME-Tastatureinstellungen ab.

Erwartet wurde model "latitutde", layout "ch" and options eurosign eurosign:e nbsp nbsp:level3 compose compose:caps", aber die folgenden Einstellungen wurden gefunden: model "evdev", layout "ch" and options eurosign eurosign:e nbsp nbsp:level3 compose compose:caps".

Welchen Satz wollen Sie verwenden?

[ X-Einstellungen verwenden ] [ GNOME-Einstellungen behalten ]


It's telling me, that the X and GNOME settings reg. keyboard differ. It expected model "latitude", but got model "evdev". This kinda buffles me, to be honest, as I went in Gnome to System -> Einstellungen -> Tastatur -> Belegung -> Tastaturmodell (System -> Settings -> Keyboard -> Layout (2nd tab) -> Model) and selected "Evdev-managed keyboard". Why does GNOME still expect latitude (that's what I used to have selected there, before I switched to evdev)?

And there's yet another thing which bugs me wrt. evdev. In my xorg.conf, I've got for keyboard:

Code:
Option      "Device"      "/dev/input/event1"


and for mouse:

Code:
Option      "Device"        "/dev/input/event3"


How "stable" are those numbers (ie. the 1 and 3)? I tried to leave out those Device options, but then X doesn't find the devices (keyboard and/or mouse doesn't work at all).

Code:
--($:~)-- emerge -vp hal hal-info xorg-server xinit xf86-input-evdev

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-apps/xinit-1.0.5-r2  USE="-debug hal -minimal pam" 0 kB
[ebuild   R   ] sys-apps/hal-0.5.10  USE="acpi -apm crypt -debug dell -disk-partition doc laptop (-selinux)" 0 kB
[ebuild   R   ] app-misc/hal-info-20071030  0 kB
[ebuild   R   ] x11-base/xorg-server-1.4.0.90  USE="-3dfx -debug -dmx dri hal -ipv6 -kdrive -minimal (-nptl) sdl xorg -xprint" INPUT_DEVICES="-acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics evdev -fpit -hyperpen -jamstudio -joystick keyboard -magellan -microtouch mouse -mutouch -palmax -penmount -spaceorb -summa synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="-amd -apm -ark -chips -cirrus -cyrix -dummy -epson -fbdev -fglrx -glint -i128 -i740 -i810 (-impact) -imstt -mach64 -mga -neomagic (-newport) -nsc nv nvidia -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vermilion -vesa vga -via -vmware -voodoo -xgi" 0 kB
[ebuild   R   ] x11-drivers/xf86-input-evdev-1.2.0  USE="-debug" 0 kB

Total: 5 packages (5 reinstalls), Size of downloads: 0 kB


Thanks a lot for any hints,
Michael
_________________
Michael
Back to top
View user's profile Send private message
fredor
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2003
Posts: 84
Location: UK

PostPosted: Wed Jan 16, 2008 2:25 pm    Post subject: Reply with quote

Try using <Option "Name" " ? "> instead of <Option "Device" "/dev/input/event3">
"Name" can be obtained from 'cat /proc/bus/input/devices'

Quote:
Section "InputDevice"

Identifier "Keyboard1"
# Driver "keyboard"
# Option "XkbModel" "pc105"
Option "XkbModel" "evdev"
Driver "evdev"
Option "Name" "AT Translated Set 2 Keyboard"
Option "evBits" "+1"
Option "keyBits" "~1-255 ~352-511"
Option "Pass" "3"
Option "XkbLayout" "gb"
# Option "XkbRules" "xorg"

EndSection

Section "InputDevice"
Identifier "MX1000"
Driver "evdev"
Option "Name" "Logitech USB Receiver"
Option "evBits" "+1-2"
Option "keyBits" "~272-287"
Option "relBits" "~0-2 ~6 ~8"
Option "Pass" "3"

EndSection


Try commenting out XkbRules.

This works for me.
_________________
Gentoo /amd64/2007.0
AMD Athlon64 X2 4200+
ASUS M2N32-SLI Deluxe
Back to top
View user's profile Send private message
mschmarck
n00b
n00b


Joined: 16 Jan 2008
Posts: 13
Location: Winterthur, Switzerland

PostPosted: Wed Jan 16, 2008 2:34 pm    Post subject: Trying to use "NAME" instead of "DEVICE" Reply with quote

Hello!

I tried to use "Name", but this didn't work for me :( When I used Name instead of Device for mouse, the pointer would not work.

Code:
--($:~)-- cat /proc/bus/input/devices
I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/class/input/input0
U: Uniq=
H: Handlers=kbd event0
B: EV=120013
B: KEY=500f 2002002 3803078 f800d001 feffffdf ffefffff ffffffff ffffffff
B: MSC=10
B: LED=7

I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/class/input/input4
U: Uniq=
H: Handlers=event4
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button (CM)"
P: Phys=PNP0C0C/button/input0
S: Sysfs=/class/input/input5
U: Uniq=
H: Handlers=kbd event5
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0019 Vendor=0000 Product=0003 Version=0000
N: Name="Sleep Button (CM)"
P: Phys=PNP0C0E/button/input0
S: Sysfs=/class/input/input6
U: Uniq=
H: Handlers=kbd event6
B: EV=3
B: KEY=4000 0 0 0 0

I: Bus=0011 Vendor=0002 Product=0008 Version=0000
N: Name="PS/2 Mouse"
P: Phys=isa0060/serio1/input1
S: Sysfs=/class/input/input7
U: Uniq=
H: Handlers=mouse1 event7
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0002 Product=0008 Version=6337
N: Name="AlpsPS/2 ALPS GlidePoint"
P: Phys=isa0060/serio1/input0
S: Sysfs=/class/input/input8
U: Uniq=
H: Handlers=mouse2 event8
B: EV=f
B: KEY=420 0 70000 0 0 0 0 0 0 0 0
B: REL=3
B: ABS=1000003

I: Bus=0003 Vendor=413c Product=2010 Version=0110
N: Name="Dell Dell USB Keyboard"
P: Phys=usb-0000:00:1d.7-8.3.1/input0
S: Sysfs=/class/input/input9
U: Uniq=
H: Handlers=kbd event1
B: EV=120003
B: KEY=10000 7 ff87207a c14057ff febeffdf ffefffff ffffffff fffffffe
B: LED=1f

I: Bus=0003 Vendor=413c Product=2010 Version=0110
N: Name="Dell Dell USB Keyboard"
P: Phys=usb-0000:00:1d.7-8.3.1/input1
S: Sysfs=/class/input/input10
U: Uniq=
H: Handlers=kbd event2
B: EV=b
B: KEY=3878 c8015001 e0000 0 0 0
B: ABS=1 0

I: Bus=0003 Vendor=046d Product=c025 Version=0110
N: Name="B16_b_02 USB-PS/2 Optical Mouse"
P: Phys=usb-0000:00:1d.7-8.3.3/input0
S: Sysfs=/class/input/input29
U: Uniq=
H: Handlers=mouse0 event3
B: EV=20007
B: KEY=ff0000 0 0 0 0 0 0 0 0
B: REL=103
B: LED=ff00


So to adress the mouse, I should use this, correct?

Code:
Section "InputDevice"                                                                                                                         
        Identifier  "B16_b_02 USB-PS/2 Optical Mouse"                                                                                         
        # Aus man evdev:                                                                                                                     
        Driver      "evdev"                                                                                                                   
        Option      "evBits"        "+1-2"                                                                                                   
        Option      "keyBits"       "~272-287"                                                                                               
        Option      "relBits"       "~0-2 ~6 ~8"                                                                                             
        Option      "Pass"          "3"                                                                                                       
                                                                                                                                             
        Option      "Name"          "B16_b_02 USB-PS/2 Optical Mouse"                                                                         
                                                                                                                                             
        # Alte Einstellungen:                                                                                                                 
        #Option      "ZAxisMapping"  "4 5 6 7"                                                                                               
        #Option      "Device"        "/dev/input/event3"                                                                                     
        #Option      "Name"         "B16_b_02 USB-PS/2 Optical Mouse"                                                                         
        #Option       "Device"       "/dev/input/mx500"                                                                                       
        #Option      "Phys"      "Phys=usb-0000:00:1d.7-8.3.3/input0"                                                                         
        #Option      "Phys"      "usb-0000:00:1d.7-8.3.3/input0"                                                                         
EndSection


Well, I tried that, but this did not work.

I also tried to use "Dev Name" instead of Name and also tried both variations
of "Phys" which I'm showing up there (only one at a time, of course *g*).

I'm now using a Logitech MX500 USB mouse, BTW.

Best regards,
Michael
_________________
Michael
Back to top
View user's profile Send private message
fredor
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2003
Posts: 84
Location: UK

PostPosted: Wed Jan 16, 2008 3:58 pm    Post subject: Reply with quote

I have a Logitech MX1000 mouse and I have had no trouble with this. The Name in my case is 'Logitech USB reciever' probably because it is a wireless version.
I have the same program versions as you and have had no problems with the mouse except when I tried xorg-server -hal. Then it didn't work at all.

My problems have been with the keyboard. I have tried with the 'fdi' files and this worked to some extent but I still needed the xorg.conf components.
I have modified the file /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi changing "us" to "gb". This may be overwritten with "hal" updates so it may be better to copy it to /etc/hal/policy/fdi/

I see you have another mouse component - Does this not work also?
_________________
Gentoo /amd64/2007.0
AMD Athlon64 X2 4200+
ASUS M2N32-SLI Deluxe
Back to top
View user's profile Send private message
ajc158
n00b
n00b


Joined: 17 Aug 2005
Posts: 42

PostPosted: Fri Jan 18, 2008 12:30 am    Post subject: Reply with quote

The solution to the keyboard issue is as follows:

The problem is the window manager / desktop environment overriding evdev to pc105, this causes up to be assigned to print screen. Simply disable the printscreen functionality of the window manager (gconf-editor -> apps -> metacity -> something...) for gnome using metacity, in my case ccsm for compiz-fusion. Remove the command issued when printscreen is hit and you will get your cursor back (but no printscreen function).

This is only a workaround, but the issue is known about, and at least KDE that I have read of has fixed it for the next version.

Alex
Back to top
View user's profile Send private message
mschmarck
n00b
n00b


Joined: 16 Jan 2008
Posts: 13
Location: Winterthur, Switzerland

PostPosted: Fri Jan 18, 2008 9:19 am    Post subject: Reply with quote

fredor wrote:
Try using <Option "Name" " ? "> instead of <Option "Device" "/dev/input/event3">
"Name" can be obtained from 'cat /proc/bus/input/devices'


Hm. I tried to use "Name". Strange thing is, that I've got that Name twice in /proc/bus/input/devices. I DO have two keyboards attached, though. One "external" USB keyboard and one "internal" keyboard on my notebook.

xorg.conf contains now:

Excerpt from xorg.conf:
Section "InputDevice"
   Identifier  "Dell Dell USB Keyboard"
   Driver      "evdev"
   Option      "XkbModel"    "evdev"
   Option      "Name"        "Dell Dell USB Keyboard"
   Option      "evBits"      "+1"
   Option      "keyBits"     "~1-255 ~352-511"
   Option      "Pass"        "3"
   Option       "XkbLayout"   "ch"
   Option       "XkbOptions"  "eurosign:e,nbsp:level3,compose:caps"
EndSection


And /proc/bus/input/devices is:

/proc/bus/input/devices:
I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/class/input/input0
U: Uniq=
H: Handlers=kbd event0
B: EV=120013
B: KEY=500f 2002002 3803078 f800d001 feffffdf ffefffff ffffffff ffffffff
B: MSC=10
B: LED=7

I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/class/input/input4
U: Uniq=
H: Handlers=event4
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button (CM)"
P: Phys=PNP0C0C/button/input0
S: Sysfs=/class/input/input5
U: Uniq=
H: Handlers=kbd event5
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0019 Vendor=0000 Product=0003 Version=0000
N: Name="Sleep Button (CM)"
P: Phys=PNP0C0E/button/input0
S: Sysfs=/class/input/input6
U: Uniq=
H: Handlers=kbd event6
B: EV=3
B: KEY=4000 0 0 0 0

I: Bus=0011 Vendor=0002 Product=0008 Version=0000
N: Name="PS/2 Mouse"
P: Phys=isa0060/serio1/input1
S: Sysfs=/class/input/input7
U: Uniq=
H: Handlers=mouse1 event7
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0002 Product=0008 Version=6337
N: Name="AlpsPS/2 ALPS GlidePoint"
P: Phys=isa0060/serio1/input0
S: Sysfs=/class/input/input8
U: Uniq=
H: Handlers=mouse2 event8
B: EV=f
B: KEY=420 0 70000 0 0 0 0 0 0 0 0
B: REL=3
B: ABS=1000003

I: Bus=0003 Vendor=413c Product=2010 Version=0110
N: Name="Dell Dell USB Keyboard"
P: Phys=usb-0000:00:1d.7-8.3.1/input0
S: Sysfs=/class/input/input9
U: Uniq=
H: Handlers=kbd event1
B: EV=120003
B: KEY=10000 7 ff87207a c14057ff febeffdf ffefffff ffffffff fffffffe
B: LED=1f

I: Bus=0003 Vendor=413c Product=2010 Version=0110
N: Name="Dell Dell USB Keyboard"
P: Phys=usb-0000:00:1d.7-8.3.1/input1
S: Sysfs=/class/input/input10
U: Uniq=
H: Handlers=kbd event2
B: EV=b
B: KEY=3878 c8015001 e0000 0 0 0
B: ABS=1 0

I: Bus=0003 Vendor=046d Product=c025 Version=0110
N: Name="B16_b_02 USB-PS/2 Optical Mouse"
P: Phys=usb-0000:00:1d.7-8.3.3/input0
S: Sysfs=/class/input/input11
U: Uniq=
H: Handlers=mouse0 event3
B: EV=20007
B: KEY=ff0000 0 0 0 0 0 0 0 0
B: REL=103
B: LED=ff00


Strange that this does not work.
_________________
Michael
Back to top
View user's profile Send private message
fredor
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2003
Posts: 84
Location: UK

PostPosted: Fri Jan 18, 2008 11:23 am    Post subject: Reply with quote

Have you tried the external keyboard this is the same as mine:-

Name="AT Translated Set 2 keyboard"

Go to /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi
and change "<merge key="input.xkb.layout" type="string">us</merge>"
to "<merge key="input.xkb.layout" type="string">ch</merge>"
with a text editor. In my case it is line 19.

If this works you can copy the file to "/etc/hal/fdi/policy/" or it may be changed with updated versions of hal.
_________________
Gentoo /amd64/2007.0
AMD Athlon64 X2 4200+
ASUS M2N32-SLI Deluxe
Back to top
View user's profile Send private message
bos_mindwarp
Apprentice
Apprentice


Joined: 19 Oct 2002
Posts: 275
Location: stockholm, sweden

PostPosted: Sat Jan 19, 2008 8:18 am    Post subject: Reply with quote

devsk wrote:
Code:
>=sys-apps/hal-0.5.10
>=x11-drivers/xf86-input-evdev-1.2.0
>=app-misc/hal-info-20071011
Is what I had to do to get my mouse working properly again. HAL is not an option for me because I think it is just cr*@. You run it and many things like suspend/resume will just break.



/signed

what I dont understand is why is it unmasked in first place when it clearly breaks stuff
Back to top
View user's profile Send private message
Turrican
Tux's lil' helper
Tux's lil' helper


Joined: 12 Mar 2003
Posts: 112
Location: Germany

PostPosted: Sat Jan 19, 2008 12:37 pm    Post subject: Reply with quote

Well, my problem was, that the "up" key made a screenshot in KDE.
After I edited the hal config (/etc/hal/fdi/policy/x11-input.fdi) the problem was still there.

For me the solution was to switch to "evdev-managed keyboard" in the KDE control center.
_________________
Windows hates me!
Back to top
View user's profile Send private message
wizard69
Apprentice
Apprentice


Joined: 22 Sep 2003
Posts: 178
Location: Berlin

PostPosted: Sun Jan 20, 2008 5:18 pm    Post subject: Reply with quote

masking the following packages also helped me

Code:
>=sys-apps/hal-0.5.10
>=x11-drivers/xf86-input-evdev-1.2.0
>=app-misc/hal-info-20071011


I don't understand why these packages where unmasked in the first place. I have a Logitech MX700 mouse/keyboard which is connected to my nb (dell vostro) via one usb cable for both devices. Everytime i press the right mouse button with the mentioned versions of hal and evdev X crashes and i'm back at the gdm login. I tried the other suggestions in this thread but they lead to other side effects like not being able to open apps from the panel in gnome. Basic applications like evdev and hal should be tested against these sort of problems before they hit the portage tree even in ~x86. I don't mind tweaking config files or recompiling a package to make it work with a new version. But getting left with a completely broken mouse and keyboard driver which crashes X after pressing the right mouse button is to much. :(
_________________
Gentoo Blog
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Sun Jan 20, 2008 10:15 pm    Post subject: Reply with quote

wizard69 wrote:
masking the following packages also helped me

Code:
>=sys-apps/hal-0.5.10
>=x11-drivers/xf86-input-evdev-1.2.0
>=app-misc/hal-info-20071011


I don't understand why these packages where unmasked in the first place. I have a Logitech MX700 mouse/keyboard which is connected to my nb (dell vostro) via one usb cable for both devices. Everytime i press the right mouse button with the mentioned versions of hal and evdev X crashes and i'm back at the gdm login. I tried the other suggestions in this thread but they lead to other side effects like not being able to open apps from the panel in gnome. Basic applications like evdev and hal should be tested against these sort of problems before they hit the portage tree even in ~x86. I don't mind tweaking config files or recompiling a package to make it work with a new version. But getting left with a completely broken mouse and keyboard driver which crashes X after pressing the right mouse button is to much. :(

Hi, wizard69.
The problem is not that gentoo guys did not test evdev and hal. They are tested long before they hit the portage and all the problems are known. The problem is, hal is not following an open source manner. If you read the blog entries from hal maintainer of gentoo, you will see. Also notice hal is not reached version 1.0, yet. And I guess you are using unstable ~arch.
Also you are right; the crashes of X after pressing the right mouse button is to much. :(
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
slim.one
n00b
n00b


Joined: 18 Oct 2006
Posts: 7

PostPosted: Mon Jan 21, 2008 10:59 am    Post subject: Reply with quote

keenblade wrote:
If you say so, then it is so; since you are experiencing that. I don't have quake-3 at the moment to try. I was just referring that both evdev and kbd drivers have the keyboard layout problem. Because you said that for the first time all your keyboard-buttons worked.
Is your mouse working fine outside quake-3?

you might try emerging quake3-demo or enemy-territory, should result in the same problems (don't forget 'in_dgamouse 1' in console). of course you could try to play without dga, but you really don't want to do that, at least not in a fast shooter like q3a.
outside q3 the mouse works pretty well, better than with the old mouse-driver... i switch to the old mouse-driver when i play (kind of dual-boot :) )
Back to top
View user's profile Send private message
pezed
n00b
n00b


Joined: 16 Oct 2003
Posts: 31

PostPosted: Mon Jan 21, 2008 6:31 pm    Post subject: Reply with quote

i downgraded to hal 0.5.9.1-r3 and it fixed all of my problems. (especially had problems with keyboard under vmware)

I'm still using evdev 1.2. hal 0.5.10 is the problem, not evdev!!
Back to top
View user's profile Send private message
DesertF0x
n00b
n00b


Joined: 28 Oct 2005
Posts: 4
Location: Germany Bremen

PostPosted: Tue Jan 22, 2008 9:45 am    Post subject: Possible Solution: Disabling autodetect / hotplugging Reply with quote

Found something which really helped me:

Quote:

You have hal-0.5.10 installed and it's hotplugging devices. To disable
hotplugging, put
Option "AutoAddDevices" "false"
in Section ServerFlags. Or switch in X to an evdev keyboard layout, since it
overrides your xorg.conf settings.


My Problem was the Keyboard layout and especially that the scrolling function of the ibm trackpoint / trackstick was gone.
Within disabling AutoAddDevices my old xorg.conf worked fine again.
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Tue Jan 29, 2008 9:31 am    Post subject: Reply with quote

First some info fo the ones not grasping this:
In xorg-server-1.4 there is hotplug possibilities.
To utilize them you need hal-0.5.10 and evdev-1.2.
It works like this:
X starts and asks HAL for input devices.
HAL tells X what inputdevices it knows of and how they should be configured (what driver to use, what layout to use).
X uses this information, starts the driver and configure it according to how HAL tells it to

What this means for the user:
If you have all the required components and right verions then your devices are hotplugged and the configuration for them resides with HAL (Input sections in xorg.conf is in this case depricated).
If any dependency is not met Xorg uses the old way of managing your devices (input sections in your xorg.conf is used).

So:
No special version of these packages are broken or "are the problem" in any way. If you experience problems this is most likely becouse you have not (re)configured things like you should.

If you do not intend to use hotplugging and do not use evdev, then 'emerge -C xf86-input-evdev' (and remove 'evdev' from your INPUT_DEVICES="" in make.conf).
If you do use evdev but still want to use the configurations from xorg.conf, then do as DesertFox told you and add
Code:
Option "AutoAddDevices" "false"
in your "Serverflags" section inside your xorg.conf.
For all else:
Look inside /usr/share/hal/fdi/policy/10osvendor/ for example configurations.
Copy the ones you like to /etc/hal/fdi/policy/ and change them to suit your needs.

And it is unmasked becouse testing is needed. it is in ~arch becouse it should work for most of you IF CONFIGURED RIGHT.
And things like my crash-click (described below) is that kind of issues the developers are looking for and they should be reported and fixed so this things could become usable for all and later stable sometime in the future.


For all you who have problems with up giving screenshots and alike:

This is a problem with your X-settings conflicting with your settings in the DE (GNOME, KDE). You may not have set them in the DE yourself, but still.
The fix is (at least in GNOME) very easy. Just reset your keyboard settings in the userprofile for your DE (in GNOME do 'gconftools-2 --recursive-unset /desktop/gnome/periphials (from memory, could be spelling-issues) and relogin).



That said I still have problems with my middle/right mousebutton crashing X for my Logitech keyboard+mouse. If I look inside my Xorg.0.log it seems like it can be becouse of a missconfigureation. It detects a keyboard on my mouse, try setting that one up with a 'us' layout (my keyboard is according to Xorg.log configuread as a 'se' which it also is in HAL). This leaves me with a us-keyboard and crash-clicking. this seems to be a upstream-problem.

And for all you whining about "oooooh, it is SOOO unstable": it works perfectly FINE on my other computer, which does have a USB-keyboard and a wireless USB-mouse. So it is only for some keyboard/mouse setups it breaks, and those will not be found if not the ones having them never tries this feature and bugreport. That is what ~arch is for.

If you can not handle this you do not belong in ~arch.

EDIT:

Sorry for being a bit grumpy. I took a look in this thread and find that many misundrstandings and declarations that borders to FUD so I wanted to try to set things straight.
This edit is about the right-cklick issue: for us having it please see bug 204951.
Back to top
View user's profile Send private message
Luda
n00b
n00b


Joined: 21 Feb 2004
Posts: 45
Location: Germany

PostPosted: Tue Jan 29, 2008 6:23 pm    Post subject: Reply with quote

Okay, so we don't need the device-sections in our xorg.confs anymore, but how do we tell hal whch keymap to use?

I can tell KDE that I've got a keyboard with de-layout, shure, but what about, for example, KDM?

Maybe something is wrong with my setup:
Code:
==) Log file: "/var/log/Xorg.0.log", Time: Tue Jan 29 19:17:12 2008
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen 1" (0)
(**) |   |-->Monitor "Samsung"
(**) |   |-->Device "GeForce4-Ti4200"
(==) Automatically adding devices
(==) Automatically enabling devices
.
.
.
==) |-->Input Device "<default pointer>"
(==) |-->Input Device "<default keyboard>"
(==) The core pointer device wasn't specified explicitly in the layout.
        Using the default mouse configuration.
(==) The core keyboard device wasn't specified explicitly in the layout.
        Using the default keyboard configuration.
.
.
.
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
        compiled for 1.4.0, module version = 1.2.3
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.0
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
        compiled for 1.4.0, module version = 1.2.2
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.0
.
.
.
(WW) <default pointer>: No Device specified, looking for one...
(II) <default pointer>: Setting Device option to "/dev/input/mice"
(--) <default pointer>: Device: "/dev/input/mice"
(==) <default pointer>: Protocol: "Auto"
(**) Option "CorePointer"
(**) <default pointer>: always reports core events
(==) <default pointer>: Emulate3Buttons, Emulate3Timeout: 50
(**) <default pointer>: ZAxisMapping: buttons 4 and 5
(**) <default pointer>: Buttons: 9
(**) <default pointer>: Sensitivity: 1
(**) Option "CoreKeyboard"
(**) <default keyboard>: always reports core events
(**) Option "Protocol" "standard"
(**) <default keyboard>: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) <default keyboard>: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) <default keyboard>: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) <default keyboard>: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) <default keyboard>: CustomKeycodes disabled
(II) evaluating device (<default keyboard>)
(II) XINPUT: Adding extended input device "<default keyboard>" (type: KEYBOARD)
(II) evaluating device (<default pointer>)
(II) XINPUT: Adding extended input device "<default pointer>" (type: MOUSE)
(--) <default pointer>: PnP-detected protocol: "ExplorerPS/2"
(II) <default pointer>: ps2EnableDataReporting: succeeded


Is this the way it is supposed to work?
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Tue Jan 29, 2008 11:01 pm    Post subject: Reply with quote

my /etc/hal/fdi/policy/10-keymap.fdi

Code:
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>

      <merge key="input.xkb.layout" type="string">se</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>


This one is copied from /usr/share/hal/fdi/policy/10ovendor/10-keymap.fdi and edited to use "se" instead of "us".

For my system the fact that the mouse is identified as a keyboard too mess this up, so I actually also need to have a duplicate of this file with exactly the same but "input.mouse" instead of "input.keys" to not have the mouse reset my layout/keymap..
Back to top
View user's profile Send private message
Luda
n00b
n00b


Joined: 21 Feb 2004
Posts: 45
Location: Germany

PostPosted: Wed Jan 30, 2008 12:20 pm    Post subject: Reply with quote

Oh, well..

first of all: I mixed up the directories.
second: I had a look at 10-keyboard-policy.fdi and wondered where I could change the layout, because there is no file called 10-keymap.fdi on my system.

I will have a second look at this issue this evening, thanks for now :)
Back to top
View user's profile Send private message
mathfeel
l33t
l33t


Joined: 03 Aug 2004
Posts: 700

PostPosted: Thu Jan 31, 2008 7:48 am    Post subject: Reply with quote

My keyboard and mouse are working except that I don't have the CONTROL key...I am not sure if it is related to the fact that some other devices are also recognized as keyboard:

Code:
(II) evaluating device (TouchPad)
(II) XINPUT: Adding extended input device "TouchPad" (type: MOUSE)
Synaptics DeviceInit called
SynapticsCtrl called.
Synaptics DeviceOn called
(--) TouchPad auto-dev sets device to /dev/input/event6
(**) Option "Device" "/dev/input/event6"
(--) TouchPad touchpad found
enable montype: 2
(II) RADEON(0): Damage tracking initialized for page flipping
(**) TPPS/2 IBM TrackPoint: always reports core events
(II) TPPS/2 IBM TrackPoint: Found 2 relative axes.
(II) TPPS/2 IBM TrackPoint: Configuring as pointer.
(II) TPPS/2 IBM TrackPoint: Found 3 mouse buttons
(II) TPPS/2 IBM TrackPoint: Configured 4 mouse buttons.
(II) XINPUT: Adding extended input device "TPPS/2 IBM TrackPoint" (type: MOUSE)
(**) TPPS/2 IBM TrackPoint: 2 valuators.
(**) TPPS/2 IBM TrackPoint: Configuring in Absolute mode.
(**) TPPS/2 IBM TrackPoint: Registering 4 buttons.
(II) TPPS/2 IBM TrackPoint: Init
(II) TPPS/2 IBM TrackPoint: On
(**) Video Bus: always reports core events
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
evdev: leds are 0x0 for device 4
(II) Video Bus: Init
(II) Video Bus: On
(**) ThinkPad Extra Buttons: always reports core events
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) XINPUT: Adding extended input device "ThinkPad Extra Buttons" (type: KEYBOARD)
evdev: leds are 0x0 for device 5
(II) ThinkPad Extra Buttons: Init
(II) ThinkPad Extra Buttons: On
(**) AT Translated Set 2 keyboard: always reports core events
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)

_________________
-----------------------------------------------------------
"In heaven all the interesting people are missing"
-- Friedrich Nietzsche
Back to top
View user's profile Send private message
superbrain666
n00b
n00b


Joined: 14 Apr 2005
Posts: 43
Location: Gentoo, Tübingen, Germany, World

PostPosted: Thu Jan 31, 2008 5:47 pm    Post subject: Almost solved for me Reply with quote

I fixed the issue with adding the correct HAL informations.
And telling KDE to use this evdev-mapped-keyboard.

BUT: My VM in VMWARE is still broken. This means my windows has problems with the cursor keys.
Very ugly because i use windows only for playing games... so games without cursors are not possible :cry:

I think it has something to do with VMWAREs build-in GTK interface or with the GTK on my Gentoo, which is not ready for evdev.
Is it possible I tell VMWARE to use the correct keymap? Maybe in a config?

I've tried to clean out my .gnomeXX and .gconf folders with no change.
Back to top
View user's profile Send private message
mhgentoo
n00b
n00b


Joined: 23 Dec 2007
Posts: 3

PostPosted: Sat Feb 02, 2008 12:48 pm    Post subject: it works after masking hal Reply with quote

i did what renrutal decided.
this works fine.
like you mentioned before, hal is the problem!

thanks for this help.
Back to top
View user's profile Send private message
Luda
n00b
n00b


Joined: 21 Feb 2004
Posts: 45
Location: Germany

PostPosted: Sat Feb 02, 2008 5:56 pm    Post subject: Reply with quote

Luda wrote:
I will have a second look at this issue this evening, thanks for now :)


Removed the current versions of hal, hal-info and evdev from package.mask, updated everything, which gave me the missing files, copied the needed fiels from /usr/share/... to /etc/..., switched the layout to "de" in 10-keymap.fdi, removed all input-devices from xorg.conf, told the KDE-Keyboard-selector to f*** off, restarted X and everything is working perfectly!

Even this crazy vertical mousewheel-button-thingie on my Logitech G5 works.


Thank you guys for sharing your knowledge =)
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Sat Feb 02, 2008 9:46 pm    Post subject: Re: it works after masking hal Reply with quote

mhgentoo wrote:
i did what renrutal decided.
this works fine.
like you mentioned before, hal is the problem!

thanks for this help.


HAL is not the problem. DBUS is not the problem. xf86-input-evdev is not the problem.
You configuration is the problem.

Read my post for futher info.
Back to top
View user's profile Send private message
appofice
n00b
n00b


Joined: 13 Jun 2007
Posts: 39

PostPosted: Sun Feb 03, 2008 12:13 am    Post subject: Reply with quote

I did have the same problem. I decide to mask the new package but now i decide to install evdev-1.2.0 and configure my xorg.conf.
My new xorg.conf for the input is like this

Section "InputDevice"

Identifier "Keyboard1"
Driver "evdev"
Option "Device" "/dev/input/by-id/usb-Microsoft_Comfort_Curve_Keyboard_2000-event-kbd"
Option "CoreKeyboard"
#Option "AutoRepeat" "500 30"
#Option "XkbRules" "xorg"
Option "XkbModel" "evdev"
#"pc105"
Option "XkbLayout" "ca"
Option "XkbVariant" "fr"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "evdev"
Option "CorePointer"
Option "Name" "Logitech USB-PS/2 Optical Mouse"
#Option "Protocol" "auto" # Mouse Systems (3-button protocol)
Option "Device" "/dev/input/by-id/usb-Logitech_USB-PS.2_Optical_Mouse-event-mouse"
Option "ZAxisMapping" "4 5 6 7"
Option "HWHEELRelativeAxisButtons" "7 6"

EndSection
now or for the moment my keyboard and mouse work well...

ps: i also did what Krampi say about /etc/hal/fdi/policy/x11-input.fdi

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
<device>
<match key="info.capabilities" contains="input.keys">
<merge key="input.xkb.layout" type="string">ca</merge>
<merge key="input.xkb.variant" type="string">fr</merge>
</match>
</device>
</deviceinfo>
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Sun Feb 03, 2008 10:12 am    Post subject: Reply with quote

appofice wrote:

<snip>
Section "InputDevice"
<snip>
Option "Device" "/dev/input/by-id/usb-Microsoft_Comfort_Curve_Keyboard_2000-event-kbd"
<snip>
EndSection

Section "InputDevice"
<snip>
Option "Device" "/dev/input/by-id/usb-Logitech_USB-PS.2_Optical_Mouse-event-mouse"
<snip>
EndSection
now or for the moment my keyboard and mouse work well...


Nice to hear it works. If you configure evdev in you xorg.conf Xorg is supposed to pick that up and use it, so it is possible Xorg uses that one. But the thought of this is that everything should be hotpluggable, right?;). Your file for HAL makes however a new keyboard still ca,fr without editing xorg.conf.

But if it does start to give problems, then take a look at this (from 'man evdev'):
Code:
       Option "Device" "string"
              Specifies the device  note  through  which  the  device  can  be
              accessed.   At  this  time ONLY /dev/input/eventn, where n is an
              integer, are matched against this this field.
              This option uses globbing.
              Please note that use of this option is strongly discouraged.

You can try use
Code:
Option "Phys" "string"
instead, how you configure that one is mentioned in 'man evdev' also.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 3 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum