Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11-drivers/xf86-input-evdev-1.2.0 keyboard problem
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Wed Jun 11, 2008 7:02 pm    Post subject: Reply with quote

Are you talking about the Page-Up <-> Screenshot-Problem?
_________________
Just you and me strogg!
Back to top
View user's profile Send private message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Wed Jun 11, 2008 7:03 pm    Post subject: Reply with quote

Xake wrote:
hoschi wrote:
It is a new macbook, new ;)
Okay: X11 with twm works without hal, X11 with twm and hal works, Gnome without hal works, but doesn't work with hal

Okay, back to zero: It is hal with gnome


So GNOME with hal breaks whatever even with a new (entirely clean) user profile?
Have you cleaned out /etc/gconf and ~/.gconf?


New laptop, new hdd, complete new gentoo-installation.
_________________
Just you and me strogg!
Back to top
View user's profile Send private message
Insanity5902
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1228
Location: Fort Worth, Texas

PostPosted: Thu Jun 12, 2008 4:57 am    Post subject: Reply with quote

I had the up and left arrow auto-repeat problem, but everything else worked fine.

After read it might be a gnome issue I ran gconf-cleaner, sadly I hit finish before I could read what it did b/c the UI froze a bit and I didn't know it ran the first click of "Next" took.

But whatever it did, it cleaned out the gconf entries and now my keybaord works fine. I have nothing setup in my xorg.conf for either my USB Mouse, Keybaord or Synaptic driver.

My next step to tackle is getting the synaptic options in the FDI.



So for those out there having problems, go give gconf-cleaner a try, when I ran it it cleaned out over 650 keys. Hopefully nothing is too broekn, but at least my arrow keys works
_________________
Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Sat Jun 14, 2008 8:55 am    Post subject: Reply with quote


  • Do not configure xorg.conf, this file is normaly not necessary with newer releases
  • Edit files in /etc/hal/fdi/policy only in special cases (touchpad with scrollfunction...)
  • Set evdev as keyboard driver in your desktop-environment
  • AND TO FUCKING HELL: TELL THE PEOPLE THEY SHOULD REMOVE THE regular mouse and keyboard drivers from xorg!!!

_________________
Just you and me strogg!
Back to top
View user's profile Send private message
WladyX
Guru
Guru


Joined: 25 Nov 2004
Posts: 503
Location: Romania

PostPosted: Sat Jun 14, 2008 10:35 am    Post subject: Reply with quote

hoschi wrote:

  • Do not configure xorg.conf, this file is normaly not necessary with newer releases


not necessary for input devices or not necessary for anything?
_________________
We are not alone.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sat Jun 14, 2008 1:40 pm    Post subject: Reply with quote

For input devices, other stuff is still needed (i.e. the graphic options).
Back to top
View user's profile Send private message
WladyX
Guru
Guru


Joined: 25 Nov 2004
Posts: 503
Location: Romania

PostPosted: Sat Jun 14, 2008 4:37 pm    Post subject: Reply with quote

Thanks for clearing that up :)
_________________
We are not alone.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7972
Location: Austria

PostPosted: Sat Jun 21, 2008 1:44 pm    Post subject: Reply with quote

Bloodsurfer wrote:
WTF?!? I just figured by chance, that my mouse's side buttons are working in Opera - just not in Firefox, where they were working before 8O How can that be?

I believe that's a firefox-3.0 issue, next/prev stopped working for me simultanously on both main and notebook systems. Everything's fine with opera, though.

In firefox-3 the next/prev functions are mapped to the buttons on top of my mx500. Not really usable... but how come?

EDIT: I just did update to evdev-1.2 and hal-0.5.11-r1, set up the fdi-file, commented out xorg.conf input sections... everything works like a charm except next/prev in firefox which is the same as before. The message at the end of emerge and a quick look in the forum pretty much explained everything, no DE-fdi hassle either thanks to e17. I'm using evdev for ages though.
Back to top
View user's profile Send private message
Undetected
n00b
n00b


Joined: 18 Jul 2003
Posts: 10
Location: KC

PostPosted: Mon Jun 23, 2008 5:34 am    Post subject: Reply with quote

According to this bugzilla entry, this is a known FF3 issue, but not really a bug
https://bugzilla.mozilla.org/show_bug.cgi?id=420294

I have an mx700 and had the same problem. Re-assigning the buttons with xmodmap, as suggested in the entry, seems to clear everything up.
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Sat Jul 19, 2008 5:24 pm    Post subject: Reply with quote

Hello.

If X fails to pick up your keyboard correctly and you get the usual arrow-keys problem, you need to configure your keyboard in /etc/X11/xorg.conf *and* use the "Device" option. This also works for VMWare. Actually, it *especially* works nice with VMWare ;)

Note: In KDE, you *must* configure kxkb (the Keyboard Layouts section in the Control Center) to use "Evdev-managed keyboard". *Not* "pc104" or anything else. Same goes for GNOME I guess. If you actually don't need to switch between keyboard layouts, don't enable keyboard layouts in KDE at all (and even umerge the kxkb package if you want to remove the section from the Control Center.)

Code:
Section "InputDevice"
    Identifier "evdevKeyboard"
    Driver   "evdev"
    Option   "AutoRepeat" "250 30"
    Option   "Device" "/dev/input/by-path/platform-i8042-serio-0-event-kbd"
    Option   "XkbModel"   "evdev"
    Option   "XkbLayout"  "us"
EndSection


If there's an 'Option "XkbRules" "xorg"' entry, delete it/comment it out.

The "Device" option differs by system. Do a 'ls /dev/input/by-path' to see what your keyboard is named like.

For VMWare, it is crucial to have this in the "ServerFlags" section if you still experience problems with the mouse and/or keyboard:

Code:
Option "AutoAddDevices" "false"


Make sure your keyboard settings are used in the "ServerLayout" section:

Code:
InputDevice "evdevKeyboard" "CoreKeyboard"
Back to top
View user's profile Send private message
Fran
Guru
Guru


Joined: 29 Feb 2004
Posts: 530
Location: Coruña (Spain)

PostPosted: Mon Aug 04, 2008 1:46 pm    Post subject: Reply with quote

So, has any gnome user solved the up=screenshot problem in any way that has not been explained yet? From time to time I try removing the input sections in xorg.conf, as well as the line
Code:
Option "AutoAddDevices" "false"

to see if it's been magically solved by some updated version of hal/xorg/gnome, but I still get that fucking screenshot dialog whenever I press "up", and my shortcuts that use the arrow keys (mod4+left/right to go to another desktop, for example) stop working or work randomly (sometimes they work, sometimes they don't).

I've read in some mail list that the problem is caused by gnome using an old xkb model instead of "Evdev-managed keyboard", but that's not my case. The button in the gnome keyboard configuration dialog says "Evdev-managed keyboard", and the output of setxkbmap -print is:
Code:
xkb_keymap {
   xkb_keycodes  { include "evdev+aliases(qwerty)"   };
   xkb_types     { include "complete"   };
   xkb_compat    { include "complete"   };
   xkb_symbols   { include "pc+us+inet(evdev)"   };
   xkb_geometry  { include "pc(pc104)"   };
};

I suppose that is correct, because if I write setxkbmap -model pc105, for example, setxkbmap -print shows
Code:
xkb_keymap {
   xkb_keycodes  { include "xfree86+aliases(qwerty)"   };
   xkb_types     { include "complete"   };
   xkb_compat    { include "complete"   };
   xkb_symbols   { include "pc+us"   };
   xkb_geometry  { include "pc(pc105)"   };
};

and things get even worse: pgup/pgdown and most of the special keys stop working. It's obvious that it has something to do with the keyboard models, because
Code:
$ grep PRSC /usr/share/X11/xkb/keycodes/xfree86
    <PRSC> = 111;
    <PRSC> = 121;
$ grep 111 /usr/share/X11/xkb/keycodes/evdev
   <UP> = 111;

but I have no fucking clue what to do to solve it. gconf-cleaner just tries to remove any gconf entry that has no schemas, so it's useless (the only keyboard-related entry in gconf without a schema is something about numlock), and I've tried with a clean gnome installation (new user with empty home dir), so it's not caused by some stale configuration.

With fluxbox everything works perfectly, of course. I tried assigning a shortcut to the print button to see if it was invoked when using the up cursor, but it isn't. And the shortcuts that use the arrows work ok.

So, will I have to continue disabling AutoAddDevices forever? I haven't seen any open bug in any bugzilla (gnome, gentoo or any other distro), so maybe this is considered fixed and I'm too fucking dumb to fix it in my computer??
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Mon Aug 04, 2008 3:50 pm    Post subject: Reply with quote

@Fran: your post tempts me to do some out-of-context quoting,
but as I wrote already many times:
check (and post) the output of `hal-device <device name>`
of device(s) listed by `hal-find-by-capability --capability input.keys`.
Back to top
View user's profile Send private message
Fran
Guru
Guru


Joined: 29 Feb 2004
Posts: 530
Location: Coruña (Spain)

PostPosted: Mon Aug 04, 2008 5:57 pm    Post subject: Reply with quote

VoidMage wrote:
@Fran: your post tempts me to do some out-of-context quoting,
but as I wrote already many times:
check (and post) the output of `hal-device <device name>`
of device(s) listed by `hal-find-by-capability --capability input.keys`.

Code:
franjva@quad ~ $ hal-find-by-capability --capability input.keys
/org/freedesktop/Hal/devices/pci_109e_36e_logicaldev_input
/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if1_logicaldev_input
/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if0_logicaldev_input
franjva@quad ~ $ hal-device /org/freedesktop/Hal/devices/pci_109e_36e_logicaldev_input
udi = '/org/freedesktop/Hal/devices/pci_109e_36e_logicaldev_input'
  input.originating_device = '/org/freedesktop/Hal/devices/pci_109e_36e'  (string)
  info.category = 'input'  (string)
  input.xkb.rules = 'base'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1e.0/0000:05:02.0/input/input6/event5'  (string)
  info.capabilities = { 'input', 'input.keys', 'button' } (string list)
  info.subsystem = 'input'  (string)
  input.xkb.model = 'evdev'  (string)
  info.parent = '/org/freedesktop/Hal/devices/pci_109e_36e'  (string)
  info.product = 'bttv IR (card=120)'  (string)
  input.xkb.layout = 'us'  (string)
  input.device = '/dev/input/event5'  (string)
  info.udi = '/org/freedesktop/Hal/devices/pci_109e_36e_logicaldev_input'  (string)
  input.xkb.variant = ''  (string)
  input.product = 'bttv IR (card=120)'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  input.x11_driver = 'evdev'  (string)
  linux.subsystem = 'input'  (string)
  linux.device_file = '/dev/input/event5'  (string)
  info.addons.singleton = { 'hald-addon-input' } (string list)

franjva@quad ~ $ hal-device /org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if1_logicaldev_input
udi = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if1_logicaldev_input'
  input.originating_device = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if1'  (string)
  info.category = 'input'  (string)
  input.xkb.rules = 'base'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1a.1/usb4/4-1/4-1:1.1/input/input3/event3'  (string)
  info.capabilities = { 'input', 'input.keys', 'button' } (string list)
  info.subsystem = 'input'  (string)
  input.xkb.model = 'evdev'  (string)
  info.parent = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if1'  (string)
  info.product = 'Darfon USB Combo Keyboard'  (string)
  input.xkb.layout = 'us'  (string)
  input.device = '/dev/input/event3'  (string)
  info.udi = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if1_logicaldev_input'  (string)
  input.xkb.variant = ''  (string)
  input.product = 'Darfon USB Combo Keyboard'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  input.x11_driver = 'evdev'  (string)
  linux.subsystem = 'input'  (string)
  linux.device_file = '/dev/input/event3'  (string)
  info.addons.singleton = { 'hald-addon-input' } (string list)

franjva@quad ~ $ hal-device /org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if0_logicaldev_input
udi = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if0_logicaldev_input'
  input.originating_device = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if0'  (string)
  info.category = 'input'  (string)
  input.xkb.rules = 'base'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1a.1/usb4/4-1/4-1:1.0/input/input2/event2'  (string)
  info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'button' } (string list)
  info.subsystem = 'input'  (string)
  input.xkb.model = 'evdev'  (string)
  info.parent = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if0'  (string)
  info.product = 'Darfon USB Combo Keyboard'  (string)
  input.xkb.layout = 'us'  (string)
  input.device = '/dev/input/event2'  (string)
  info.udi = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if0_logicaldev_input'  (string)
  input.xkb.variant = ''  (string)
  input.product = 'Darfon USB Combo Keyboard'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  input.x11_driver = 'evdev'  (string)
  linux.subsystem = 'input'  (string)
  linux.device_file = '/dev/input/event2'  (string)
  info.addons.singleton = { 'hald-addon-input' } (string list)


I don't know why I have 2 event devices for the keyboard with different capabilities :?. Anyway, that's the output.
Back to top
View user's profile Send private message
Fran
Guru
Guru


Joined: 29 Feb 2004
Posts: 530
Location: Coruña (Spain)

PostPosted: Mon Aug 04, 2008 6:19 pm    Post subject: Reply with quote

BTW, I also tried changing .keymap to .keys and rules=base to rules=evdev:
Code:
franjva@quad ~ $ hal-device /org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if1_logicaldev_input
udi = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if1_logicaldev_input'
  input.originating_device = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if1'  (string)
  info.category = 'input'  (string)
  input.xkb.rules = 'evdev'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1a.1/usb4/4-1/4-1:1.1/input/input3/event3'  (string)
  info.capabilities = { 'input', 'input.keys', 'button' } (string list)
  info.subsystem = 'input'  (string)
  input.xkb.model = 'evdev'  (string)
  info.parent = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if1'  (string)
  info.product = 'Darfon USB Combo Keyboard'  (string)
  input.xkb.layout = 'es'  (string)
  input.device = '/dev/input/event3'  (string)
  info.udi = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if1_logicaldev_input'  (string)
  input.xkb.variant = ''  (string)
  input.product = 'Darfon USB Combo Keyboard'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  input.x11_driver = 'evdev'  (string)
  linux.subsystem = 'input'  (string)
  info.callouts.add = { 'hal-setup-keymap' } (string list)
  linux.device_file = '/dev/input/event3'  (string)
  info.addons.singleton = { 'hald-addon-input' } (string list)

franjva@quad ~ $ hal-device /org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if0_logicaldev_input
udi = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if0_logicaldev_input'
  input.originating_device = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if0'  (string)
  info.category = 'input'  (string)
  input.xkb.rules = 'evdev'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1a.1/usb4/4-1/4-1:1.0/input/input2/event2'  (string)
  info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'button' } (string list)
  info.subsystem = 'input'  (string)
  input.xkb.model = 'evdev'  (string)
  info.parent = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if0'  (string)
  info.product = 'Darfon USB Combo Keyboard'  (string)
  input.xkb.layout = 'es'  (string)
  input.device = '/dev/input/event2'  (string)
  info.udi = '/org/freedesktop/Hal/devices/usb_device_d62_1c_noserial_if0_logicaldev_input'  (string)
  input.xkb.variant = ''  (string)
  input.product = 'Darfon USB Combo Keyboard'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  input.x11_driver = 'evdev'  (string)
  linux.subsystem = 'input'  (string)
  info.callouts.add = { 'hal-setup-keymap' } (string list)
  linux.device_file = '/dev/input/event2'  (string)
  info.addons.singleton = { 'hald-addon-input' } (string list)


but the problem persists.

(edit) This is my latest /etc/hal/fdi/policy/10-keymap.fdi, in case it's useful:
Code:
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keys">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
      <merge key="input.xkb.rules" type="string">evdev</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">es</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>
Back to top
View user's profile Send private message
Fran
Guru
Guru


Joined: 29 Feb 2004
Posts: 530
Location: Coruña (Spain)

PostPosted: Wed Aug 06, 2008 7:44 pm    Post subject: Reply with quote

Ok, I've solved it. The fucking solution was... TO USE GDM. I was using startx instead of a login manager. With startx: up->screenshot, no matter what you do. With GDM, everything works ok :roll:. Well, ALMOST ok. If I use Mod4+left to go to a previous desktop, the gnome pager thingie (not the applet, but the popup pager in the center of the screen) disappears even though I haven't released Mod4. With Mod4+right, however, the pager remains, as it always has.

Well, I can live with that.
Back to top
View user's profile Send private message
Smart1
n00b
n00b


Joined: 16 May 2007
Posts: 66

PostPosted: Thu Oct 02, 2008 7:06 pm    Post subject: Reply with quote

I have continually Problem with loosing of keyboard. :evil:

emerge -a xf86-input-evdev xf86-input-keyboard xf86-input-mouse xf86-video-v4l kima

In mine xorg.conf I don't have "input" for mouse and keyboard. All is excluded. :)

I have copied

cp -a /usr/share/hal/fdi/policy/10osvendor/10-input-policy.fdi /etc/hal/fdi/policy/ :)

And only adjust to use "ch" keyboard

<merge key="input.xkb.layout" type="string">ch</merge>
<merge key="input.xkb.variant" type="string">nodeadkeys</merge>

/etc/init.d/hald restart

In KDE i have adjusted for keyboard "evdev-managed keyboard" :)

Somedays I can work with X 15-20 hours, and somedays only 30 minutes. :twisted:

If I exit KDE i can type on prompt.

Again "startx" and the keyboard for a Time works. :?

Please what, can I do more to fix this problems. :?:

Regards,
_________________
http://www.gentoo.org/ http://www.sysresccd.org/ http://www.linuxquestions.org/

Registered Linux user: #130654 http://counter.li.org
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Sat Oct 04, 2008 3:53 pm    Post subject: Reply with quote

Smart1 wrote:
I have continually Problem with loosing of keyboard. :evil:


With loosing you mean it stops working? That does not sound like any problem I have encountered so far...
Are you sure it is xorg and not a hardware problem?
Back to top
View user's profile Send private message
Smart1
n00b
n00b


Joined: 16 May 2007
Posts: 66

PostPosted: Sun Oct 05, 2008 11:35 am    Post subject: Reply with quote

Yes it stop working and I have only Mouse. :oops:

I have full Keyboard if I can switch to console.

Have tried too to add Option "AutoAddDevices" "false" to xorg.conf

Section "ServerLayout"
# https://bugs.gentoo.org/show_bug.cgi?id=205406
# Option "AutoAddDevices" "false"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
# InputDevice "Keyboard0" "CoreKeyboard"
# InputDevice "Mouse0" "CorePointer"
# InputDevice "Mouse0" "SendCoreEvents"
EndSection

I have restarted hald with
/etc/init.d/hald restart

but this not helps, hangs too.

I have this Problem first with new hal and new KDE 3.5.10.

This happens ordinarily if I work quickly as usual with the Keyboard. But not always.

Could I shall change Keyboard? This is a old Logitech Deluxe, PS2.
_________________
http://www.gentoo.org/ http://www.sysresccd.org/ http://www.linuxquestions.org/

Registered Linux user: #130654 http://counter.li.org
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Mon Oct 06, 2008 11:16 am    Post subject: Reply with quote

Smart1 wrote:
Yes it stop working and I have only Mouse. :oops:

I have full Keyboard if I can switch to console.

Have tried too to add Option "AutoAddDevices" "false" to xorg.conf

Section "ServerLayout"
# https://bugs.gentoo.org/show_bug.cgi?id=205406
# Option "AutoAddDevices" "false"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
# InputDevice "Keyboard0" "CoreKeyboard"
# InputDevice "Mouse0" "CorePointer"
# InputDevice "Mouse0" "SendCoreEvents"
EndSection

I have restarted hald with
/etc/init.d/hald restart

but this not helps, hangs too.

I have this Problem first with new hal and new KDE 3.5.10.

This happens ordinarily if I work quickly as usual with the Keyboard. But not always.

Could I shall change Keyboard? This is a old Logitech Deluxe, PS2.


What does you /var/log/Xorg.0.log say?
Have you tried with no Xorg settings in hal, to se if it even brings up a default keyboard (ie us).
Back to top
View user's profile Send private message
Smart1
n00b
n00b


Joined: 16 May 2007
Posts: 66

PostPosted: Mon Oct 06, 2008 8:22 pm    Post subject: Reply with quote

First I have used hal-0.5.11-r2, with him I have only occasionall Problems with Keyboard.

Then I tried to write Yours here a Answer with this Version.

But, if I tried to write, Keyboard ALWAYS hangs. With first letter! I have tried often, perhaps 5-6.

Then I have turn off PC and restart.

I think this is also a Problem between mozilla-firefox-bin- 3.0.3 and hal. I have opened about 60 Tabs.

Now I have reduced to 40.

I have installed hal-0.5.10, with him I don't have Keyboard and Mouse generally.

Now I have installed hal-0.5.11-r3 and Keyboard and Mouse works at the moment.

Xorg.0.log

(II) config/hal: Adding input device Logitech Logitech USB Headset
(II) LoadModule: "evdev"

(II) Loading /usr/lib64/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
compiled for 1.5.0, module version = 2.0.5
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.1
(**) Logitech Logitech USB Headset: always reports core events
(**) Logitech Logitech USB Headset: Device: "/dev/input/event5"
(II) Logitech Logitech USB Headset: Found keys
(II) Logitech Logitech USB Headset: Configuring as keyboard
(II) XINPUT: Adding extended input device "Logitech Logitech USB Headset" (type: KEYBOARD)
(**) Option "xkb_rules" "base"
(**) Logitech Logitech USB Headset: xkb_rules: "base"
(**) Option "xkb_model" "evdev"
(**) Logitech Logitech USB Headset: xkb_model: "evdev"
(**) Option "xkb_layout" "ch"
(**) Logitech Logitech USB Headset: xkb_layout: "ch"
(**) Option "xkb_variant" "nodeadkeys"
(**) Logitech Logitech USB Headset: xkb_variant: "nodeadkeys"
(II) config/hal: Adding input device ImExPS/2 Logitech Explorer Mouse
(**) ImExPS/2 Logitech Explorer Mouse: always reports core events
(**) ImExPS/2 Logitech Explorer Mouse: Device: "/dev/input/event2"
(II) ImExPS/2 Logitech Explorer Mouse: Found x and y relative axes
(II) ImExPS/2 Logitech Explorer Mouse: Found mouse buttons
(II) ImExPS/2 Logitech Explorer Mouse: Configuring as mouse
(II) XINPUT: Adding extended input device "ImExPS/2 Logitech Explorer Mouse" (type: MOUSE)
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event0"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "base"
(**) AT Translated Set 2 keyboard: xkb_rules: "base"
(**) Option "xkb_model" "evdev"
(**) AT Translated Set 2 keyboard: xkb_model: "evdev"
(**) Option "xkb_layout" "ch"
(**) AT Translated Set 2 keyboard: xkb_layout: "ch"
(**) Option "xkb_variant" "nodeadkeys"
(**) AT Translated Set 2 keyboard: xkb_variant: "nodeadkeys"

I have tried to write for Keyboard "us" in 10-keymap.fdi but is allways detected as "ch"

I think the Version hal-0.5.11-r3 is perhaps good.
_________________
http://www.gentoo.org/ http://www.sysresccd.org/ http://www.linuxquestions.org/

Registered Linux user: #130654 http://counter.li.org
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Mon Oct 06, 2008 8:44 pm    Post subject: Reply with quote

Smart1 wrote:
<snip>

I have tried to write for Keyboard "us" in 10-keymap.fdi but is allways detected as "ch"

I think the Version hal-0.5.11-r3 is perhaps good.


Here something feels wrong. If not configured I think Xorg always sets itself to "us", as afaik Xorg can not really detect what layout your keyboard have.
Have you commented out everything input-related from xorg.conf for testing purposes?

If you do start X with only an xterm (no DE, no WM, no nothing) does it still misbehaves?


Apart from that I can really not se anything wrong in the log... Anyone else see something I have missed?
Back to top
View user's profile Send private message
Smart1
n00b
n00b


Joined: 16 May 2007
Posts: 66

PostPosted: Mon Oct 06, 2008 9:06 pm    Post subject: Reply with quote

Yes all of "Input" is commented.

I have not tried to start X only with xterm. And I don't know how to do this.

~/.xinitrc
startkde

I have tried different Options in the xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Thu Jul 17 18:39:00 PDT 2008

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (root@dusko) Mon Aug 25 17:05:20 CEST 2008
# http://gentoo-wiki.com/TV-Out_with_GeForce
#Section "Device"
# Identifier "Videocard0"
# Driver "nvidia"
# VendorName "Chaintech"
# BoardName "nVidia GeForce 4 MX 440"
# Option "RenderAccel" "1"
# # TV Out Setup
# Option "TVStandard" "PAL-B"
# Option "TVOutFormat" "SVIDEO"
# Option "TVOverScan" "0.6"
# Option "ConnectedMonitor" "TV" # Add this if you're having problems
#EndSection


Section "ServerLayout"
# Pošto sa novom verzijom hal-0.5.10 ne radi kursor u X-u
# da se iskljuci hal
# https://bugs.gentoo.org/show_bug.cgi?id=205406
# Option "AutoAddDevices" "false"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
# InputDevice "Keyboard0" "CoreKeyboard"
# InputDevice "Mouse0" "CorePointer"
# InputDevice "Mouse0" "SendCoreEvents"
EndSection

Section "Files"
# FontPath "/usr/share/fonts/sharefonts"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/corefonts"
FontPath "/usr/share/fonts/freefonts"
FontPath "/usr/share/fonts/freefont-ttf"
FontPath "/usr/share/fonts/terminus"
FontPath "/usr/share/fonts/dejavu"
FontPath "/usr/share/fonts/ttf-bitstream-vera"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/unifont"
FontPath "/usr/share/fonts/cronyx/100dpi/:unscaled"
FontPath "/usr/share/fonts/cronyx/misc/:unscaled"
FontPath "/usr/share/fonts/cronyx/75dpi/:unscaled"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
EndSection


Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection


Section "ServerFlags"
Option "Xinerama" "0"
EndSection

# ****************************************************************
# Sva podešavanja tastature i miša isključite, kad vam hal napravi
# /etc/hal/10-x11-input.fdi fajlu
# http://www.gentooforum.de/post/108441/keyboard-evdev.html
# ****************************************************************
# http://gentoo-wiki.com/HOWTO_Advanced_Mouse
# Autodetekcija
#Section "InputDevice"
# Identifier "Mouse0"
# Driver "evdev"
# Option "evBits" "+1-2"
# Option "keyBits" "~272-287"
# Option "relBits" "~0-2 ~6 ~8"
# Option "Pass" "3"
# http://gentoo-wiki.com/X11_Mouse/Individual_Configurations
# Option "ZAxisMapping" "4 5"
# Option "Buttons" "10"
# Option "SendCoreEvents"
#EndSection

# https://forums.gentoo.org/viewtopic-t-641870.html
# pomešano
#Section "InputDevice"
# Identifier "Mouse1"
# Driver "evdev"
# Option "Device" "/dev/input/event0"
# Option "evBits" "+1-2"
# Option "keyBits" "~272-287"
# Option "relBits" "~0-2 ~6 ~8"
#EndSection

# Prema adresama
#Section "InputDevice"
# Identifier "Mouse0"
# Driver "evdev"
# Option "Device" "/dev/input/event2" # (cat /proc/bus/input/devices)
# Option "Name" "ImExPS/2 Logitech Explorer Mouse"
#EndSection

# Staro pre evdev
#Section "InputDevice"
# # generated from data in "/etc/conf.d/gpm"
# Identifier "Mouse0"
# Driver "mouse"
# Option "Protocol" "ExplorerPS/2"
# Option "Device" "/dev/input/mice"
# Option "Emulate3Buttons" "no"
# Option "ZAxisMapping" "4 5"
#EndSection


# ************************************************************
# Sva podešavanja tastature isključite, kad vam hal napravi
# /etc/hal/10-x11-input.fdi fajlu
# ************************************************************
# http://gentoo-wiki.com/X11_Keyboard#Keyboard_Layout
# Autodetekcija
#Section "InputDevice"
# Identifier "Keyboard0"
# Option "CoreKeyboard"
# Option "XkbLayout" "ch"
# Option "XkbVariant" "de_nodeadkeys"
# Option "XkbModel" "evdev"
# Option "XkbRules" "xorg"
# Option "evBits" "+1"
# Option "keyBits" "~1-255 ~352-511"
# Option "Pass" "3"
# Driver "evdev"
#EndSection

# https://forums.gentoo.org/viewtopic-t-641870.html
#Section "InputDevice"
# Identifier "Keyboard0"
# Driver "evdev"
# Option "Device" "/dev/input/event0"
# Option "evBits" "+1"
# Option "keyBits" "~1-255 ~352-511"
# Option "XkbLayout" "gb"
#EndSection

# http://dongsupark.de/blog/archives/84
#Section "InputDevice"
# Identifier "Keyboard0"
# Driver "evdev"
# Option "CoreKeyboard"
# Option "XkbRules" "xorg"
# Option "XkbModel" "evdev"
# Option "XkbLayout" "us" # or any other keyboard layout
#EndSection

# Staro pre evdev
#Section "InputDevice"
# # generated from default
# Identifier "Keyboard0"
# Driver "kbd"
#EndSection


Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Panasonic"
HorizSync 30.0 - 95.0
VertRefresh 50.0 - 180.0
Option "DPMS"
# Users of reduced blanking now need:
# Option "ReducedBlanking"
EndSection


Section "Device"
# If you experience flickering, try setting the following line in
# the Device section of your xorg.conf file:
# Option "HWCursor" "false"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8800 GT"
# http://gentoo-wiki.com/Xorg/Transparency#Nvidia_.2B_Xorg
Option "RenderAccel" "true"
EndSection

Section "Screen"
# DefaultDepth 32
# Removed Option "metamodes" " 1280x1024_85 +0+0; 1024x768_85 +0+0; 1024x768 +0+0; 800x600 +0+0"
# Removed Option "metamodes" "1280x1024_85 +0+0; 1024x768_85 +0+0; 1024x768 +0+0; 800x600 +0+0"
# Removed Option "metamodes" "1280x1024 +0+0; 1024x768 +0+0; 800x600 +0+0"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "DynamicTwinView" "True"
# Option "DynamicTwinView" "False"
Option "DPMS" "TRUE"
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1280x1024_85 +0+0; 1280x1024 +0+0; 1024x768_85 +0+0; 800x600 +0+0"
# http://www.elitesecurity.org/t339351-Slackware-problem-sa-Refresh-rate-nvidia-driver
# Option "TwinViewXineramaInfoOrder" "CRT-0"
# Option "metamodes" "1024x768_85 +0+0; nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
_________________
http://www.gentoo.org/ http://www.sysresccd.org/ http://www.linuxquestions.org/

Registered Linux user: #130654 http://counter.li.org
Back to top
View user's profile Send private message
Da_G
n00b
n00b


Joined: 01 Nov 2006
Posts: 12

PostPosted: Mon Oct 06, 2008 10:20 pm    Post subject: Reply with quote

I tried a number of things to fix this issue, eventually got hal/evdev detecting my keyboard properly but up arrow was still triggering the wrong keycode.

Tried 'gdm' as opposed to 'startx' per a post above, and it works a treat. No further issues. Kind of a hassle having to login but, having a working up arrow is more important..
Back to top
View user's profile Send private message
Smart1
n00b
n00b


Joined: 16 May 2007
Posts: 66

PostPosted: Mon Oct 06, 2008 11:43 pm    Post subject: Reply with quote

I have still Problems with Keyboard. Shall I go away from xorg-server-1.5.1 or an other Programs? It is a never ending pain... :twisted:
_________________
http://www.gentoo.org/ http://www.sysresccd.org/ http://www.linuxquestions.org/

Registered Linux user: #130654 http://counter.li.org
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Tue Oct 07, 2008 8:59 am    Post subject: Reply with quote

Smart1 wrote:
I have still Problems with Keyboard. Shall I go away from xorg-server-1.5.1 or an other Programs? It is a never ending pain... :twisted:

Sooner or later you probably will figure it out, and if this is a error in the server, then who should bug-report so it can get fixed if not you?

Did you not have this problem with xorg-server-1.4?
If this problem came with a system update, exatly updating what package lead to this problem?

Do you use the hal useflag?
In that case anything related to input in you xorg.conf should be ignored as long as you enter a specific option into xorg.conf overriding hal.

To start a clean xterm, in console without a X started doing "X xterm" should work.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 8 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum