Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11-drivers/xf86-input-evdev-1.2.0 keyboard problem
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Tue May 13, 2008 8:04 pm    Post subject: Reply with quote

Just take a look at your and mine profile and you will see - I use gentoo for a long time and I solved a lot of funny problems. Hey! Of course I can simply switch back to stable X11 and wait until the developers solved the problems and declare in this thread (like many others) that the problem is solved.

If you will take a look through the thread you will also see, a lot of people here have this "upkey" problem and nobody knows what the problem is or how to solve, and the people who are lucky seem not to know why.



Sorry. But your post looks like "I managed it, you not! Your are a stupid fool. Leave the room through the door with sign other distriubtion."

And again, switching the distribution is not solving the problem!

PS:
Switchting "hal/evdev" off maybe doesn't work, because I assign input-devices with their names, most others use still device-names.
_________________
Just you and me strogg!
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Wed May 14, 2008 2:35 pm    Post subject: Reply with quote

Hey, hoschi. What does hal-device print for your keyboard, when it doesn't work correctly ?
Back to top
View user's profile Send private message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Wed May 14, 2008 7:44 pm    Post subject: Reply with quote

Just for you :)

Quote:
10: udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'
linux.device_file = '/dev/input/event4' (string)
input.xkb.model = 'evdev' (string)
input.product = 'AT Translated Set 2 keyboard' (string)
info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'button' } (string list)
info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input' (string)
linux.subsystem = 'input' (string)
input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port' (string)
info.product = 'AT Translated Set 2 keyboard' (string)
linux.hotplug_type = 2 (0x2) (int)
input.xkb.rules = 'base' (string)
linux.sysfs_path = '/sys/devices/platform/i8042/serio0/input/input4/event4' (string)
info.addons.singleton = { 'hald-addon-input' } (string list)
input.x11_driver = 'evdev' (string)
info.category = 'input' (string)
input.xkb.layout = 'us' (string)
input.physical_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port' (string)
input.device = '/dev/input/event4' (string)
info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port' (string)
input.xkb.variant = '' (string)


xorg.conf
Quote:
Section "ServerLayout"
Identifier "Simple Layout"
Screen "IBM ThinkPad"
Option "AIGLX" "true"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "Files"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
Load "glx"
Load "record"
Load "dri"
Load "xtrap"
Load "GLcore"
Load "dbe"
Load "extmod"
Load "freetype"
Load "type1"
EndSection

Section "Monitor"
Identifier "IBM TFT"
HorizSync 31.5 - 48.5
VertRefresh 50-70
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
#Option "PageFlip" # [<bool>]
Identifier "Intel 915GM"
Driver "i810"
VendorName "Intel Corporation"
BoardName "Mobile 915GM/GMS/910GML Express Graphics Controller"
BusID "PCI:0:2:0"
Option "XAANoOffscreenPixmaps" "true"
Option "DRI" "true"
EndSection

Section "Screen"
Identifier "IBM ThinkPad"
Device "Intel 915GM"
Monitor "IBM TFT"
DefaultDepth 24
Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


/etc/hal/fdi/policy is currenty empty, because I don't recogniced a difference with 10-keymap.fdi and without :wink:
_________________
Just you and me strogg!
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Wed May 14, 2008 9:47 pm    Post subject: Reply with quote

It looks like your fdi file is not applied to hal.
However, I don't see anything obviously wrong with it.
What's your hal/hal-info version ? Do you have any custom fdi files (not only input related) ?
Does your syslog show any errors ?
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Sat May 17, 2008 12:07 am    Post subject: Reply with quote

hoschi wrote:
Just for you :)

Quote:
10: udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'
linux.device_file = '/dev/input/event4' (string)
input.xkb.model = 'evdev' (string)
input.product = 'AT Translated Set 2 keyboard' (string)
info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'button' } (string list)
info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input' (string)
linux.subsystem = 'input' (string)
input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port' (string)
info.product = 'AT Translated Set 2 keyboard' (string)
linux.hotplug_type = 2 (0x2) (int)
input.xkb.rules = 'base' (string)
linux.sysfs_path = '/sys/devices/platform/i8042/serio0/input/input4/event4' (string)
info.addons.singleton = { 'hald-addon-input' } (string list)
input.x11_driver = 'evdev' (string)
info.category = 'input' (string)
input.xkb.layout = 'us' (string)
input.physical_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port' (string)
input.device = '/dev/input/event4' (string)
info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port' (string)
input.xkb.variant = '' (string)


Was what it you wanted to have working to begin with?
Is it only your uparrow that does not work?
Have you tried with a clean profile (i.e. newly created user) to see if the problem exists for him too?
That will tell you if the error really is your config for your server or your config for your user.
Back to top
View user's profile Send private message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Sun May 18, 2008 9:24 am    Post subject: Reply with quote

VoidMage wrote:
It looks like your fdi file is not applied to hal.
However, I don't see anything obviously wrong with it.
What's your hal/hal-info version ? Do you have any custom fdi files (not only input related) ?
Does your syslog show any errors ?


hal-0.5.10
hal-info-20071030

custom: no

syslog: also no, only the regular x11 warnings
_________________
Just you and me strogg!
Back to top
View user's profile Send private message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Sun May 18, 2008 9:26 am    Post subject: Reply with quote

Xake wrote:
hoschi wrote:
Just for you :)

Quote:
10: udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'
linux.device_file = '/dev/input/event4' (string)
input.xkb.model = 'evdev' (string)
input.product = 'AT Translated Set 2 keyboard' (string)
info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'button' } (string list)
info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input' (string)
linux.subsystem = 'input' (string)
input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port' (string)
info.product = 'AT Translated Set 2 keyboard' (string)
linux.hotplug_type = 2 (0x2) (int)
input.xkb.rules = 'base' (string)
linux.sysfs_path = '/sys/devices/platform/i8042/serio0/input/input4/event4' (string)
info.addons.singleton = { 'hald-addon-input' } (string list)
input.x11_driver = 'evdev' (string)
info.category = 'input' (string)
input.xkb.layout = 'us' (string)
input.physical_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port' (string)
input.device = '/dev/input/event4' (string)
info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port' (string)
input.xkb.variant = '' (string)


Was what it you wanted to have working to begin with?
Is it only your uparrow that does not work?
Have you tried with a clean profile (i.e. newly created user) to see if the problem exists for him too?
That will tell you if the error really is your config for your server or your config for your user.


Only uparrow and FN+F4 (Suspend-Button)

<edit />
You will all laugh, HAL is deprecated and will be replaced by the smaller and more sophisticated devicekit which will maybe implemented during Gnome-2.24 or 2.26 :lol:

http://www.pro-linux.de/news/2008/12692.html (german link)
_________________
Just you and me strogg!
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Tue May 20, 2008 6:10 pm    Post subject: Reply with quote

It looks like I have to correct myself.
With today's unkeyworded ebuild of x11-base/xorg-server-1.4.0.90-r4,
that tweak with input.keymap to input.keys is no longer needed.
Probably it's the 0059-xkb-when-copying-the-keymap-make-sure-the-structs patch that fixed it.
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Tue May 20, 2008 8:42 pm    Post subject: Reply with quote

hoschi wrote:
<edit />
You will all laugh, HAL is deprecated and will be replaced by the smaller and more sophisticated devicekit which will maybe implemented during Gnome-2.24 or 2.26 :lol:

http://www.pro-linux.de/news/2008/12692.html (german link)


Then what replace means in this context... It is possible it keeps the things that breaks things for most people, i.e. the configlayout.

Still I believe your problem has nothing to do with HAL as much as it has to do with the transit it implies from xf86-input-keyboard to xf86-input-evdev and if you are really unlucky it could be that evdev has problems realted to your keyboard layout. Have you recompiled xkeyboard-config and made sure that the layoutfiles really was unaltered replaced (I have had problems with broken xkb data when etc-updat/dispatch-conf has tuched them in any way).
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5855
Location: Removed by Neddy

PostPosted: Sat May 24, 2008 10:31 pm    Post subject: Reply with quote

ok problem still exists

This isn't a HAL, xorg or EVDEV issue... it is def a GNOME issue
Normal user everything is fine

I went and added a new user and well... the keyboard is doing the stupid UPKEY == printscreen BS!
Did the gconftool-2 ... and that didn't do anything

There is something missing in the understanding of this problem



--EDIT--

adding:
Option "XkbRules" "xorg"

to the keyboard layout worked for all new added users.

--EDIT2--
nop still no worky

new users are b0rked w.r.t. this
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sun May 25, 2008 7:28 pm    Post subject: Reply with quote

First of all, if this is a Gnome issue, then maybe is a setting from a different place than
the ones you are unsetting.
If you are using xorg with hal, then tweaks to xorg.conf are pointless, it's all in the fdi.
If gnome is overriding it, it's probably either:
- it has its settings written somewhere and you did not unset it
- it has some default settings that have to be overridden
And unless I'm wrong, input.xkb.rules has to be evdev.

One more thing, lately a-bit-broken-but-working ebuild for hal 0.5.11 has been added to the tree,
does it change anything ?
Back to top
View user's profile Send private message
tiffany
n00b
n00b


Joined: 04 May 2008
Posts: 6

PostPosted: Tue May 27, 2008 8:10 am    Post subject: Reply with quote

I've spent days and days of compiling since I have an old computer. But nothing works one time up arrow and the other delete key mapped wrong. When will new versions of HAL and EVDEV will be out?
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Tue May 27, 2008 1:06 pm    Post subject: Reply with quote

Have anyone me you ever tried downgrading to <evdev-1.2.0 and in your xorg.conf entered "evdev" as your driver for the keyboard and the mouse?
What is your experiences by doing that?
Back to top
View user's profile Send private message
tiffany
n00b
n00b


Joined: 04 May 2008
Posts: 6

PostPosted: Tue May 27, 2008 6:47 pm    Post subject: Reply with quote

Im from Greece and we have a completely different character set. Now I've disabled everything and up arrow and del key works fine. But GNOME keyboard doesn't change to greek as I've configured. Only US. Any suggestion? /etc/hal dir and xorg.conf screw everything.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Wed May 28, 2008 1:44 am    Post subject: Reply with quote

Hal doesn't screw up everything, your misconfiguration does.
First of all, anything <evdev-1.2.0 won't work in >=xorg-server-1.4,
as the changes were both in driver and in server.
Only thing important is to compose a correct fdi file and to put it in a place,
where hal reads it.
Once again, minimal is:
Code:

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
<!--
        <match key="info.capabilities" contains="input.keys">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>
-->
    <match key="info.capabilities" contains="input.keys">
      <!-- <merge key="input.xkb.model" type="string">pc104</merge> -->
      <merge key="input.xkb.rules" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">pl</merge>
      <append key="input.xkb.options" type="strlist">altwin:menu</append>
    </match>
  </device>
</deviceinfo>

That is, of course, unless you are using KDE/Gnome/anything alike, cause
it seems that desktop environments override hal settings for keyboard with values,
that are invalid for evdev, so there you need to set those properly, too.

Also, that input.keymap -> input.keys hack for info.callouts.add seems to be needed
for xorg-server below 1.4.0.90-r4.
Back to top
View user's profile Send private message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Wed May 28, 2008 9:04 pm    Post subject: Reply with quote

Xake wrote:
hoschi wrote:
<edit />
You will all laugh, HAL is deprecated and will be replaced by the smaller and more sophisticated devicekit which will maybe implemented during Gnome-2.24 or 2.26 :lol:

http://www.pro-linux.de/news/2008/12692.html (german link)


Then what replace means in this context... It is possible it keeps the things that breaks things for most people, i.e. the configlayout.

Still I believe your problem has nothing to do with HAL as much as it has to do with the transit it implies from xf86-input-keyboard to xf86-input-evdev and if you are really unlucky it could be that evdev has problems realted to your keyboard layout. Have you recompiled xkeyboard-config and made sure that the layoutfiles really was unaltered replaced (I have had problems with broken xkb data when etc-updat/dispatch-conf has tuched them in any way).


Here I am again:
The Gnome guys seem to save user-date in /etc/gconf, if I remove this folder the problem is fixed. But nearly everything what is stored their is missing (loading desktop fails, loading panel fails, loading g-p-m fails...), it seem that it is necessary to replace a special file in this folder.
I installed here a complete new system on a macbook (with new xorg, hal, dbus and without gnome!) = works great

HAL : Gnome Gconf* 1 : 0

*Windows-Registry to plague Unix users...
_________________
Just you and me strogg!
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Thu May 29, 2008 3:15 pm    Post subject: Reply with quote

hoschi wrote:
Here I am again:
The Gnome guys seem to save user-date in /etc/gconf, if I remove this folder the problem is fixed. But nearly everything what is stored their is missing (loading desktop fails, loading panel fails, loading g-p-m fails...), it seem that it is necessary to replace a special file in this folder.
I installed here a complete new system on a macbook (with new xorg, hal, dbus and without gnome!) = works great

HAL : Gnome Gconf* 1 : 0

*Windows-Registry to plague Unix users...


Good, that one I did not know.

And never compare gconf to the windows registry!
With gconf all you have to do is logout of X, kill everything gconf{,d} realted to your user and have fun with the textfiles.
With windows you have to - if you are lucky - reformat/reinstall and kill your cat.


When it comes to /etc/gconf it just sounds like you had an old file that had not been properly unmerged.
equery/qfile is your friend as there should be no files there not belonging to an ebuild.
Back to top
View user's profile Send private message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Sat May 31, 2008 10:46 pm    Post subject: Reply with quote

I now installed Gnome-2.22, stupid idea, on my plain macbook on a plain user and the problem again occurs. And only in Gnome-2.22, with a plain X11 the UPARROW-Key works. So, gconf does what and how? It seems to me, that X11 and HAL even without any fdi file work great, only Gnome seem make sth. wrong.

Maybe I should use the power of the mightyshell and put Gnome to a very dark place on my disk... /dev/null :mrgreen:

Fear the mighty shell!
The shell, owning u seless graphical envirornments since more 40 years, because a desktop is just pain.
_________________
Just you and me strogg!
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Mon Jun 02, 2008 5:52 pm    Post subject: Reply with quote

hoschi wrote:
I now installed Gnome-2.22, stupid idea, on my plain macbook on a plain user and the problem again occurs. And only in Gnome-2.22, with a plain X11 the UPARROW-Key works. So, gconf does what and how? It seems to me, that X11 and HAL even without any fdi file work great, only Gnome seem make sth. wrong.

Maybe I should use the power of the mightyshell and put Gnome to a very dark place on my disk... /dev/null :mrgreen:

Fear the mighty shell!
The shell, owning u seless graphical envirornments since more 40 years, because a desktop is just pain.


What you should do is take a look inside of /etc/gconf and look for files that is not placed there by any ebuild, and look inside of ~/.gconf/desktop/gnome/peripherals and maybe even remove that subdirectory when not running gconf* as your user.
Since gnome-desktop-settings takes care of this, and it relies on gconf then everything in GNOMe (even gdm) can break if there is something there from a pre-evdev time.
Back to top
View user's profile Send private message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Mon Jun 02, 2008 8:12 pm    Post subject: Reply with quote

It is a new macbook, new ;)
Okay: X11 with twm works without hal, X11 with twm and hal works, Gnome without hal works, but doesn't work with hal

Okay, back to zero: It is hal with gnome


1. Where I have to place my configuration files
/etc/hal/fdi/policy
/usr/share/hal/fdi/policy/10osvender
/usr/share/hal/fdi/policy20thirdparty
2. What name and number shoud have the configuration files
3. What is wrong with my default:
Quote:
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
<device>
<match key="info.capabilities" contains="input.keymap">
<append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
</match>

<match key="info.capabilities" contains="input.keys">
<merge key="input.xkb.rules" type="string">base</merge>

<!-- If we're using Linux, we use evdev by default (falling back to
keyboard otherwise). -->
<merge key="input.xkb.model" type="string">keyboard</merge>
<match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
string="Linux">
<merge key="input.xkb.model" type="string">evdev</merge>
</match>

<merge key="input.xkb.layout" type="string">us</merge>
<merge key="input.xkb.variant" type="string" />
</match>
</device>
</deviceinfo>


I have a us-keyboard in my macbook, should be correct.

Just for info:
peterle@macbook ~ $ hal-device | grep -i info.callouts.add
info.callouts.add = { 'hal-storage-cleanup-all-mountpoints' } (string list)


What to hell I need to do, that hal recognice my config?! Seem that it doesn't care about anything I change?
_________________
Just you and me strogg!
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Tue Jun 03, 2008 12:22 pm    Post subject: Reply with quote

Well, actually it works even in /etc/hal/fdi/policy.
The name/number matters only in the way that hal sorts files before applying,
and the latter override the earlier.

I just noticed it now:
<merge key="input.xkb.model" type="string">keyboard</merge>
is not a correct value, as AFAIK.
Please, try to simply use my file with only layout changed to us
and without input.xkb.options.
Back to top
View user's profile Send private message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Tue Jun 03, 2008 10:49 pm    Post subject: Reply with quote

I will give it a try.
_________________
Just you and me strogg!
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Tue Jun 10, 2008 7:32 pm    Post subject: Reply with quote

hoschi wrote:
It is a new macbook, new ;)
Okay: X11 with twm works without hal, X11 with twm and hal works, Gnome without hal works, but doesn't work with hal

Okay, back to zero: It is hal with gnome


So GNOME with hal breaks whatever even with a new (entirely clean) user profile?
Have you cleaned out /etc/gconf and ~/.gconf?
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5855
Location: Removed by Neddy

PostPosted: Tue Jun 10, 2008 9:51 pm    Post subject: Reply with quote

Well I think I sorted my problem and its def a GNOME problem

New user/new profile with all mentioned fixes (hal,fdi...) and still keyboard issues w.r.t. GNOME

well... System->Preferences->Keyboard preferences under the layout tab will have the layout specified in the fdi file listed BUT the radio button to set as default NOT set???

Not only that but you cannot set it.
I had to add a new keyboard layout, set the layout I wanted as default and then delete the tmp layout for it to sort it out!!!


I am sure there is a gconf option todo this but FFS that is annoying
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
Tariella
Guru
Guru


Joined: 10 Dec 2005
Posts: 377
Location: Europe/Austria

PostPosted: Wed Jun 11, 2008 9:14 am    Post subject: Reply with quote

I had this problem too and it is not a gnome problem since I'm not using gnome.

Hal is not "broken" but there is a policy that overrules the keyboard layout.
It ist placed somewhere in /usr/share/hal/fdi/policy/10osvendor and called something like "keymap" or "keyboard".
All you habe to do is to "overrule" this policy with your own by copying the policy to /etc/hal/fdi/policy and editing it. (have a look at Krampi's post somewhere at the beginning of this thread)

I had to read forums of other distros to find out about it. This should be better documented in gentoo imho. The trouble is that this problem comes without warning before upgrading hal. :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 7 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum