Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11-drivers/xf86-input-evdev-1.2.0 keyboard problem
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Bloodsurfer
Guru
Guru


Joined: 07 Dec 2005
Posts: 361
Location: Wolfstein, Germany (Rhineland-Palatinate)

PostPosted: Wed Apr 09, 2008 10:09 am    Post subject: Reply with quote

WTF?!? I just figured by chance, that my mouse's side buttons are working in Opera - just not in Firefox, where they were working before 8O How can that be?
_________________
SiberianSniper: my girlfriend's name ends with .c
Clete2: Uber geek! W00t! I'd rather have it end in .cpp... <insert name>.cpp
Dralnu: ...why not <name>.o? Then she's ready for linking...
SiberianSniper: or <name>.ko, so she's ready for insertion?
Back to top
View user's profile Send private message
aPoX
n00b
n00b


Joined: 28 Jan 2003
Posts: 10

PostPosted: Sat Apr 12, 2008 10:41 am    Post subject: Reply with quote

Xake, this is absolutely related to hal.

I don't have GNOME or KDE installed and I'm having the same keyboard issues. Infact, this is not only related to Gentoo, it's also occuring in Debian/Ubuntu/ArchLinux/Fedora.

Quote:

:: ATTENTION!
:: Since xorg-server version 1.4.0.90-7 hal support has
:: been enabled. By default keyboard layouts and variants
:: will now be overridden by hal. Please modfiy
::
:: /etc/hal/fdi/policy/11-xkeyboard.fdi
::
:: to suit your needs and restart X.


http://bbs.archlinux.org/viewtopic.php?pid=333663
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/173833
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Mon Apr 14, 2008 7:44 pm    Post subject: Reply with quote

[quote="aPoX"]Xake, this is absolutely related to hal.[quote]

Short answer:
The only way this is related to hal is that the place where the settings are stored (i.e. as a .fdi instead of in xorg.conf, just as your example said).

Long answer:
These BETAS of Xorg uses hal to find input devices and query hal for the settings. (Nearly) the only real change.
Where things break:
The BETAS of Xorg+hal uses evdev by default and evdev does not behave in the same way as your old xf86-input-{keyboard,mouse} settings.
Problem is:
Dumb applications and DEs thinks it is funny to store these settings themselves too. But when there is a mismatch between their settings and the underlying (i.e. Xorgs) settings things may break.
But this you would all have known if you had tried to configure your system to only use evdev (i.e. ditch xf86-input-{keyboard,mouse}) long way before the hal+Xorg-loveaffair even was in git.

That said:
Some things may break, but it is more like the newest version of evdev does not like Logitech keyboard, but there are patches for that.

That said no2:
I use vmware and have still to see any problem with that and a clean userprofile. Not then. Not now.
But then I am using vmware-console against a vmware-server and that may be the reason.
Back to top
View user's profile Send private message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Tue Apr 29, 2008 10:52 pm    Post subject: Reply with quote

*removed everything from xorg.conf

Quote:
Section "ServerLayout"
Identifier "Simple Layout"
Screen "IBM ThinkPad"
Option "AIGLX" "true"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "Files"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
Load "glx"
Load "record"
Load "dri"
Load "xtrap"
Load "GLcore"
Load "dbe"
Load "extmod"
Load "freetype"
Load "type1"
EndSection

Section "Monitor"
Identifier "IBM TFT"
HorizSync 31.5 - 48.5
VertRefresh 50-70
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
#Option "PageFlip" # [<bool>]
Identifier "Intel 915GM"
Driver "i810"
VendorName "Intel Corporation"
BoardName "Mobile 915GM/GMS/910GML Express Graphics Controller"
BusID "PCI:0:2:0"
Option "XAANoOffscreenPixmaps" "true"
Option "DRI" "true"
EndSection

Section "Screen"
Identifier "IBM ThinkPad"
Device "Intel 915GM"
Monitor "IBM TFT"
DefaultDepth 24
Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


*copied 10-keymap.fdi to /etc/hal/fdi/policy with no changes (i have a thinkpad with us-layout)

*reload hald, restart x11, set evdev as keyboard in gnome-2.22



>> arrow-key "UP" still don't work, working in gnome-terminal or scrolling up is really cruel because it opens the screenshot-tool
_________________
Just you and me strogg!
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Wed May 07, 2008 5:38 pm    Post subject: Reply with quote

hoschi wrote:
*copied 10-keymap.fdi to /etc/hal/fdi/policy with no changes (i have a thinkpad with us-layout)

*reload hald, restart x11, set evdev as keyboard in gnome-2.22



>> arrow-key "UP" still don't work, working in gnome-terminal or scrolling up is really cruel because it opens the screenshot-tool


Try unsetting EVERYTHING in your /desktop/gnome/peripherals/keyboard with the help of gconf...
Back to top
View user's profile Send private message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Wed May 07, 2008 9:21 pm    Post subject: Reply with quote

i removed the howl directory - no change

Quote:
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
<device>
<match key="info.capabilities" contains="input.keymap">
<append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
</match>

<match key="info.capabilities" contains="input.keys">
<merge key="input.xkb.rules" type="string">base</merge>

<!-- If we're using Linux, we use evdev by default (falling back to
keyboard otherwise). -->
<merge key="input.xkb.model" type="string">keyboard</merge>
<match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
string="Linux">
<merge key="input.xkb.model" type="string">evdev</merge>
</match>

<merge key="input.xkb.layout" type="string">us</merge>
<merge key="input.xkb.variant" type="string" />
</match>
</device>
</deviceinfo>

_________________
Just you and me strogg!
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Wed May 07, 2008 10:59 pm    Post subject: Reply with quote

Change:
<match key="info.capabilities" contains="input.keymap">
to:
<match key="info.capabilities" contains="input.keys">

cause that's the correct value for hal 0.5.10
Back to top
View user's profile Send private message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Thu May 08, 2008 11:18 pm    Post subject: Reply with quote

Quote:
peterle@thinkpad ~ $ cat /etc/hal/fdi/policy/10-keymap.fdi
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
<device>
<match key="info.capabilities" contains="input.keys">
<append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
</match>

<match key="info.capabilities" contains="input.keys">
<merge key="input.xkb.rules" type="string">base</merge>

<!-- If we're using Linux, we use evdev by default (falling back to
keyboard otherwise). -->
<merge key="input.xkb.model" type="string">keyboard</merge>
<match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
string="Linux">
<merge key="input.xkb.model" type="string">evdev</merge>
</match>

<merge key="input.xkb.layout" type="string">us</merge>
<merge key="input.xkb.variant" type="string" />
</match>
</device>
</deviceinfo>


Still no effect :(
_________________
Just you and me strogg!
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Fri May 09, 2008 7:36 am    Post subject: Reply with quote

hoschi wrote:
Quote:
peterle@thinkpad ~ $ cat /etc/hal/fdi/policy/10-keymap.fdi
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
<device>
<match key="info.capabilities" contains="input.keys">
<append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
</match>

<match key="info.capabilities" contains="input.keys">
<merge key="input.xkb.rules" type="string">base</merge>

<!-- If we're using Linux, we use evdev by default (falling back to
keyboard otherwise). -->
<merge key="input.xkb.model" type="string">keyboard</merge>
<match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
string="Linux">
<merge key="input.xkb.model" type="string">evdev</merge>
</match>

<merge key="input.xkb.layout" type="string">us</merge>
<merge key="input.xkb.variant" type="string" />
</match>
</device>
</deviceinfo>


Still no effect :(


try to run as your user: 'gconftool-2 --recursive-unset /desktop/gnome/peripherals', if nothing changes exit gnome/X11, kill all processes belonging to your user and GNOME (like gconfd-2 and so on) and log in again.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Fri May 09, 2008 12:11 pm    Post subject: Reply with quote

Do something very simple:
run:
hal-find-by-capability --capability input.keys
for every listed device name run:
hal-device <device name>
Post output here.
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5858
Location: Removed by Neddy

PostPosted: Fri May 09, 2008 8:47 pm    Post subject: Reply with quote

I'm also having the UPARROW mapping to printscreen (gnome-2.22 here)

I have done the: cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/10-keymap.fdi (and edit for my keymap)
as well as gconftool-2 --recursive-unset /desktop/gnome/peripherals

With no luck (UPARROW still does printscreen)

Code:

FluidMotion j # emerge hal-info hal xf86-input-evdev xorg-server xinit -p
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-apps/xinit-1.0.8-r3 
[ebuild   R   ] sys-apps/hal-0.5.10 
[ebuild   R   ] app-misc/hal-info-20071030 
[ebuild   R   ] x11-base/xorg-server-1.4.0.90-r3 
[ebuild   R   ] x11-drivers/xf86-input-evdev-1.2.0


HOWEVER... when I am in gnome and the UPARROW is mapped wrong IF I do a CTRL-ALT-Backspace (to restart X) it then works???
BUT If I do a /etc/init/xdm restart from a virtual console the UPARROW still does it sillness?

I am sure if I downgraded HAL it would work BUT ppl have evdev and hal-0.5.10 working so it is possible
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5858
Location: Removed by Neddy

PostPosted: Sat May 10, 2008 11:39 am    Post subject: Reply with quote

OK interestingly IF I set gdm to be manual-login then my keyboard works as expectedly
BUT when it is set to autologin then the whole UPARROW mapped to printscreen happens

those that are having the issue do you have you login manager set to auto-login?
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sat May 10, 2008 4:09 pm    Post subject: Reply with quote

I think my question would be valid for you, too (as would be input.keys problem).
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5858
Location: Removed by Neddy

PostPosted: Sat May 10, 2008 5:45 pm    Post subject: Reply with quote

Code:

jrb@FluidMotion ~ $ hal-find-by-capability --capability input.keys
/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input
/org/freedesktop/Hal/devices/usb_device_1532_101_noserial_if1_logicaldev_input


jrb@FluidMotion ~ $ hal-device /org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input
udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'
  linux.device_file = '/dev/input/event2'  (string)
  input.xkb.model = 'evdev'  (string)
  input.product = 'AT Translated Set 2 keyboard'  (string)
  info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'button' } (string list)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'  (string)
  linux.subsystem = 'input'  (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  info.product = 'AT Translated Set 2 keyboard'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  input.xkb.rules = 'base'  (string)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio0/input/input2/event2'  (string)
  info.addons.singleton = { 'hald-addon-input' } (string list)
  input.x11_driver = 'evdev'  (string)
  info.category = 'input'  (string)
  input.xkb.layout = 'gb'  (string)
  input.physical_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  input.device = '/dev/input/event2'  (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  input.xkb.variant = ''  (string)


jrb@FluidMotion ~ $ hal-device /org/freedesktop/Hal/devices/usb_device_1532_101_noserial_if1_logicaldev_input
udi = '/org/freedesktop/Hal/devices/usb_device_1532_101_noserial_if1_logicaldev_input'
  linux.device_file = '/dev/input/event4'  (string)
  input.xkb.model = 'evdev'  (string)
  input.product = 'Razer Razer Copperhead Laser Mouse'  (string)
  info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'button' } (string list)
  info.udi = '/org/freedesktop/Hal/devices/usb_device_1532_101_noserial_if1_logicaldev_input'  (string)
  linux.subsystem = 'input'  (string)
  input.originating_device = '/org/freedesktop/Hal/devices/usb_device_1532_101_noserial_if1'  (string)
  info.product = 'Razer Razer Copperhead Laser Mouse'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  input.xkb.rules = 'base'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1d.0/usb1/1-2/1-2:1.1/input/input4/event4'  (string)
  info.addons.singleton = { 'hald-addon-input' } (string list)
  input.x11_driver = 'evdev'  (string)
  info.category = 'input'  (string)
  input.xkb.layout = 'gb'  (string)
  input.physical_device = '/org/freedesktop/Hal/devices/usb_device_1532_101_noserial_if1'  (string)
  input.device = '/dev/input/event4'  (string)
  info.parent = '/org/freedesktop/Hal/devices/usb_device_1532_101_noserial_if1'  (string)
  input.xkb.variant = ''  (string)

_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sat May 10, 2008 7:37 pm    Post subject: Reply with quote

Important questions:
your hal/hal-info/xf86-input-evdev version ?
Did you do something strange with your hal, cause I don't think it should add kyboard properties to the keyboard ?
And it's not adding info.callouts.add, so you need that
<match key="info.capabilities" contains="input.keys">
line in the correct place.

Also I think correct place would be /usr/share/hal/fdi/policy/20thirdparty/ (don't know if that's correct, but it works for me, though if
/etc/hal actually work, is OK after all).
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5858
Location: Removed by Neddy

PostPosted: Sat May 10, 2008 8:02 pm    Post subject: Reply with quote

VoidMage wrote:
Important questions:
your hal/hal-info/xf86-input-evdev version ?

Code:

sys-apps/hal-0.5.10 
app-misc/hal-info-20071030 
x11-drivers/xf86-input-evdev-1.2.0


VoidMage wrote:

Did you do something strange with your hal, cause I don't think it should add kyboard properties to the keyboard ?

Nop, the only thing I did w.r.t. HAL was to cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy

VoidMage wrote:

And it's not adding info.callouts.add, so you need that
<match key="info.capabilities" contains="input.keys">
line in the correct place.


Code:

jrb@FluidMotion ~ $ cat /etc/hal/fdi/policy/10-keymap.fdi
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>

      <merge key="input.xkb.layout" type="string">gb</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>

seems to be
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sat May 10, 2008 9:40 pm    Post subject: Reply with quote

First of all, I'll repeat:
CHANGE
<match key="info.capabilities" contains="input.keymap">
TO
<match key="info.capabilities" contains="input.keys">
RESTART HAL
if afterwards it's still not applied, put the file in /usr/share/hal/fdi/policy/20thirdparty/
RESTART HAL
You'll know it worked when
info.callouts.add = { 'hal-setup-keymap' } (string list)
appears in the hal-device output

And what other files you have in /etc/hal/ ?
With app-misc/hal-info-20071030 I don't have any fdi files there (though perhaps that is the correct place after all)
but my mouse looks like this:
Code:

udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input'
  linux.device_file = '/dev/input/event4'  (string)
  input.product = 'ImExPS/2 Generic Explorer Mouse'  (string)
  info.capabilities = { 'input', 'input.mouse' } (string list)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input'  (string)
  linux.subsystem = 'input'  (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port'  (string)
  info.product = 'ImExPS/2 Generic Explorer Mouse'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio1/input/input4/event4'  (string)
  input.x11_driver = 'evdev'  (string)
  info.category = 'input'  (string)
  input.physical_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port'  (string)
  input.device = '/dev/input/event4'  (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port'  (string)


Just for reference, my keyboard:
Code:

udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'
  linux.device_file = '/dev/input/event2'  (string)
  input.xkb.model = 'evdev'  (string)
  input.product = 'AT Translated Set 2 keyboard'  (string)
  info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'button' } (string list)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'  (string)
  linux.subsystem = 'input'  (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  info.product = 'AT Translated Set 2 keyboard'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  input.xkb.rules = 'evdev'  (string)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio0/input/input2/event2'  (string)
  info.addons.singleton = { 'hald-addon-input' } (string list)
  input.x11_driver = 'evdev'  (string)
  info.category = 'input'  (string)
  input.xkb.layout = 'pl'  (string)
  input.physical_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  input.device = '/dev/input/event2'  (string)
  info.callouts.add = { 'hal-setup-keymap' } (string list)
  input.xkb.options = { 'altwin:menu' } (string list)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  input.xkb.variant = ''  (string)


Though (if that matters), I run hal as a system service.
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5858
Location: Removed by Neddy

PostPosted: Sat May 10, 2008 10:49 pm    Post subject: Reply with quote

my mistake I didn't notice all the info.capabilities

changed that to input.keys still didn't work (with a /etc/init.d/xdm stop && /etc/init.d/hald restart && /etc/init.d/xdm start inbetween)

copied the file to: /usr/share/hal/fdi/policy/20thirdparty/ and still didn't work (with a /etc/init.d/xdm stop && /etc/init.d/hald restart && /etc/init.d/xdm start inbetween)

did a gconftool-2 --recursive-unset /desktop/gnome/peripherals and then a reboot and still doesn't work

I'm going back to the kbd driver, hal is just to broken.
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sun May 11, 2008 10:02 am    Post subject: Reply with quote

Well, my fdi file looks like this
Code:

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keys">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>
    <match key="info.capabilities" contains="input.keys">
      <!-- <merge key="input.xkb.model" type="string">pc104</merge> -->
      <merge key="input.xkb.layout" type="string">pl</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name" string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>
      <merge key="input.xkb.rules" type="string">evdev</merge>
      <append key="input.xkb.options" type="strlist">altwin:menu</append>
    </match>
  </device>
</deviceinfo>

And it just works. I don't really have any hal knowledge, it's something I took from this forum and bugzilla.
Though I'm not using Gnome.
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5858
Location: Removed by Neddy

PostPosted: Sun May 11, 2008 10:46 am    Post subject: Reply with quote

Well got it working (tnx for help)

Seems it was definitely a GNOME issue
even when I set my system back to using kbd driver GNOME insisted it was going to use evdev (and as such no mouse or keyboard).
moving both the fdi files out of the hal policy folder/s and restarting X got the same up-arrow BUT this time gnome-keyboard insisted my layout was USA

moving those files back and re-starting X the upkey issue was fixed BUT they keymap was USA still. manually setting it to UK from the GNOME-gui sorted that
strange that the gconftool-2 --recursive-unset /desktop/gnome/peripherals didn't reset that



its not good that there is basically 3 places that
1) layout
2) keyboard driver
is set (xorg.conf,hal fdi, gnome setting) AND the order is key. I thought that evdev is/was suppose to simplify things
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sun May 11, 2008 3:08 pm    Post subject: Reply with quote

You're looking at this the wrong way.
Originally you setup the keyboard in xorg.conf (or whatever this file was called before xorg)
Gnome/KDE keyb. controls were overriding those settings.
Now xorg is trying to move to hal, but those desktop controls still try to override it.
That may sometimes lead to conflicts.
Back to top
View user's profile Send private message
rodrigoaraujorge
n00b
n00b


Joined: 12 May 2008
Posts: 2

PostPosted: Mon May 12, 2008 3:12 am    Post subject: Reply with quote

OK guys. We already know how to solve the layout problem of keyboards. However, I'm also having FN key problems since I upgraded HAL.
There is a topic with 6 posts about that but it is dead: https://forums.gentoo.org/viewtopic-t-661319-highlight-.html?sid=af8b729fa8e29832f615acc866fdaeee

I posting here because FN is a keyboard problem and it is related to HAL. Does anyone know what can I replace, unset or do to solve it ? I do not want to downgrade my HAL version.

Thank you all for this big topic (spent almost 30 minutes reading it entirely). Cheers.
Back to top
View user's profile Send private message
wizard69
Apprentice
Apprentice


Joined: 22 Sep 2003
Posts: 178
Location: Berlin

PostPosted: Mon May 12, 2008 7:49 am    Post subject: Reply with quote

if you want to continue using the kbd driver and a xorg config file add this to the section server layout in your xorg.conf


Code:
 Option         "AutoAddDevices" "false"



this will stop hal from auto configuring your mouse and keyboard and xorg will drop back to the old behaviour using xorg.conf.
_________________
Gentoo Blog
Back to top
View user's profile Send private message
hoschi
Advocate
Advocate


Joined: 19 Jul 2003
Posts: 2517
Location: Ulm, Germany, Europe

PostPosted: Mon May 12, 2008 8:27 pm    Post subject: Reply with quote

Naib wrote:
OK interestingly IF I set gdm to be manual-login then my keyboard works as expectedly
BUT when it is set to autologin then the whole UPARROW mapped to printscreen happens

those that are having the issue do you have you login manager set to auto-login?


I use "startx" with the XSESSION-VAR.

<edit />
I have tried out every advice from this thread, an no one works. Even the adivce from the post above doesn't work, because this will switch evdev completely off (no mouse support).

Sorry. But the HAL and XORG-Developers build a fucking crap of software...
_________________
Just you and me strogg!
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Tue May 13, 2008 10:55 am    Post subject: Reply with quote

hoschi wrote:

I have tried out every advice from this thread, an no one works. Even the adivce from the post above doesn't work, because this will switch evdev completely off (no mouse support).

Wrong, you just have to configure your mouse to use evdev in you xorg.conf. That worked for me long before HAL in xorg was even mentioned.
That worked for me still last time i checked (before I found out how to configure HAL).
hoschi wrote:

Sorry. But the HAL and XORG-Developers build a fucking crap of software...


Sad to hear you say so. I think this is just good news all of it. X has been standing still from time to time and I think this is a breath of life and a good sing that it acctually starts to happend things.

That said I have had very little problems with this thing. But then again I always when I found myself with problems in Gentoo asks myself if it maybe is ME that is the fault, and if I am handling things the wrong way. Most of the time I find it is. And I even know people who have switched distros just becouse they found out they were not the person to configure their own system from ground up but to have others do it (fedor, ubuntu, you name it).
Blaming others work does not help very often. If you can't at least file a good bugreport and are still giving up, then you know you have not done your homework with Gentoo and maybe should consider an alternative.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 6 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum