Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[UDEV] Detection de carte SD dans un lecteur multicarte
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
ycaironi
n00b
n00b


Joined: 29 Mar 2006
Posts: 48

PostPosted: Sat Jan 05, 2008 12:10 pm    Post subject: [UDEV] Detection de carte SD dans un lecteur multicarte Reply with quote

Bonjour gentooiste et bonne année 2008.

Voici mon soucis. Je viens d'acheter un appareil photo avec carte SD
Lorsque je passe la carte dans mon lecteur multicarte ( sans n'avoir rien fait sur le lecteur avant ), rien ne se passe.
- udevmonitor reste vierge et dmesg ne retourne rien.

Si auparavant je detecte un clé USB ( que je laisse ensuite en palce ou non ), et que je remet la carte SD, alors en environ 20 secondes, (enorme non?), elle est détetée et montée.
Par la suite tant que je n'étenit pas le PC, la carte est montée en 20secondes.

J'ai remarqué sur les forums que les problèmes de rafraichissement auto avaient cours dans le passé. Est-ce toujours le cas?
Que peut il se passé exactement dans mon cas?

Merci du support, et rebonne année....

Yann
_________________
Yann
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Sat Jan 05, 2008 1:42 pm    Post subject: Reply with quote

ton lecteur multicarte, c'est un truc intégré ou un truc USB ?
Back to top
View user's profile Send private message
SuperDindon
Tux's lil' helper
Tux's lil' helper


Joined: 01 Sep 2005
Posts: 125

PostPosted: Sat Jan 05, 2008 3:04 pm    Post subject: Reply with quote

Quote:
Device Drivers
----SCSI device support
--------[Y] Probe all LUNs on each SCSI device

Activée dans ton noyau ?
Back to top
View user's profile Send private message
ycaironi
n00b
n00b


Joined: 29 Mar 2006
Posts: 48

PostPosted: Sat Jan 05, 2008 4:34 pm    Post subject: Reply with quote

Oui le probe all LUNs est activé.

Le lecteur multicarte est un USB interne ( ce genre de lecteur que tu achete que tu monte dans la baie 3p1/4 et que tu brnache directement sur les pico USB de la carte mère ).
_________________
Yann
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Tue Jan 08, 2008 12:28 pm    Post subject: Reply with quote

hello


j'ai le même problème que toi : un lecteur de carte branché sur l'usb en interne (donc tjrs connecté)
il lui faut un temps monstrueux pour enfin détecter la carte mémoire que je lui ai inséré (SD, MMC, etc)


J'ai essayé de forcer via MAKEDEV, mais aucun changement.... je n'ai pas encore trouvé ce qui coince...


je précise que le noyau détecte mon lecteur de carte au boot, crée les périphériques /dev/sd* (sdb,sdc,sdd,sde dans mon cas) et quand j'insère une carte, il me crée (tant bien que mal) un sdx1


je ne sais pas si j'ai été très clair, mais si quelqu'un a une solution je suis preneur !
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Fri Jan 11, 2008 11:37 am    Post subject: Reply with quote

hello

tu as trouvé une solution à ton problême ? de mon côté je reviens bredouille...
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Mon Jan 14, 2008 8:39 am    Post subject: Reply with quote

Salut, j'avais réussi a faire fonctionner mon lecteur de cartes SD/MMC Secure Digital, en mettant l'option PCI Express hotplug en dur dans le kernel... et le support Secure Digital et mmc_core en modules... voili voilou si ça peut aider
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Mon Jan 14, 2008 8:42 am    Post subject: Reply with quote

arf je vois pas le rapport avec le pci express hotplug, m'enfin, qui ne tente rien n'a rien !

si j'ai un peu de temps, je teste ça dès ce soir !

merci pour la réponse !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum