Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
syslog-ng won't stop MARK-ing [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2060
Location: Near Toronto

PostPosted: Thu Jan 03, 2008 12:51 am    Post subject: syslog-ng won't stop MARK-ing [SOLVED] Reply with quote

Hi all. Although I modified the /etc/syslog-ng/syslog-ng.conf
file, putting in this line:

Code:
        stats(0);


I still get the unnecessary "I'm not dead yet" messages
(viz. Jan 2 22:11:48 gothmog -- MARK --)
in /var/log/messages.

How do I stop this please?

There is something really wrong here, because the original
stats line is like this:

Code:
        # The default action of syslog-ng 1.6.0 is to log a STATS line
        # to the file every 10 minutes.  That's pretty ugly after a while.
        # Change it to every 12 hours so you get a nice daily update of
        # how many messages syslog-ng missed (0).
       stats(43200);


But I was and am getting MARK messages every 20 minutes (exactly),
rather than the specified once every 12 *hours* OR the supposed
default of every 10 minutes.

What is going on? It keeps waking up my drive ...
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)


Last edited by albright on Thu Jan 03, 2008 4:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
shadowknight
Tux's lil' helper
Tux's lil' helper


Joined: 03 Aug 2002
Posts: 142

PostPosted: Thu Jan 03, 2008 1:03 am    Post subject: Reply with quote

I don't know about your specific problem, but I had a similar problem with syslog bombarding /var/log/messages with random queries from my usb dvd drive. I didn't catch it until I got an error message saying that my partition was out of space (10 GB "O.o") I cleared the relevant files and killed syslog and switch to metalog and haven't had any problems since. Don't know if that will help your situation but a simple fix that worked for me.
Back to top
View user's profile Send private message
think4urs11
Administrator
Administrator


Joined: 25 Jun 2003
Posts: 6659
Location: above the cloud

PostPosted: Thu Jan 03, 2008 11:11 am    Post subject: Re: syslog-ng won't stop MARK-ing Reply with quote

albright wrote:
But I was and am getting MARK messages every 20 minutes (exactly)

mark_freq(0);
adding this to options should stop it
_________________
Nothing is secure / Security is always a trade-off with usability / Do not assume anything / Trust no-one, nothing / Paranoia is your friend / Think for yourself
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2060
Location: Near Toronto

PostPosted: Thu Jan 03, 2008 4:17 pm    Post subject: Reply with quote

thanks Think4UrS11 - that did it!
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7818

PostPosted: Mon Mar 03, 2008 8:57 am    Post subject: Reply with quote

Moved from Other Things Gentoo to Duplicate Threads, refer to topic "Strange `--MARK--`".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum