Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[compilation]poppler ne compile pas (résolus)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
daemon666
n00b
n00b


Joined: 01 Jan 2008
Posts: 5

PostPosted: Tue Jan 01, 2008 11:04 am    Post subject: [compilation]poppler ne compile pas (résolus) Reply with quote

Bonjour,
Je suis nouveau sous Gentoo, jel 'ai installée depuis hier, j'adore, ca change beaucoup d'Ubuntu, ca me convient parfaitement.
J'ai seulement un petit problème lors de la compilation de KDE (kdebase-startkde), un paquet nommé poppler (en 0.6.1-r1) ne compile pas et stop tout, avec un message du genre:
ERROR: app-text/poppler-0.6.1-r1 failled
Call stack:
ebuild.sh, line 1701: Called dyn_compile
ebuild.sh, line 1039: Called qa_call 'src_compile'
ebuild.sh, line 44: Called src_compile
poppler-0.6.1-r1.ebuild, line 43: Called die
The specific snippet of code:
emake || die "compilation failed"
The die message:
compilation failed

If you need support ...

Enfin voilou, j'ai essayé de compiler le paquet a part, rien ne change.
Que faire ? Car la je suis bien embété ^^

Merci.


Last edited by daemon666 on Tue Jan 01, 2008 11:52 am; edited 2 times in total
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Tue Jan 01, 2008 11:27 am    Post subject: Reply with quote

Salut et bienvenue !
Peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)

Et pour ton erreur, il faut que tu nous montres la vraie erreur qu'est située quelques lignes plus haut ;) (et pense à utiliser les balises [code] et [quote])
Back to top
View user's profile Send private message
daemon666
n00b
n00b


Joined: 01 Jan 2008
Posts: 5

PostPosted: Tue Jan 01, 2008 11:41 am    Post subject: Reply with quote

Oups désolé ^^
Alors etant sur un autre pc, je vais recopier un bout du contenu du log.
La premiere erreur apercue est 10 lignes au dessus de ce que je vous ai montré:
Code:

/usr/lib/gcc/i486-pc-linux-gnu/4.1.2/../../../../i486-pc-linux-gnu/bin/ld: warning: libexpat.so.0, needed by /usr/lib/libfontconfig.so, not found (try using -rpath or -rpath-link)
/usr/lib/libfontconfig.so: undefined reference to 'XML_ParserCreate'
/usr/lib/libfontconfig.so: undefined reference to 'XML_GetErrorCode'
/usr/lib/libfontconfig.so: undefined reference to 'XML_SetUserData'
/usr/lib/libfontconfig.so: undefined reference to 'XML_SetDoctypeDeclHandler'
/usr/lib/libfontconfig.so: undefined reference to 'XML_ParseBuffer'
/usr/lib/libfontconfig.so: undefined reference to 'XML_GetCurrentLineNumber'
/usr/lib/libfontconfig.so: undefined reference to 'XML_ErrorString'
/usr/lib/libfontconfig.so: undefined reference to 'XML_ParserFree'
/usr/lib/libfontconfig.so: undefined reference to 'XML_SetElementHandler'
/usr/lib/libfontconfig.so: undefined reference to 'XML_GetBuffer'
/usr/lib/libfontconfig.so: undefined reference to 'XML_SetCharacterDataHandler'
collect2: ld returned 1 exit status
make[2]: *** [pdffonts] Error 1
make[2]: *** Waiting for unfinished jobs...
make[2]: Leaving directory '/var/tmp/portage/app-text/poppler-0.6.1-r1/work/poppler-0.6.1/utils
make[1]: *** [all-recursive] Error 1
make[1]:  Leaving directory '/var/tmp/portage/app-text/poppler-0.6.1-r1/work/poppler-0.6.1/utils
make: *** [all] Error 2

Voilou, d'après ce que j'ai compris il me manquerais la librairie libexpat non ?
Merci.
Back to top
View user's profile Send private message
daemon666
n00b
n00b


Joined: 01 Jan 2008
Posts: 5

PostPosted: Tue Jan 01, 2008 11:51 am    Post subject: Reply with quote

Bon ba voilou, problème reglé ^^
J'ai cherché un peu sur la librairie expat, j'ai vu que cela posait problème a cause d'un chagement de version.
J'ai tout d'abord emergé expat, et fait un lien symbolique dans /usr/lib tel quel: ln -s libexpat.so.1 libexpat.so.0.
Bon ba c'est résolu ^^
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Tue Jan 01, 2008 11:56 am    Post subject: Reply with quote

Heu, surtout pense ensuite à faire un revdep-rebuild --library libexpat.so.0 (revdep-rebuild est dans app-portage/gentoolkit), et ensuite vire le lien libexpat.so.0, pour avoir un système propre ;)
Back to top
View user's profile Send private message
daemon666
n00b
n00b


Joined: 01 Jan 2008
Posts: 5

PostPosted: Tue Jan 01, 2008 12:13 pm    Post subject: Reply with quote

Peux-tu m'expliquer le but de cette commande stp ?
Car si jamais un autre paquet a besoin de cette librairie ?
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Tue Jan 01, 2008 12:33 pm    Post subject: Reply with quote

Ça recompilera tous tes progs actuellement linkés sur la lib libexpat.so.0 pour la nouvelle lib libexpat.so.1, ce qui donc répare tes binaires et évite les cassages d'ABI (ce que tu risques si tu gardes ce symlink foireux).
Back to top
View user's profile Send private message
daemon666
n00b
n00b


Joined: 01 Jan 2008
Posts: 5

PostPosted: Tue Jan 01, 2008 1:54 pm    Post subject: Reply with quote

Oki merci ;)
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Wed Jan 02, 2008 1:35 pm    Post subject: Reply with quote

Quelle entrée en force .. :lol:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum