Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[pam] je n'arrive pas a l'update car je ne comprends pas....
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
zoltix
Apprentice
Apprentice


Joined: 22 Mar 2004
Posts: 249
Location: Brusssels

PostPosted: Sun Dec 30, 2007 11:20 pm    Post subject: [pam] je n'arrive pas a l'update car je ne comprends pas.... Reply with quote

Bonsoir,
Je n'arrive pas a faire l'update de spam car je ne comprends pas bien l'anglais. Si vous pouviez m'aider. Le lien c'est http://www.gentoo.org/proj/en/base/pam/upgrade-0.99.xml
J'ai esseyé de faire
Code:
 emerge  pam
et j'ai eu un message d'erreur
Code:

>>> Merging sys-libs/pam-0.99.9.0 to /
 *
 * Your current setup is using the pam_stack module.
 * This module is deprecated and no longer supported, and since version
 * 0.99 is no longer installed, nor provided by any other package.
 * The package will be built (to allow binary package builds), but will
 * not be installed.
 * Please replace pam_stack usage with proper include directive usage,
 * following the PAM Upgrade guide at the following URL
 *   http://www.gentoo.org/proj/en/base/pam/upgrade-0.99.xml
 *
 *
 * ERROR: sys-libs/pam-0.99.9.0 failed.
 * Call stack:
 *             ebuild.sh, line 1717:  Called dyn_preinst
 *             ebuild.sh, line 1156:  Called pkg_preinst
 *   pam-0.99.9.0.ebuild, line  165:  Called die
 * The specific snippet of code:
 *      check_old_modules || die "deprecated PAM modules still used"
 *  The die message:
 *   deprecated PAM modules still used
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-libs/pam-0.99.9.0/temp/build.log'.
 *
!!! FAILED preinst: 1

 * Messages for package sys-libs/pam-0.99.9.0:

 *
 * Your current setup is using the pam_stack module.
 * This module is deprecated and no longer supported, and since version
 * 0.99 is no longer installed, nor provided by any other package.
 * The package will be built (to allow binary package builds), but will
 * not be installed.
 * Please replace pam_stack usage with proper include directive usage,
 * following the PAM Upgrade guide at the following URL
 *   http://www.gentoo.org/proj/en/base/pam/upgrade-0.99.xml
 *
 *
 * Your current setup is using the pam_stack module.
 * This module is deprecated and no longer supported, and since version
 * 0.99 is no longer installed, nor provided by any other package.
 * The package will be built (to allow binary package builds), but will
 * not be installed.
 * Please replace pam_stack usage with proper include directive usage,
 * following the PAM Upgrade guide at the following URL
 *   http://www.gentoo.org/proj/en/base/pam/upgrade-0.99.xml
 *
 *
 * ERROR: sys-libs/pam-0.99.9.0 failed.
 * Call stack:
 *             ebuild.sh, line 1717:  Called dyn_preinst
 *             ebuild.sh, line 1156:  Called pkg_preinst
 *   pam-0.99.9.0.ebuild, line  165:  Called die
 * The specific snippet of code:
 *      check_old_modules || die "deprecated PAM modules still used"
 *  The die message:
 *   deprecated PAM modules still used
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-libs/pam-0.99.9.0/temp/build.log'.
 *


Si j'ai compris j'ai fait


Code:
qfile -o /etc/pam.d/*


et apparemment je n'en ai pas de fichier et pui je ne comprends pas trop ce que le doc me dit de faire....

Merci d'avance de votre aide...
A+
Back to top
View user's profile Send private message
SlashRhumSlashNeisson
Apprentice
Apprentice


Joined: 30 Dec 2006
Posts: 200
Location: Lille

PostPosted: Mon Dec 31, 2007 5:02 am    Post subject: Reply with quote

Salut,

Il faut remplacer "pam_stack.so" par "system-auth" dans chaque fichier de /etc/pam.d/

Donc dès que tu trouves une ligne avec "pam_stack.so", tu la remplaces par "include system-auth"

Exemple:

Code:
auth    required     pam_stack.so    service=system-auth


devient:

Code:
auth    include      system-auth


De plus si tu as une ligne avec
Code:
pam_nologin.so
, réordonnes là après
Code:
auth    include      system-auth


Exemple:

Code:
auth    required     pam_stack.so    service=system-auth
auth    required     pam_nologin.so


devient:

Code:
auth    required     pam_nologin.so
auth    include      system-auth


Ensuite
Code:
emerge pam


That's all :wink:
_________________
Gentoo only
Back to top
View user's profile Send private message
zoltix
Apprentice
Apprentice


Joined: 22 Mar 2004
Posts: 249
Location: Brusssels

PostPosted: Mon Dec 31, 2007 11:27 am    Post subject: Reply with quote

excellent ca marche....
Merci
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Mon Dec 31, 2007 11:50 am    Post subject: Reply with quote

N'oublie pas le (résolu) ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum