Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Mis a jour] Portage blocqué......Car trop ancien
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
zoltix
Apprentice
Apprentice


Joined: 22 Mar 2004
Posts: 249
Location: Brusssels

PostPosted: Sat Dec 29, 2007 9:50 pm    Post subject: [Mis a jour] Portage blocqué......Car trop ancien Reply with quote

Hello,
Cela fait presque un ans que je n'ai pas mis a jour ma gentoo,
mais je viens de lancer la commande
Code:

emerge --sync
emerge --update --deep --world

et j'ai eu quelques soucis et puis j'ai eu

Code:


freeman portage # emerge -puvDn world

These are the packages that would be merged, in order:

Calculating world dependencies |
!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
media-plugins/gst-plugins-v4l x11-themes/gdm-themes dev-db/mysql-administrator m
edia-sound/amp app-emulation/xwine net-firewall/firestarter media-video/avidemux
 x11-themes/nautilus-themes net-p2p/xmule net-im/gaim dev-db/mysql-query-browser
 app-admin/gnomesu

... done!
[blocks B     ] <dev-lang/python-2.3.6-r2 (is blocking app-admin/python-updater-
0.2)

[blocks B     ] <media-libs/fontconfig-2.3.2-r2 (is blocking media-libs/freetype
-2.3.5-r2)
[blocks B     ] <sys-apps/dbus-0.91 (is blocking sys-apps/dbus-1.0.2-r2)
[blocks B     ] =sys-libs/glibc-2.4* (is blocking sys-auth/consolekit-0.2.3)
[blocks B     ] sys-apps/coldplug (is blocking sys-fs/udev-115-r1)
[blocks B     ] <sys-fs/device-mapper-1.02.19-r1 (is blocking sys-fs/udev-115-r1
)
[blocks B     ] <sys-fs/udev-115-r1 (is blocking sys-fs/device-mapper-1.02.22-r5
)
[blocks B     ] <dev-python/pygtk-2.9 (is blocking dev-python/pygobject-2.14.0)
[blocks B     ] <app-text/scrollkeeper-9999 (is blocking app-text/rarian-0.6.0-r
1)
[blocks B     ] <=app-crypt/gnupg-2.0.1 (is blocking app-crypt/gnupg-2.0.7)
[blocks B     ] =app-dicts/aspell-en-0.5* (is blocking app-text/aspell-0.60.5)
[blocks B     ] <www-servers/apache-2.2.4 (is blocking app-admin/apache-tools-2.
2.6)
[blocks B     ] <dev-java/ant-1.7.0 (is blocking dev-java/ant-core-1.7.0)
[blocks B     ] >=sys-fs/udev-089 (is blocking sys-apps/coldplug-20040920-r1)
[blocks B     ] kde-base/kde-env (is blocking kde-base/kdelibs-3.5.7-r3)
[ebuild     U ] sys-libs/gpm-1.20.1-r6 [1.20.1-r5] USE="(-selinux)" 8 kB
[ebuild     U ] sys-libs/ncurses-5.6-r2 [5.5-r3] USE="gpm unicode -bootstrap -build -debug -doc -minimal -no
cxx -profile% -trace" 2,352 kB
[ebuild     U ] app-shells/bash-3.2_p17-r1 [3.1_p17] USE="nls -afs -bashlogger -plugins% -vanilla" 2,521 kB
[ebuild     U ] sys-apps/sandbox-1.2.18.1-r2 [1.2.17] 231 kB
[ebuild     U ] sys-libs/readline-5.2_p7 [5.1_p4] 2,007 kB
[ebuild     U ] dev-libs/expat-2.0.1 [1.95.8] USE="(-test%)" 435 kB
[ebuild     U ] sys-devel/gettext-0.17 [0.15] USE="nls -doc -emacs -nocxx" 11,368 kB
[ebuild     U ] sys-apps/texinfo-4.8-r5 [4.8-r2] USE="nls -build -static" 1,486 kB
............



J'ai voulu esseyer de les désinstaller mais j'ai vite vu que c'etais des portages du system car j'ai eu un autre message


Code:

!! 'dev-lang/python' is part of your system profile.
!!! Unmerging it may be damaging to your system.

>>> Waiting 10 seconds before starting...
>>> (Control-C to abort)...
Press Ctrl-C to Stop in: 10 9 8 7 6



Que puis je faire pour la mettre a jour?

Merci d'avance de votre aide....

Bonne nuit...
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Sat Dec 29, 2007 10:16 pm    Post subject: Reply with quote

Peut-être mettre à jour python directement ? emerge -u python
pense à mettre à jour les profils aussi.
Back to top
View user's profile Send private message
zoltix
Apprentice
Apprentice


Joined: 22 Mar 2004
Posts: 249
Location: Brusssels

PostPosted: Sat Dec 29, 2007 10:45 pm    Post subject: Reply with quote

j'ai tout cassé..........python ne marche plus.....donc je n'ai plus d'emerge.........
Que dois faire ?
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sat Dec 29, 2007 10:53 pm    Post subject: Reply with quote

Tu peux retenter de réinstaller Python en utilisant un paquet précompilé : http://tinderbox.x86.dev.gentoo.org/default-linux/x86/dev-lang/python-2.4.4-r6.tbz2

Mais vu au point où tu en es, ça sera beaucoup plus simple de partir de zéro et de refaire une installation complète.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
zoltix
Apprentice
Apprentice


Joined: 22 Mar 2004
Posts: 249
Location: Brusssels

PostPosted: Sat Dec 29, 2007 11:56 pm    Post subject: Reply with quote

J'avance doucement mais je n'ai pas envie de réinstaller pour mieux apprendre avec votre aide.
mais maintenant j'ai une autre erreur .......mais commen je ne sais pas bien utiliser chmod...Peut être pourriez vous m'aider...
Code:

bash: /usr/bin/emerge: /usr/bin/python: bad interpreter: Permission denied
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Sun Dec 30, 2007 3:10 pm    Post subject: Reply with quote

Code:
temet@gentop ~ $ ls -l /usr/bin/pyt*
lrwxrwxrwx 1 root root    9 nov 10 00:28 /usr/bin/python -> python2.4
lrwxrwxrwx 1 root root    9 nov 10 00:28 /usr/bin/python2 -> python2.4
-rwxr-xr-x 1 root root 6860 nov 10 00:28 /usr/bin/python2.4


Tape la même commande pour voir.
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum