Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200712-21 ] Mozilla Firefox, SeaMonkey: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Sat Dec 29, 2007 7:26 pm    Post subject: [ GLSA 200712-21 ] Mozilla Firefox, SeaMonkey: Multiple vuln Reply with quote

Gentoo Linux Security Advisory

Title: Mozilla Firefox, SeaMonkey: Multiple vulnerabilities (GLSA 200712-21)
Severity: normal
Exploitable: remote
Date: December 29, 2007
Bug(s): #198965, #200909
ID: 200712-21

Synopsis

Multiple vulnerabilities have been discovered in Mozilla Firefox and Mozilla Seamonkey.

Background

Mozilla Firefox is a cross-platform web browser from Mozilla. SeaMonkey is a free, cross-platform Internet suite.

Affected Packages

Package: www-client/mozilla-firefox
Vulnerable: < 2.0.0.11
Unaffected: >= 2.0.0.11
Architectures: All supported architectures

Package: www-client/mozilla-firefox-bin
Vulnerable: < 2.0.0.11
Unaffected: >= 2.0.0.11
Architectures: All supported architectures

Package: www-client/seamonkey
Vulnerable: < 1.1.7
Unaffected: >= 1.1.7
Architectures: All supported architectures

Package: www-client/seamonkey-bin
Vulnerable: < 1.1.7
Unaffected: >= 1.1.7
Architectures: All supported architectures


Description

Jesse Ruderman and Petko D. Petkov reported that the jar protocol handler in Mozilla Firefox and Seamonkey does not properly check MIME types (CVE-2007-5947). Gregory Fleischer reported that the window.location property can be used to generate a fake HTTP Referer (CVE-2007-5960). Multiple memory errors have also been reported (CVE-2007-5959).

Impact

A remote attacker could possibly exploit these vulnerabilities to execute arbitrary code in the context of the browser and conduct Cross-Site-Scripting or Cross-Site Request Forgery attacks.

Workaround

There is no known workaround at this time.

Resolution

All Mozilla Firefox users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-2.0.0.11"
All Mozilla Firefox binary users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-bin-2.0.0.11"
All SeaMonkey users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/seamonkey-1.1.7"
All SeaMonkey binary users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/seamonkey-bin-1.1.7"


References

CVE-2007-5947
CVE-2007-5959
CVE-2007-5960


Last edited by GLSA on Sat Jan 03, 2009 4:18 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum