Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] USB pen drive non riconosciuta
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Realnot
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2007
Posts: 120
Location: Ferrara

PostPosted: Fri Dec 28, 2007 2:15 pm    Post subject: [Risolto] USB pen drive non riconosciuta Reply with quote

Salve ragazzi, ormai è un po di tempo che provo, ma non riesco proprio a montare la penna usb da 1 gb non capisco dove devo montarla... su kde faccio:
tasto destro -> crea -> collegamento a dispositivo -> dispositivo macchina fotografica, usb etc... nella finestra che compare clicco su dispositivo e compaiono i vari percorsi che posso settare:

shm (/dev/shm) <-- non ho la più pallida idea di cosa sia...
proc (/proc)
dev/cdrom (/mnt/cdrom)
dev/hda3 (/)
dev/hda1 (/boot)

Comunque lasciando stare kde... ho seguito la guida: http://www.gentoo.org/doc/it/usb-guide.xml, ma nulla da fare... qui pasto l'url dell'output con la penna usb inserita: http://phpfi.com/285636

la cosa che mi ha lasciato perplesso è sda: sda: unknown partition table non lo trova, è sconosciuto :( no so proprio come fare... io vorrei accedere alla mia penna usb cliccando semplicemente l'icona del dispositivo che ho creato sul desktop...

localhost ~ # mount /dev/sda1 /mnt/usb
mount: special device /dev/sda1 does not exist
localhost ~ # df -h
Filesystem Size Used Avail Use% Mounted on
/dev/hda3 367G 7.3G 341G 3% /
udev 1007M 2.7M 1004M 1% /dev
shm 1007M 0 1007M 0% /dev/shm
/dev/hda1 92M 4.5M 82M 6% /mnt/usb
localhost ~ #

poi ho chiesto ad un amico, mi ha detto che devo emergere HAL ed udev, hal non posso emergerlo per il seguente motivo...

localhost ~ # emerge sys-apps/hal
Calculating dependencies... done!

!!! Error: the <sys-fs/udev-115-r1 package conflicts with another package;
!!! the two packages cannot be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

localhost ~ # emerge sys-apps/hal --pretend

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] sys-fs/device-mapper-1.02.22-r5 USE="(-selinux)"
[ebuild N ] sys-apps/dbus-1.0.2-r2 USE="-X -debug -doc (-selinux)"
[ebuild N ] sys-apps/dmidecode-2.9
[ebuild N ] sys-fs/cryptsetup-1.0.5-r1 USE="nls -build -dynamic (-selinux)"
[ebuild N ] dev-libs/dbus-glib-0.73 USE="-debug -doc (-selinux)"
[ebuild N ] sys-apps/hal-0.5.9.1-r3 USE="crypt -acpi -debug -dell -disk-partition -doc -pcmcia (-selinux)"
[ebuild N ] app-misc/hal-info-20070618
[blocks B ] <sys-fs/udev-115-r1 (is blocking sys-fs/device-mapper-1.02.22-r5)

successivamente ho emerso udev...

Grazie mille
_________________
I'm not stupid, only mentally free...


Last edited by Realnot on Fri Dec 28, 2007 6:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
Flameeyes
Retired Dev
Retired Dev


Joined: 30 Mar 2005
Posts: 187
Location: Dublin, Ireland

PostPosted: Fri Dec 28, 2007 2:35 pm    Post subject: Re: USB pen drive non riconosciuta Reply with quote

Realnot wrote:
Salve ragazzi, ormai è un po di tempo che provo, ma non riesco proprio a montare la penna usb da 1 gb non capisco dove devo montarla... su kde faccio:
tasto destro -> crea -> collegamento a dispositivo -> dispositivo macchina fotografica, usb etc... nella finestra che compare clicco su dispositivo e compaiono i vari percorsi che posso settare:


Lascia perdere crea collegamento a dispositivo, quel che vuoi è usare media:/, ricompila kdebase-kioslaves con la USE hal abilitata (o kdebase se non usi le split ebuilds)..

Realnot wrote:
localhost ~ # mount /dev/sda1 /mnt/usb
mount: special device /dev/sda1 does not exist


Come il dmesg ti dice, la chiavetta è sda, non è partizionata, quindi è /dev/sda che vuoi, non /dev/sda1.

Realnot wrote:
successivamente ho emerso udev...


Hai aggiornato udev suppongo, visto che udev è parte del sistema base di Gentoo ormai da un paio d'anni, quindi senza non potevi stare. Ora riprova a installare HAL e come per magia lo potrai fare...
_________________
You want to know what I'm working on right now? Just follow my blog.
Back to top
View user's profile Send private message
Realnot
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2007
Posts: 120
Location: Ferrara

PostPosted: Fri Dec 28, 2007 3:16 pm    Post subject: Reply with quote

Grazie mille, ho fatto tutto quello che hai detto, ma quando vado a dare

localhost realnot # mount /dev/sda /mnt/usb
mount: you must specify the filesystem type

vuole il filesystem... il comando è lo stesso che ho trovato nell'handbook per dare il filesystem alle partizioni vero? cmq che filesystem devo dare a /dev/sda?
_________________
I'm not stupid, only mentally free...
Back to top
View user's profile Send private message
!ico
Apprentice
Apprentice


Joined: 26 Oct 2005
Posts: 199
Location: Bassano del Grappa (VI)

PostPosted: Fri Dec 28, 2007 3:31 pm    Post subject: Reply with quote

prova con:
Code:

mount -t auto /dev/sda /mnt/usb


comunque solitamente funziona anche con un -t vfat.

ola ;)
_________________
" I tasti iniziano. I tasti finiscono. Tu sai che sono 88; su questo nessuno può fregarti. Non sono infiniti loro. Tu, tu sei infinito, e dentro quei tasti, infinita è la musica che puoi fare. Loro sono 88. Tu sei infinito".
Novecento (Baricco)
Back to top
View user's profile Send private message
Realnot
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2007
Posts: 120
Location: Ferrara

PostPosted: Fri Dec 28, 2007 3:39 pm    Post subject: Reply with quote

l'output di entrambi i comandi è questo:

localhost realnot # mount -t auto /dev/sda /mnt/usb
mount: you must specify the filesystem type
localhost realnot # mount -t vfat /dev/sda /mnt/usb
mount: wrong fs type, bad option, bad superblock on /dev/sda,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

localhost realnot #
_________________
I'm not stupid, only mentally free...
Back to top
View user's profile Send private message
!ico
Apprentice
Apprentice


Joined: 26 Oct 2005
Posts: 199
Location: Bassano del Grappa (VI)

PostPosted: Fri Dec 28, 2007 3:57 pm    Post subject: Reply with quote

questo vuol dire:
1) che non lo riconosce da solo
2) che non usa vfat
3) che devi cercare in giro che fs usa la tua penna usb (istruzioni? internet?)
4) che non sono sicuro dell'esattezza miei consigli

ola ;)
_________________
" I tasti iniziano. I tasti finiscono. Tu sai che sono 88; su questo nessuno può fregarti. Non sono infiniti loro. Tu, tu sei infinito, e dentro quei tasti, infinita è la musica che puoi fare. Loro sono 88. Tu sei infinito".
Novecento (Baricco)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Dec 28, 2007 4:00 pm    Post subject: Reply with quote

Se è una vecchia pendrive è probabile che sia stata partizionata come partizione estesa della quarta primaria ( serviva per winzozz 98 )
fdisk -l cosa riporta?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Realnot
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2007
Posts: 120
Location: Ferrara

PostPosted: Fri Dec 28, 2007 4:17 pm    Post subject: Reply with quote

no, la chiavetta usb è nuova, ieri ho comprato stampante, audio 2.1 e chiavetta usb, sto cercando di configurare il tutto ma non è semplice, ho sempre dei probl :( cmq questo è l'output di fdisk -l

Disk /dev/hda: 400.0 GB, 400088457216 bytes
255 heads, 63 sectors/track, 48641 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 12 96358+ 83 Linux
/dev/hda2 13 74 498015 82 Linux swap / Solaris
/dev/hda3 75 48641 390114427+ 83 Linux

Disk /dev/sda: 2199.0 GB, 2199023255040 bytes
255 heads, 63 sectors/track, 267349 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/sda doesn't contain a valid partition table
_________________
I'm not stupid, only mentally free...
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Dec 28, 2007 4:25 pm    Post subject: Reply with quote

Realnot wrote:
Disk /dev/sda doesn't contain a valid partition table

questo risponde a tutto. Se non la hai ancora usata vuol dire che non è formattata o è difettosa/usata (in genere sono sempre preformattate, mi pare molto sospetto).
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Realnot
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2007
Posts: 120
Location: Ferrara

PostPosted: Fri Dec 28, 2007 4:28 pm    Post subject: Reply with quote

uhm.. e quindi ora cosa posso fare? vero non ho mai usato la chiavetta usb? formattata? la metto sul pc windows metto un paio di file dentro e riprovo?
_________________
I'm not stupid, only mentally free...
Back to top
View user's profile Send private message
Realnot
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2007
Posts: 120
Location: Ferrara

PostPosted: Fri Dec 28, 2007 4:33 pm    Post subject: Reply with quote

ho inserito la chiavetta sull'altro pc, windows mi ha chiesto se voglio formattare il disco, gli ho detto di si
_________________
I'm not stupid, only mentally free...
Back to top
View user's profile Send private message
Realnot
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2007
Posts: 120
Location: Ferrara

PostPosted: Fri Dec 28, 2007 4:46 pm    Post subject: Reply with quote

localhost realnot # fdisk -l
ora l'output di fdisk -l è questo... sembra tutto ok?
Disk /dev/hda: 400.0 GB, 400088457216 bytes
255 heads, 63 sectors/track, 48641 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 12 96358+ 83 Linux
/dev/hda2 13 74 498015 82 Linux swap / Solaris
/dev/hda3 75 48641 390114427+ 83 Linux

Disk /dev/sda: 1030 MB, 1030749696 bytes
32 heads, 63 sectors/track, 998 cylinders
Units = cylinders of 2016 * 512 = 1032192 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 999 1006560 6 FAT16
Partition 1 has different physical/logical endings:
phys=(997, 31, 63) logical=(998, 19, 18)
_________________
I'm not stupid, only mentally free...
Back to top
View user's profile Send private message
!ico
Apprentice
Apprentice


Joined: 26 Oct 2005
Posts: 199
Location: Bassano del Grappa (VI)

PostPosted: Fri Dec 28, 2007 4:51 pm    Post subject: Reply with quote

si, ora la puoi montare con vfat come scritto sopra.
NB: invece di fare 3 post in 10 minuti, modificalo con le varie aggiunte..

ola ;)
_________________
" I tasti iniziano. I tasti finiscono. Tu sai che sono 88; su questo nessuno può fregarti. Non sono infiniti loro. Tu, tu sei infinito, e dentro quei tasti, infinita è la musica che puoi fare. Loro sono 88. Tu sei infinito".
Novecento (Baricco)
Back to top
View user's profile Send private message
Realnot
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2007
Posts: 120
Location: Ferrara

PostPosted: Fri Dec 28, 2007 5:00 pm    Post subject: Reply with quote

ci sono riuscito :) ho dato il filesystem alla perferica come hai detto tu... mount vfat bla bla poi mi è comparsa una finestra hotplug che mi ha riconosciuto la chiave, poi mi sono spostato in /etc/fstab ed ho creato la seguente riga:

/dev/sda1 /mnt/usb vfat auto 0 1

in fine ho creato l'icona ed ho selezionato il percorso /dev/sda1, ora funziona tutto alla perfezione, grazie per il supporto... ora il bello arriva con l'audio e la stampante... lol vabbè, grazie ancora a tutti quanti per la disponibilità ;)
_________________
I'm not stupid, only mentally free...
Back to top
View user's profile Send private message
!ico
Apprentice
Apprentice


Joined: 26 Oct 2005
Posts: 199
Location: Bassano del Grappa (VI)

PostPosted: Fri Dec 28, 2007 5:04 pm    Post subject: Reply with quote

prego, aggiungi il tag Risolto al titolo modificando il primo post.
ola ;)
_________________
" I tasti iniziano. I tasti finiscono. Tu sai che sono 88; su questo nessuno può fregarti. Non sono infiniti loro. Tu, tu sei infinito, e dentro quei tasti, infinita è la musica che puoi fare. Loro sono 88. Tu sei infinito".
Novecento (Baricco)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Dec 28, 2007 5:23 pm    Post subject: Reply with quote

Realnot wrote:
/dev/sda1 /mnt/usb vfat auto 0 1
al massimo è "defaults" non "auto" e ti conviene viso che è vfat usare il devicxe mapper e quindi /dev/disk/by-label/comesichiama oltre al fatto che non si mette mai un device rimovibile in mount automatico, avrai errori al boot, forse era "noauto".
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum