Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ALSA] messages d'erreurs au démarrage
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
KageBunshinNoGentoo
Tux's lil' helper
Tux's lil' helper


Joined: 15 Dec 2006
Posts: 125

PostPosted: Fri Dec 28, 2007 8:40 am    Post subject: [ALSA] messages d'erreurs au démarrage Reply with quote

Salut à tous,

Je pense avoir un conflit entre le module et le driver implémenté dans le noyau mais je ne vois vraiment pas comment procéder.

Quote:

/etc/init.d/alsasound restart
* WARNING: you are stopping a boot service.
* Storing ALSA Mixer Levels ... [ ok ]
* Killing processes using ALSA ... [ ok ]
* Unloading ALSA modules ... [ ok ]
* Loading ALSA modules ...
* Loading: snd-card-0 ...
WARNING: Error inserting snd_page_alloc (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/snd-page-alloc.ko): Invalid module format
WARNING: Error inserting snd (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/snd.ko): Invalid module format
WARNING: Error inserting snd_timer (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/snd-pcm.ko): Invalid module format [ ok ]
* Loading: snd-mixer-oss ...
WARNING: Error inserting snd (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/snd.ko): Invalid module format
FATAL: Error inserting snd_mixer_oss (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/oss/snd-mixer-oss.ko): Unknown symbol in module, or unknown parameter (see dmesg) [ !! ]
* Loading: snd-pcm-oss ...
WARNING: Error inserting snd (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/snd.ko): Invalid module format
WARNING: Error inserting snd_mixer_oss (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/oss/snd-mixer-oss.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_page_alloc (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/snd-page-alloc.ko): Invalid module format
WARNING: Error inserting snd_timer (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/snd-pcm.ko): Invalid module format
FATAL: Error inserting snd_pcm_oss (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/oss/snd-pcm-oss.ko): Unknown symbol in module, or unknown parameter (see dmesg) [ !! ]
* Loading: snd-seq ...
WARNING: Error inserting snd (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/snd.ko): Invalid module format
WARNING: Error inserting snd_timer (/lib/modules/2.6.23-gentoo-r3/kernel/sound/core/snd-timer.ko): Unknown symbol in module, or unknown parameter (see d [ ok ]
* Restoring Mixer Levels ... [ ok ]


Pouvez vous me mettre sur la voie svp?
Merci
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Fri Dec 28, 2007 8:47 am    Post subject: Reply with quote

Bah t'as mis celui du noyau ou celui de portage?
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Fri Dec 28, 2007 8:55 am    Post subject: Reply with quote

Si ce sont ceux du noyau, un petit make clean dans les sources du noyau et rm -rf /lib/modules/2.6.23-gentoo-r3/ pour nettoyer tout ça.
Ensuite recompile ton noyau et tes modules pour les réinstaller proprement.

Si ce sont ceux de l'ebuild alsa-driver, rm -rf /lib/modules/2.6.23-gentoo-r3/ et utilise ceux du noyau.
Ensuite recompile tes modules (ainsi que ceux pour ALSA) pour les réinstaller proprement.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
darkangel92
Apprentice
Apprentice


Joined: 19 Nov 2006
Posts: 202

PostPosted: Fri Dec 28, 2007 11:11 am    Post subject: Reply with quote

et pis un ch'tit update-module :wink:
_________________
Gigabyte P35 DS4 Rev 2.0 Bios F14C, Q6600 GO 2,4GHZ@3,6GHz (8*450MHz) , 2Go PC6400 GSKILLS PK , GeForce 8600 GT 512Mo
Sonata III 500W, 2 MAxtor DD SATA II, 1 WD Velociraptor 300Go, WIFI Hercules (RT61)
Gentoo 64 bits, KUbuntu 64 bits, Win XP Pro 32 bits
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum